Se produce una pérdida de memoria cuando se utiliza la API de WinINet en una aplicación para enviar las peticiones HTTPS a un servidor

Seleccione idioma Seleccione idioma
Id. de artículo: 2437070 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Se utiliza Windows Internet (WinINet) API en una aplicación para enviar el protocolo de transferencia de hipertexto a través de las solicitudes de la capa de sockets seguro (HTTPS) a un servidor. En esta situación, el uso de memoria de la aplicación aumenta continuamente. Esto indica que hay una pérdida de memoria.

NotaEste problema sólo afecta a las peticiones HTTPS.

Causa

Este problema se produce debido a un error en la API de WinINet. Cuando la aplicación establece una conexión mediante el envío de solicitudes HTTPS para el servidor, WinINet asigna 85 bytes para cada solicitud. Sin embargo, no se liberan a 85 bytes para cada solicitud después de establecer la conexión. Por lo tanto, se produce una pérdida de memoria de 85 bytes por solicitud.

Solución

Información de la actualización de seguridad

Para resolver este problema, instale la actualización de seguridad acumulativa más reciente para Windows Internet Explorer. Para ello, visite el siguiente sitio Web de Microsoft:
http://windowsupdate.Microsoft.com
Para obtener más información técnica acerca de la actualización de seguridad acumulativa más reciente para Windows Internet Explorer, visite el siguiente sitio Web de Microsoft:
http://www.Microsoft.com/TechNet/Security/Current.aspx
NotaEsta actualización se incluyó primero en la actualización de seguridad 2416400 (MS10-090).
2416400MS10-090: Actualización de seguridad acumulativa para Internet Explorer

Más información

Para obtener más información acerca de la API de WinINet, visite el siguiente sitio Web de Microsoft Developer Network (MSDN):
Información general acerca de la API de WinINet

Propiedades

Id. de artículo: 2437070 - Última revisión: martes, 14 de diciembre de 2010 - Versión: 1.0
La información de este artículo se refiere a:
  • Microsoft Internet Explorer 6.0
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
Palabras clave: 
kbprb kbsurveynew kbexpertisebeginner kbexpertiseinter kbmt KB2437070 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2437070

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com