O roteamento não funciona quando múltiplos adaptadores utilizam simultaneamente o endereçamento de IP particular

Traduções deste artigo Traduções deste artigo
ID do artigo: 244268 - Exibir os produtos aos quais esse artigo se aplica.
IMPORTANTE: Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça backup do Registro e verifique se entendeu como restaurá-lo caso ocorra algum problema. Para obter mais informações sobre como fazer backup, restaurar e editar o Registro, clique no número de artigo abaixo para consultá-lo na Base de Dados de Conhecimento da Microsoft:
256986 Descrição do Registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando mais de um adaptador de rede no computador com hospedagem múltipla com base no Windows utiliza um protocolo TCP/IP a partir do intervalo de sub-rede do endereçamento automático de IP particular (APIPA) 169.254.0.0-169.254.255.255, a máscara de sub-rede 255.255.0.0 e o roteamento para essa sub-rede podem não funcionar caso ambas as condições a seguir existam:
  • Os adaptadores configurados de rede APIPA foram conectados à redes físicas diferentes.
  • Os adaptadores configurados de rede APIPA utilizam simultaneamente endereços a partir da sub-rede APIPA.

Causa

Esse problema ocorre porque o roteamento TCP/IP requer que todos os adaptadores de rede com um endereço TCP/IP com mesma sub-rede estejam na mesma rede física. Devido a esse fato, o roteamento não funciona caso os adaptadores múltiplos de rede utilizem ao mesmo tempo no mesmo computador os endereços a partir da sub-rede APIPA.

Resolução

AVISO: Caso utilize o Editor do Registro incorretamente, isso pode causar sérios problemas que exigirão que você reinstale o sistema operacional. A Microsoft não garante que seja possível resolver os problemas decorrentes do uso inadequado do Editor de Registro. Utilize-o por conta própria.

Para solucionar esse problema, não ative ao mesmo tempo o APIPA em mais de um adaptador de rede no computador.

Para impedir a ocorrência desse comportamento, utilize o método apropriado. OBSERVAÇÃO: Para concluir esse procedimento, faça logon no domínio do Windows utilizando as credenciais do administrador, ou o domínio da conta deve ser de um membro do grupo dos administradores.

Desative o APIPA em todos exceto em um Adaptador de rede

  1. Uitlize o Editor de Registro para criar a chave de registro a seguir, na qualo nome do adaptador é o nome do adaptador DHCP no qual deseja desativar o DHCP (Dynamic Host Configuration Protocol):
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters\Interfaces\nome do adaptador
  2. Adicione o valor a seguir a essa chave:
    Nome de valor: AutoconfiguraçãoAtivadaIP
    Tipo de valor: REG_DWORD
    Valor em hexadecimal: 0 (A valor de 0 desativa o suporte APIPA nesse adaptador)
    OBSERVAÇÃO: Caso a entrada da AutoconfiguraçãoAtivadaIP não esteja presente, um valor padrão de 1 é deduzido, o que indica que o APIPA foi ativado.

  3. Após fazer essa alteração, reinicie o computador.

Desative o APIPA no Computador Inteiro

  1. Uitlize o Editor de Registro para criar a chave de Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  2. Adicione o valor a seguir a essa chave:
    Nome de valor: AutoconfiguraçãoAtivadaIP
    Tipo de valor: REG_DWORD
    Valor em hexadecimal: 0 (A valor de 0 desativa o suporte do APIPA nesse computador)
    OBSERVAÇÃO: Caso a entrada da AutoconfiguraçãoAtivadaIP não esteja presente, um valor padrão de 1 é deduzido, o que indica que o APIPA foi ativado.

  3. Após fazer essa alteração, reinicie o computador.
Caso o roteamento ainda não esteja funcionando corretamente, talvez tenha de reparar a conexão:
  1. Clique com botão direito do mouse no ícone de conexão LAN em conexões de rede e, em seguida, em Status.
  2. Clique na guia Suporte e no botão Reparar.
  3. Caso receba a mensagem a seguir, clique em OK para fechar caixa de mensagem Reparar conexão e teste novamente a conexão LAN para a funcionalidade de roteamento básico entre as rede físicas diferentes que estão conectadas ao computador:
    Falha nas seguintes etapas da operação de reparo: Renovando o endereço de IP. Contate o administrador de rede ou o ISP

Mais Informações

A lista a seguir inclui os cenários que podem resultar na utilização do adaptador de endereço TCP/IP a partir de um espaço de endereço APIPA:

Utilize o APIPA em um adaptador e um DHCP em outro adaptador

Uma das condições a seguir podem gerar esse comportamento:
  • O adpatador configurado DHCP não tem um endereço de aTCP/IP ao iniciar o computador e não é possível localizar um servidor DHCP.
  • O adaptador configurado DHCP não pode localizar um servidor DHCP para renovar a concessão do DHCP e não recebe resposta quando o comando ping é efetuado no gateway padrão.

Utilize o DHCP em mais de um adaptador

Uma das condições a seguir podem gerar esse comportamento:
  • Os adaptadores configurados DHCP não têm um endereço de TCP/IP ao iniciar o computador e não podem localizar um servidor DHCP.
  • O adaptador configurado DHCP não pode localizar um servidor DHCP para renovar a concessão do DHCP e não recebe resposta quando o comando ping é aplicado no gateway padrão. Esse problema ocorre somente se em qualquer momento mais de um adaptador estiver simultaneamente utilizando um endereço de TCP/IP a partir de uma sub-rede APIPA.
OBSERVAÇÃO: Um adaptador configurado DHCP utiliza um endereço de TCP/IP a partir de uma sub-rede APIPA que continua na tentativa de localizar um servidor DHCP a cada cinco minutos. Caso seja possível localizar um servidor DHCP, utilize o endereço de TCP/IP fornecido pelo servidor DHCP.

Propriedades

ID do artigo: 244268 - Última revisão: terça-feira, 11 de maio de 2004 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
Palavras-chave: 
kbnetwork kbprb KB244268

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com