Smerovanie nefunguje pri viacerých adaptéry použitie Automatic Private IP Addressing súčasne

Preklady článku Preklady článku
ID článku: 244268 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

Na tejto stránke

PRIZNAKY

Keď viac ako jeden sieťový adaptér v počítači so systémom Windows viaceré podsiete používa Transport Control Protocol/Internet Protocol (TCP/IP) adresu z 169.254.0.0-169.254.255.255 masku podsiete 255.255.0.0, rozsah podsiete riešenie APIPA (Automatic Private IP ADDRESSING) smerovanie k tejto podsieti nemusia fungovať, ak existujú obe nasledujúce podmienky:
  • APIPA nakonfigurovaný sieťové adaptéry sú pripojené na rozdielnych fyzických sieťach.
  • Sieťové adaptéry APIPA nakonfigurovaný súčasne používať adresy z APIPA podsiete.

PRICINA

Tento problém sa vyskytuje, pretože TCP/IP smerovanie vyžaduje, aby všetky sieťové adaptéry s adresy TCP/IP z rovnakej podsieti v rovnakej fyzickej sieti. Z tohto dôvodu smerovanie nefunguje ak viacero sieťových adaptérov na rovnakom počítači používať adresy z APIPA podsiete v rovnakom čase.

RIESENIE

Dôležité upozornenie Tento oddiel, metóda alebo úloha obsahuje kroky, ktoré vám povedať, ako upraviť databázu registry. Ak databázu Registry upravíte nesprávne, môžu nastať vážne problémy. Preto dávajte pozor a postupujte presne podľa týchto krokov. Na dosiahnutie lepšej ochrany je vhodné pred úpravou databázu Registry zálohovať. To vám umožní obnoviť databázu Registry, ak sa vyskytnú problémy. Ďalšie informácie o zálohovaní a obnovení databázy Registry nájdete v nasledujúcom článku databázy Microsoft Knowledge Base:
322756 Zálohovanie a obnovovanie databázy Registry v systéme Windows

Chcete tento problém obísť, musíte nie APIPA na viac ako jeden sieťový adaptér v počítači zapnutá v rovnakom čase.

Na zabránenie vzniku toto správanie, použite vhodnú metódu.POZNÁMKA: Ak chcete dokončiť tento postup, musíte sa prihlásiť pomocou poverení správcu domény Windows, alebo konto domény, musíte byť členom skupiny administrators.

Vypnúť APIPA pre všetky, ale jeden sieťový adaptér

  1. Použite Editor databázy Registry vytvorte nasledovný kľúč databázy registry, kde názov adaptéra Ak chcete vypnúť APIPA je názov konfigurácie protokolu DHCP (Dynamic Host) nakonfigurovaný adaptér:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\Tcpip\Parameters\Interfaces\názov adaptéra
  2. Pridajte nasledujúcu hodnotu pre tento kľúč:
    Názov hodnoty: premennej IPAutoconfigurationEnabled
    Typ hodnoty: REG_DWORD
    Hodnoty v šestnástkovom formáte: 0 (hodnota 0 vypne APIPA podporu na tomto adaptéri)
    POZNÁMKA: Ak premennej IPAutoconfigurationEnabled položka nie je prítomný, predpokladá sa predvolená hodnota 1, čo naznačuje, že je zapnuté APIPA.

  3. Po vykonaní tejto zmeny, reštartujte počítač.

Vypnúť APIPA na celý počítač

  1. Použite Editor databázy Registry vytvorte nasledovný kľúč databázy registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters
  2. Pridajte nasledujúcu hodnotu pre tento kľúč:
    Názov hodnoty: premennej IPAutoconfigurationEnabled
    Typ hodnoty: REG_DWORD
    Hodnoty v šestnástkovom formáte: 0 (hodnota 0 vypne APIPA podporu na tomto počítači)
    POZNÁMKA: Ak premennej IPAutoconfigurationEnabled položka nie je prítomný, predpokladá sa predvolená hodnota 1, čo naznačuje, že je zapnuté APIPA.

  3. Po vykonaní tejto zmeny, reštartujte počítač.
Ak smerovania stále nepracuje správne, možno budete musieť opraviť pripojenie:
  1. Kliknite pravým tlačidlom myši Pripojenie siete LAN Ikona Sieťové pripojenia a potom kliknite na tlačidlo Stav.
  2. Kliknite na Podpora karte, kliknite na tlačidlo Opravy tlačidlo.
  3. Ak sa zobrazí nasledovné hlásenie, kliknite na ok zavriete okno hlásenia opravy pripojenie a pripojenie LAN na základné smerovania funkcie medzi rozdielnych fyzických sieťach, ktoré sú pripojené k počítaču na opakovanie testu:
    Nasledovné kroky opravy operácia zlyhala: Obnovenie adresy IP. Obráťte sa na správcu siete alebo poskytovateľa internetových služieb

DALSIE INFORMACIE

Nasledujúci zoznam zahŕňa scenáre, ktoré môžu mať za následok adaptér pomocou adresy TCP/IP z priestoru adries APIPA:

Používate APIPA na jeden adaptér a DHCP na inom adaptéri

Buď z týchto podmienok môže generovať toto správanie:
  • DHCP nakonfigurovaný adaptér nemá adresu protokolu TCP/IP, po spustení počítača a nemôže nájsť DHCP server.
  • DHCP nakonfigurovaný adaptér je schopný lokalizovať servera DHCP obnoviť jeho prenájmu DHCP a nedostane žiadnu odpoveď, keď ping predvolenú bránu.

Používate DHCP na viac ako jeden adaptér

Buď z týchto podmienok môže generovať toto správanie:
  • DHCP nakonfigurovaný adaptéry nemajú adresu protokolu TCP/IP, keď spustíte počítač, a nie sú schopní nájsť DHCP server.
  • DHCP nakonfigurovaný adaptéry sú obaja nepodarilo sa nájsť server DHCP obnoviť ich prenájmu DHCP a obaja nezodpovedané keď ping predvolenú bránu. Tento problém sa vyskytuje len ak v danom čase viac adaptérov súčasne používa adresy TCP/IP z APIPA podsiete.
POZNÁMKA: Adaptér DHCP nakonfigurovaný pomocou adresy TCP/IP z APIPA podsiete naďalej pokus o vyhľadanie servera DHCP každých päť minút. Ak je schopný nájsť DHCP server, používa adresy TCP/IP poskytuje server DHCP.

Vlastnosti

ID článku: 244268 - Posledná kontrola: 23. októbra 2011 - Revízia: 3.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Kľúčové slová: 
kbnetwork kbprb kbmt KB244268 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem:244268

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com