Id. de artículo: 244435 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Resumen

Microsoft Excel sólo guarda la parte de cada hoja de cálculo que está en uso, lo que significa la sección que contiene datos o formato. A veces la última celda de una hoja de cálculo puede estar más allá del rango de datos utilizados realmente. Este problema puede hacer que tenga un tamaño de archivo mayor de lo necesario, que imprima páginas adicionales, que reciba mensajes de error "Memoria insuficiente" o que experimente otros comportamientos anómalos. El borrado de las filas y columnas sobrantes para restablecer la última celda puede ayudar a para resolver estos problemas.

Nota: puede buscar la última celda de la hoja de cálculo activa si presiona Ctrl+Mayús+Fin.

Más información

La causa más frecuente de que la última celda quede fuera del rango de la hoja de cálculo que está actualmente en uso es un formato excesivo. Cuando da formato a filas y columnas enteras, algunos tipos de formato pueden hacer que la última celda se establezca en una celda situada muy por debajo o a la derecha del rango real que está en uso.

Este problema también puede producirse cuando importa un archivo de Lotus 1-2-3 a Excel. Cuando guarda el archivo de Lotus en el formato de libro de Excel, Excel no puede determinar la última celda de la hoja de cálculo de Lotus 1-2-3. Por tanto, hace que toda la hoja de cálculo esté activa. Para restablecer la dirección de la última celda, puede utilizar cualquiera de los métodos siguientes para borrar la información innecesaria (datos y formato) de las columnas y filas no usadas de la hoja de cálculo. Después de quitar la información extraña, guarde la hoja para obligar a Excel a volver a generar la tabla de celdas activas.

Nota: cuando utiliza cualquiera de los métodos siguientes, puede recibir un mensaje de error "Memoria insuficiente" u otro similar. Esto se debe a que Excel intenta eliminar el rango seleccionado. Si recibe este mensaje de error, utilice rangos de filas o columnas menores al borrar datos.

Método 1: eliminar manualmente las filas y columnas sobrantes

Para restablecer la última celda eliminando manualmente las filas y columnas sobrantes, siga estos pasos:
  1. Seleccione todas las columnas situadas a la derecha de la última columna que contiene datos seleccionando los encabezados de columna adecuados.

    Sugerencia: una manera de hacerlo consiste en presionar F5 y escribir la referencia adecuada. Por ejemplo, escriba F:IV para las columnas o escriba 5:65536 para las filas.
  2. En el menú Edición, haga clic en Borrar todo.

    Nota: si este paso no borra todo el formato sobrante, quizás tenga que hacer clic con el botón secundario en las columnas y, a continuación, hacer clic en Eliminar para quitar totalmente las celdas. Si elimina celdas a las que hacen referencia fórmulas, la referencia cambiará a "¡#REF!". Por tanto, se recomienda que cree una copia de seguridad del archivo original y compruebe si las fórmulas contienen "¡#REF!" después de seguir estos pasos.
  3. Repita los pasos 1 y 2 para las filas que están debajo de la última fila que contiene datos.
  4. Guarde el archivo.
  5. Para seguir trabajando en el archivo, ciérrelo y vuelva a abrirlo.

Método 2: utilizar un complemento de Excel

Nota: el siguiente complemento de Excel sólo se aplica a la versión en inglés de Excel, no a las versiones en otros idiomas de Excel. Se recomienda que cambie el idioma en Excel antes de utilizar este complemento de Excel.

Ahora se puede descargar un complemento de Excel que quita el exceso de formato y restablece la última celda. Para descargar este complemento, visite el siguiente sitio web de Microsoft:
http://www.microsoft.com/downloads/details.aspx?FamilyId=ECFD076C-B873-48CC-B842-DA999C848C82&displaylang=en
  1. En la página de descarga, haga clic en el botón Descargar. Cuando se le pida, haga clic en Abrir o en Ejecutar.
  2. Cuando aparezca el contrato de licencia, haga clic en .
  3. Cuando aparezca el indicador de WinZip Self-Extractor, haga clic en el botón Examinar y seleccione la ubicación en la que desee extraer el complemento.

    Nota: puede poner el archivo en la ubicación de los complementos de Excel; en tal caso, aparecerá automáticamente en el cuadro de diálogo Complementos de Excel. Esa ubicación es la carpeta Library de la ubicación de instalación de Office. Normalmente, esta ubicación es la carpeta C:\Archivos de programa\Microsoft Office\Office\Library.

    Después de seleccionar la ubicación de descarga que desea en el cuadro de diálogo Examinar, haga clic en UnZip en el cuadro de diálogo WinZip. Haga clic en Aceptar en el indicador de descarga correcta y, a continuación, haga clic en Close en el cuadro de diálogo WinZip.
  4. Inicie Excel y siga estos pasos, según la versión de Excel que esté ejecutando.

    Microsoft Office Excel 2007

    1. Haga clic en el Botón de Microsoft Office y, a continuación, haga clic en Opciones de Excel.
    2. Haga clic en Complementos, haga clic en Complementos de Excel en el cuadro Administrar y, a continuación, haga clic en Ir.
    3. Si no guardó el archivo en la carpeta Library, haga clic en el botón Examinar, busque el archivo y selecciónelo en la ventana Examinar.
    4. Haga clic en Excess Format Cleaner 1.1 y, a continuación, haga clic en OK.

    Microsoft Office Excel 2003 y versiones anteriores de Excel

    1. Haga clic en Complementos en el menú Herramientas.
    2. Si no guardó el archivo en la carpeta Library, haga clic en el botón Examinar, busque el archivo y selecciónelo en la ventana Examinar.
    3. Haga clic en Excess Format Cleaner 1.1 y, a continuación, haga clic en OK.
  5. En Excel 2007, haga clic en la ficha Complementos y, a continuación, haga clic en Clear Excess Formats in XSFormatCleaner.xla en el grupo Comandos de menú.

    En Excel 2003 y en versiones anteriores de Excel, abra el libro que desee limpiar y haga clic en Clear Excess Formatting in libro en el menú Archivo. La macro borrará el exceso de formato de todas las hojas de cálculo del archivo.

    Cuando se complete la macro, se le informará de que debe guardar el libro para que los cambios sean permanentes.
  6. Guarde, cierre y vuelva a abrir el archivo.

Propiedades

Id. de artículo: 244435 - Última revisión: martes, 25 de marzo de 2008 - Versión: 6.0
La información de este artículo se refiere a:
  • Microsoft Office Excel 2007
  • Microsoft Office Excel 2003
  • Microsoft Excel 2002 Standard Edition
  • Microsoft Excel 2000 Standard Edition
  • Microsoft Excel 97 Standard Edition
Palabras clave: 
kbexpertisebeginner kbcode kbdtacode kbhowto kbinfo kbprogramming KB244435

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com