Article ID: 2448283 - Last Review: November 23, 2011 - Revision: 3.0

You cannot connect to Outlook Mobile Access on a server that is running Exchange Server 2003

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SYMPTOMS

You receive the following error message when you try to connect to Outlook Mobile Access (OMA) on a server that is running Microsoft Exchange Server 2003:
Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

Parser Error Message: The located assembly's manifest definition with name 'Microsoft.Exchange.OMA.UserInterface' does not match the assembly reference.

CAUSE

This issue occurs when the following conditions are true:
  • The server that is running Exchange Server 2003 is configured to use a language version other than English.
  • An Exchange Server 2003 hotfix or update package that contains the Microsoft.Exchange.OMA.UserInterface.dll file is installed.

WORKAROUND

To resolve this problem, manually replace the Microsoft.Exchange.OMA.UserInterface.dll file. To do this, follow these steps:
  1. Download the English version of the hotfix, and then unzip the package.
  2. Extract the Microsoft.Exchange.OMA.UserInterface.dll file. To do this, open a command prompt, type the following command, and then press Enter:
    Exchange2003-KBxxxxxx-x86.exe /x
    In this command, xxxxxx is the Microsoft Knowledge Base (KB) article number that describes the hotfix.
  3. Copy the Microsoft.Exchange.OMA.UserInterface.dll file that you extracted in step 2 into the following folder:
    \Exchsrvr\OMA\browse\bin

APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
Keywords: 
kbsurveynew kbprb kbtshoot KB2448283