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Symptoms

When you enable the Business Logging policy in Distributed Connectivity Services (DCS) in Microsoft Customer Care Framework 2009, performance of the server may be adversely affected.

Cause

This problem occurs because you cannot make the following changes in behavior when you enable the Business Logging policy:

  • The business logging process is Synchronous and cannot be changed to Asynchronous.

  • The logging of the message body is based on the configuration that is in place when the Business Logging policy is applied to an operation and cannot be made optional.

Resolution

To resolve this problem, install this hotfix. After this hotfix is installed, two new options are introduced:

  • isAsynchronous

  • enableMessageBodyLog

The values of these options can be set by using the DCS Management Services Console. As you can see in the following image, you can configure these properties of the Business Logging policy for a service operation by using the Edit Policy screen of the Policy Management section in the DCS Management Services Console.

Edit Policy screen

The default value for the isAsynchronous option is False. This value specifies that the default business logging behavior is Synchronous. When you set this value to True, a separate thread is run in parallel or asynchronously to the main service thread to log the details in the Business Log database.

The default value for the enableMessageBodyLog option is True. This specifies that the default message body logging behavior for requests and responses is based on the configuration that is in place when the Business Logging policy is applied to an operation.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must apply this hotfix to a computer that is running the following:

  • Distributed Connectivity Services (DCS) Service Pack 1 (SP1)

  • DCS Service Pack 1 (SP1) Business Logic Visual Studio Extensions



Restart information

You do not have to restart the computer after you apply this hotfix. However, you must restart the Internet Information Services (IIS) service.

Installation information

  1. Apply this hotfix to a computer that hosts the DCS core services and the target service applications. The behavior of the client computers is unaffected by this hotfix.

  2. Update the following variables in the SR110092328008235.bat file to actual values:

    SET APP_SOURCE=".\ Microsoft.ConnectedIndustry.ServiceModel.Application.dll"Update the DCS installation path for the following variable:

    SET DCS_PATH=C:\Program Files\Microsoft CISUpdate the DCS VS extension installation path for the following variable:

    SET DCS_EXT_PATH=C:\Program Files\Microsoft CISUpdate the Visual Studio installation path for this variable:

    SET VS_PATH=C:\Program Files\

  3. Exit all running instances of Microsoft Visual Studio.

  4. In the MMC, close all open DCS snap-ins.

  5. As an administrator, run the “SR110092328008235.bat” file in a Visual Studio command prompt.


The batch file replaces the Microsoft.ConnectedIndustry.ServiceModel.Application.dll file in the following locations:

  • C:\Program Files\Microsoft CIS\DCS\V1.0\Bin

  • C:\Program Files\Microsoft CIS\DCS\V1.0\SDK

  • C:\Program Files\Microsoft CIS\DCS Business Logic Visual Studio Extensions VS2008\DeploymentTool

  • C:\Program Files\Microsoft CIS\DCS Business Logic Visual Studio Extensions VS2008\ServiceModelReg

  • C:\Program Files\Microsoft CIS\DCS Business Logic Visual Studio Extensions VS2008\ServiceModelConfig

  • C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\PrivateAssemblies


Additionally, the batch file also adds the following file to the Global Assembly Cache (GAC):

Microsoft.ConnectedIndustry.ServiceModel.Application.dll

File information

The global version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.

File name

File version

File size

Date

Time

Platform

Microsoft.ConnectedIndustry.ServiceModel.Application.dll

1.5.0.142

223,040

20-Oct-2010

04:36

x86

Sr110092328008235.bat

Not Applicable

5,200

07-Sep-2010

08:25

Not Applicable



Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

The Business Logging policy in DCS in Customer Care Framework 2009 enables you to log the header and message body details for all messages that are sent to and from an operation. In DCS, when the enableBusinessLog property is enabled for an operation, the SOAP message details are logged in the business logging database. 

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