Artigo: 245063 - Última revisão: segunda-feira, 27 de Novembro de 2006 - Revisão: 19.3

Jogos: Mensagem de erro: Setup failed to extract files from <unidade:\nome_do_ficheiro>.CAB

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Este artigo foi publicado anteriormente em PT245063

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Quando tenta instalar um dos programas listados na secção "Aplica-se a", poderá receber uma mensagem de erro semelhante à seguinte, em que nome_do_ficheiro é o nome de um ficheiro necessário:
Setup failed to extract files from unidade:\nome_do_ficheiro.CAB. This is most likely caused by low memory (low disk space for swapping file) or corrupted cabinet file. Please restart your machine and run setup again.

Causa

Este problema poderá ocorrer se uma ou mais das seguintes condições se verificar:
  • Um problema no processo de leitura do disco do jogo.
  • Existem programas (como um programa antivírus ou software de depuração) que são executados em segundo plano e que interferem com o processo de configuração do jogo.
  • A pasta Temp do Windows está cheia.
  • O ficheiro de paginação do Windows está danificado.
  • O disco rígido em que o ficheiro de paginação do Microsoft Windows está guardado está fragmentado.

Resolução

Para resolver este problema, utilize um ou mais dos seguintes métodos, pela ordem em que são apresentados.

Método 1: Verificar o CD

Verifique se o CD apresenta sinais de deformação ou riscos visíveis. Se o disco estiver danificado, contacte o Microsoft Sales através do número (800) 360-7561 para obter um CD de substituição.

Método 2: Instalar e iniciar o jogo a partir de uma unidade de CD ou de DVD diferente

A unidade de CD poderá não conseguir ler o CD do jogo. Tente instalar o jogo a partir de outra unidade de CD ou DVD no mesmo computador ou noutro computador. Se a instalação tiver êxito e conseguir iniciar o jogo neste teste, o problema poderá estar relacionado com o facto de a unidade de CD ou DVD original não conseguir ler o CD do jogo. Se este problema persistir, avance para o método seguinte.

Método 3: Limpar a unidade de CD

Limpe a unidade de CD utilizando um disco de limpeza de unidades de CD. Caso não tenha este disco, adquira-o. Os discos de limpeza de unidades de CD estão disponíveis na maioria das lojas de produtos informáticos. Se o problema persistir, avance para o método seguinte.

Método 4: Instalar o jogo num computador diferente

Nota: se não tiver um outro computador para tentar instalar o jogo, avance para o método seguinte.

Tente instalar o jogo num computador diferente. Se não conseguir instalar o jogo num computador diferente, devolva o disco do jogo ao fornecedor de software para obter um pacote de substituição.

Se adquiriu o programa nos últimos 30 dias, poderá conseguir devolvê-lo à loja onde o adquiriu de modo a obter a substituição ao abrigo da garantia de reembolso de 30 dias da Microsoft. Verifique a embalagem para obter informações sobre a garantia de reembolso de 30 dias da Microsoft. Para obter um disco de substituição, contacte a Microsoft Order Desk através do número (800) 360-7561 e solicite a substituição do disco danificado. Caso se encontre fora dos Estados Unidos, contacte a subsidiária local da Microsoft. Para localizar a subsidiária local, visite a seguinte página Web de sedes internacionais da Microsoft:
http://www.microsoft.com/worldwide/ (http://www.microsoft.com/worldwide/)

Se conseguir instalar o jogo num computador diferente, o problema não está relacionado com o disco. Avance para o método seguinte.

Método 5: Efectuar um procedimento de arranque limpo e limpar a pasta Temp

Quando inicia o Microsoft Windows, normalmente, alguns programas são iniciados e executados automaticamente em segundo plano e podem interferir com o jogo. Estes programas podem incluir programas antivírus e utilitários de sistema. Ao efectuar um arranque limpo, estará a impedir que estes programas sejam iniciados automaticamente.

Para concluir este procedimento, tem de ter sessão iniciada como administrador ou como membro do grupo de administradores. Se o seu computador estiver ligado a uma rede, as definições de política de rede também poderão impedi-lo de concluir este procedimento.

Para reiniciar o computador utilizando um procedimento de arranque limpo, siga estes passos se estiver a utilizar o Microsoft Windows XP:

Nota: poderá ocorrer uma perda temporária da funcionalidade de alguns serviços quando efectuar estes passos. Ao restaurar as definições também restaurará a funcionalidade, mas poderá retornar ao comportamento ou mensagem de erro original.
  1. Clique em Iniciar, clique em Executar, escreva msconfig na caixa Abrir e clique em OK.
  2. No separador Geral, clique em Arranque selectivo. Em Arranque selectivo, clique para desmarcar as seguintes caixas de verificação:
    • Processar ficheiro System.ini
    • Processar ficheiro Win.ini
    • Carregar itens de arranque
  3. No separador Serviços, clique para seleccionar a caixa de verificação Ocultar todos os serviços da Microsoft e clique em Desactivar todos.
  4. Clique em OK e em Reiniciar.
Clique no botão Reproduzir para visualizar esta transmissão de multimédia em sequência de demonstração.

Para obter mais informações ou para ver passos para outros sistemas operativos, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
331796  (http://support.microsoft.com/kb/331796/ ) Como efectuar um procedimento de arranque limpo para impedir que programas em segundo plano interfiram com um jogo ou com um programa actualmente em utilização
Depois de efectuar o procedimento de arranque limpo, limpe a pasta Temp do Windows. Para o fazer, utilize o seguinte método adequado à sua versão do Windows.

Microsoft Windows XP ou Microsoft Windows 2000

Nota: a pasta Temp está localizada numa pasta de utilizador específica (por exemplo, C:\Documents and Settings\nome de utilizador\Definições locais\Temp). Para limpar a pasta Temp do Windows, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva %temp% na caixa Abrir e clique em OK.
  2. No menu Editar, clique em Seleccionar tudo.
  3. No menu Ficheiro, clique em Eliminar.

    Quando lhe for pedido para confirmar a eliminação, clique em Sim.
  4. Teste o jogo.

Microsoft Windows 98 ou Microsoft Windows Millennium Edition

Para limpar a pasta Temp do Windows, siga estes passos:
  1. Clique em Iniciar e clique em Executar.
  2. Na caixa Abrir, escreva temp e clique em OK.
  3. No menu Editar, clique em Seleccionar tudo.
  4. No menu Ficheiro, clique em Eliminar.

    Quando lhe for pedido para confirmar a eliminação, clique em Sim.
  5. Teste o jogo.
Se o problema persistir, avance para o método seguinte.

Método 6: Desactivar o acesso directo à memória na unidade de CD

Para desactivar o acesso directo à memória (DMA, Direct Memory Access) no computador, utilize o método adequado à sua versão do Windows.

Microsoft Windows XP

Nota: se a unidade não estiver listada, provavelmente, tem uma unidade SCSI. As opções DMA não estão disponíveis para unidades SCSI.
  1. Clique em Iniciar e clique em Painel de controlo.
  2. Clique em Desempenho e manutenção e clique em Sistema.
  3. Clique no separador Hardware e clique em Gestor de dispositivos.
  4. Expanda a pasta Controladores IDE ATA/ATAPI, faça duplo clique em Canal IDE primário e clique no separador Definições avançadas.
  5. Na caixa Modo de transferência, clique em Somente PIO e clique em OK.
  6. Faça duplo clique em Canal IDE primário e clique no separador Definições avançadas.
  7. Na caixa Modo de transferência, clique em DMA se disponível e clique em OK.
  8. Reinicie o computador.
Para obter mais informações sobre como alterar o controlador da unidade do computador para o modo DMA no Microsoft Windows XP, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
310751  (http://support.microsoft.com/kb/310751/ ) É difícil localizar definições de dispositivos no Windows XP

Windows 98 e Microsoft Windows Millennium Edition

Para desactivar DMA na unidade de CD, siga estes passos:
  1. Clique em Iniciar, aponte para Definições e clique em Painel de controlo.
  2. Faça duplo clique em Sistema.
  3. No separador Gestor de dispositivos, clique em Ver dispositivos por tipo.
  4. Expanda CDROM.
  5. Clique na unidade de CD que pretende alterar e clique em Propriedades.
  6. Clique no separador Definições.
  7. Clique para desmarcar a caixa de verificação DMA e clique em Fechar.
  8. Feche o Painel de controlo e reinicie o computador.
Se o problema persistir, avance para o método seguinte.

Método 7: Reduzir a colocação em cache na unidade de CD

Nota: este procedimento destina-se apenas ao Microsoft Windows 98 e ao Microsoft Windows Millennium Edition (Me).

Para reduzir a colocação em cache na unidade de CD, siga estes passos:
  1. Clique em Iniciar, aponte para Definições e clique em Painel de controlo.
  2. Faça duplo clique em Sistema.
  3. No separador Desempenho, clique em Sistema de ficheiros.
  4. No separador CD-ROM, mova o controlo de regulação de Tamanho da cache suplementar para a posição Pequena.
  5. Na caixa Optimizar padrão de acesso para, clique em Sem leitura antecipada.
  6. Clique em OK e clique em Fechar.
  7. Quando lhe for pedido para reiniciar o computador, clique em Sim.
Se o problema persistir, avance para o método seguinte.

Método 8: Verificar a existência de erros no disco rígido

Para verificar o disco rígido, utilize o método adequado ao seu sistema.

Microsoft Windows XP ou Microsoft Windows 2000

  1. Abra O meu computador.
  2. Clique com o botão direito do rato no disco rígido que pretende verificar e clique em Propriedades.
  3. No separador Ferramentas, na secção Verificação de erros, clique em Verificar agora.
  4. Seleccione a caixa de verificação Corrigir erros do sistema de ficheiros automaticamente e a caixa de verificação Procurar e tentar recuperar sectores danificados e clique em Iniciar.
  5. Permita que o processo seja concluído.

Windows 98 ou Windows Millennium Edition

  1. Clique em Iniciar, aponte para Programas, aponte para Acessórios, aponte para Ferramentas do sistema e clique em ScanDisk.
  2. Seleccione a unidade em que está instalado o jogo e clique em Iniciar.
  3. Permita que o processo seja concluído.
Se este problema persistir, avance para o método seguinte.

Método 9: Desfragmentar a unidade de disco rígido

Quando um programa é instalado no computador, os ficheiros do mesmo poderão ser armazenados em várias localizações não contíguas no disco rígido. Este procedimento é denominado fragmentação. Se o disco rígido estiver fragmentado, os programas no computador poderão ser executados mais lentamente.

A ferramenta Desfragmentador de disco optimiza o desempenho do computador reorganizando os ficheiros no disco rígido em blocos contíguos. Quando a ferramenta Desfragmentador de disco concluir a desfragmentação dos ficheiros no disco rígido, os programas poderão ser executados com mais rapidez.

Nota: pode utilizar o computador enquanto o Desfragmentador de disco está a ser executado. No entanto, o computador funciona mais lentamente durante o processo de desfragmentação e este é reiniciado se o conteúdo da unidade for alterado durante o processo. Para desfragmentar o disco rígido, siga estes passos:
  1. Clique em Iniciar, aponte para Programas (ou Todos os programas), aponte para Acessórios, aponte para Ferramentas do sistema e clique em Desfragmentador de disco.
  2. Seleccione a unidade em que está instalado o jogo e clique em Desfragmentar.
  3. Permita que o processo de desfragmentação seja concluído.

    Nota: no Windows 98 e no Windows Millennium Edition (Me), clique em OK.

Método 10: Recriar o ficheiro de paginação do Windows

Para recriar o ficheiro de paginação do Windows, utilize o método adequado ao seu sistema.

Windows XP

Nota: para executar esta tarefa, tem de ser um administrador ou um membro do grupo de administradores no seu computador e no computador que está a gerir.
  1. Clique em Iniciar e clique em Painel de controlo.
  2. Clique em Desempenho e manutenção.
  3. Clique em Ferramentas administrativas.
  4. Faça duplo clique em Gestão de computadores.
  5. Na árvore da consola, clique com o botão direito do rato em Gestão de computadores (local) e clique em Propriedades.
  6. No separador Avançadas, clique em Definições em Desempenho.
  7. Na secção Memória virtual, clique em Alterar.
  8. Na lista Unidade, clique na unidade que contém o ficheiro de paginação que pretende alterar.
  9. Em Tamanho do ficheiro de paginação para a unidade seleccionada, escreva 0 para Tamanho inicial (MB) e Tamanho máximo (MB) e clique em Definir.
  10. Reinicie o computador e repita os passos 1 a 8. Seleccione a opção Tamanho gerido pelo sistema e clique em Definir.
Windows 98 e Windows Millennium Edition
  1. Clique em Iniciar e clique em Encerrar.
  2. Clique em Reiniciar no modo de MS-DOS e clique em OK.
  3. Na linha de comandos, escreva as seguintes linhas e prima ENTER após cada linha:
    cd\windows
    del win386.swp
    exit
  4. Clique em Iniciar, aponte para Definições e clique em Painel de controlo.
  5. Faça duplo clique em Sistema.
  6. No separador Desempenho, clique em Memória virtual.
  7. Clique em Permitir que o utilizador possa especificar as definições de memória virtual.
  8. Na caixa Disco rígido, certifique-se de que tem, pelo menos, 50 megabytes (MB) de espaço disponível no disco rígido. Se tiver vários discos rígidos instalados no computador, certifique-se de que tem, pelo menos, 50 MB de espaço disponível no disco rígido em que o Windows está instalado.

    Nota: se não tiver, pelo menos, 50 MB de espaço disponível no disco rígido, tem de libertar espaço removendo ficheiros antigos ou programas que não necessite.
  9. Clique em Cancelar e clique em OK.

Mais Informação

Para obter mais informações sobre como resolver problemas relacionados com erros de leitura de CDs, clique nos números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
218617  (http://support.microsoft.com/kb/218617/ ) Como resolver problemas de leitura em unidades CD-ROM ou DVD-ROM
321641  (http://support.microsoft.com/kb/321641/ ) Como resolver problemas relacionados com a leitura de discos nos formatos CD, CD-R, CD-RW e DVD
314096  (http://support.microsoft.com/kb/314096/ ) Como resolver problemas da unidade de CD-ROM no Windows XP

A informação contida neste artigo aplica-se a:
  • Microsoft Flight Simulator X Deluxe
  • Microsoft Flight Simulator X Standard
  • Microsoft Links 2003 Championship Edition
  • Microsoft Age of Empires II: The Age of Kings
  • Microsoft Age of Empires II: The Conqueror's Expansion
  • Microsoft Age of Empires II Gold Edition
  • Microsoft Age of Mythology Gold
  • Microsoft Age of Mythology: The Titans
  • Microsoft Combat Flight Simulator 2: WWII Pacific Theater
  • Microsoft Combat Flight Simulator 3: Battle for Europe
  • Microsoft Flight Simulator 2000 Standard Edition
  • Microsoft Flight Simulator 2000 Professional Edition
  • Microsoft Flight Simulator 2002 Standard Edition
  • Microsoft Flight Simulator 2002 Professional Edition
  • Microsoft Flight Simulator 2004 Century of Flight
  • Microsoft Halo PC 1.0
  • Microsoft Rise of Nations
  • Microsoft Rise of Nations: Gold Edition
  • Microsoft Rise of Nations: Thrones and Patriots
  • Microsoft eMbedded Visual C++ 4.0
  • Microsoft Zoo Tycoon 1.0
  • Microsoft Zoo Tycoon Complete Collection
  • Microsoft Zoo Tycoon: Dinosaur Digs 1.0
  • Microsoft Zoo Tycoon: Marine Mania
Palavras-chave: 
kbhowto kbarttypeshowme kberrmsg kbprb kbsetup KB245063