Artigo: 245188 - Última revisão: quarta-feira, 1 de Novembro de 2006 - Revisão: 1.1

Mensagem de erro: STOP C0000221 - Checksum de imagem inválida em Oleaut32.dll

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Depois de instalar programas personalizados num computador com o Microsoft Windows NT Server 4.0, o computador poderá deixar de responder (não reagir) e poderá receber a seguinte mensagem de erro:
STOP C0000221 - Checksum de imagem inválido
A imagem do ficheiro Oleaut32.dll é possivelmente danificar o cabeçalho de soma de verificação não corresponde à soma de verificação calculada.
Tentativas para substituir o ficheiro oleaut.dll danificado utilizando a última configuração reconhecida como correcta e o disco de reparação de emergência (ERD, Emergency Repair Disk) não têm êxito.

Causa

A causa é desconhecida.

Resolução

Para resolver este problema, substitua o ficheiro Oleaut32.dll. Tenha em atenção que se estiver a executar o Microsoft Internet Information Server 4.0, poderá ser necessário substituir bem como outros ficheiros.

Se o Windows NT Server 4.0 reside numa partição FAT (file allocation table), siga estes passos:

  1. Inicie o computador em MS-DOS.
  2. Substitua o ficheiro Oleaut32.dll na pasta % SystemRoot%\System32 com o ficheiro Oleaut32.dll incluído no Microsoft Windows NT 4.0 Service Pack 3 ou posterior.

    Nota : Se estiver a efectuar este procedimento num Compaq computador, aplicam-se a disquete de suporte de software de Compaq mais recente (SSD).
  3. Reinicie o computador.
Se o Windows NT Server 4.0 reside numa partição do sistema de ficheiros NTFS, siga estes passos:

  1. Instalar uma instalação paralela do Windows NT Server 4.0 e instale o service pack mais recente do Windows NT 4.0 para a instalação paralela.
  2. Inicie o computador na instalação paralela.
  3. Copie o ficheiro Oleaut32.dll a instalação paralela para a pasta %SystemRoot%\System32 da instalação original.

    Nota : Se estiver a efectuar este procedimento num Compaq computador, aplicar o SSD Compaq mais recente.
  4. Reinicie o computador para a instalação original e, em seguida, remova a instalação paralela.
Se substituir o ficheiro de Oleaut32 e o computador é o Internet Information Server 4.0 na instalação original e o problema persistir, siga estes passos:

  1. Instale uma instalação paralela do Windows NT Server 4.0.
  2. Instalar os programas seguintes na instalação paralela pela seguinte ordem:
    1. O Windows NT 4.0 Service Pack 3
    2. Microsoft Internet Explorer 4.0
    3. Microsoft Windows NT 4.0 Option Pack
    4. Microsoft Windows NT 4.0 Service Pack 4
  3. Copie todos os ficheiros na pasta \Winnt\System32, excluindo subpastas da instalação paralela para a pasta \Winnt\System32 da instalação original.
  4. Copie todos os ficheiros na pasta \Winnt\System32\Drivers, excluindo subpastas da instalação paralela para a pasta \Winnt\System32\Drivers da instalação original.
  5. Reinicie o computador para a instalação original e, em seguida, a menos que recebe uma mensagem de erro do Dr. Watson, remova a instalação paralela.
  6. Se receber uma mensagem de erro do Dr. Watson enquanto estiver a iniciar o computador para a instalação original, reiniciá-lo para a instalação paralela e, em seguida, siga estes passos:
    1. Na instalação original, mude o nome os seguintes ficheiros:
      Explorer.exe
      Ficheiro Comctl32.dll
      Kernel32.dll
      Ntdll.dll
      Shdocvw.dll
      Shell32.dll
    2. Substitua os ficheiros listados com os mesmos ficheiros da instalação paralela.
    3. Reinicie o computador para a instalação original e, em seguida, remova a instalação paralela.

Mais Informação

Os dois primeiros procedimentos, também pode utilizar os passos específicos de sistema de ficheiros para reparar qualquer ficheiro danificado é referido na mensagem de erro STOP C0000221.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT Server 4.0 Standard Edition
Palavras-chave: 
kbmt kbprb KB245188 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 245188  (http://support.microsoft.com/kb/245188/en-us/ )