Article ID: 245470 - Last Review: June 12, 2001 - Revision: 1.0

PRB: MTS 'Does Not Have a Visible Share Point Available' on the Server

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This article was previously published under Q245470
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SYMPTOMS

When you add a remote component in Microsoft Transaction Server (MTS) Explorer, the following error message may occur:
No visible file share point available on server.
When you click Details, the following dialog box appears:
No visible share points are available on the server to copy the component files. The user account set for the System package on the client computer must have read access to a share point on the server.

A visible share point must be available to access the proxy/stub DLLs and type libraries for each component. You can use the MTX Explorer to check which proxy/stub DLLs and type libraries are registered for the interfaces implemented by the components.

NOTE: If you implement MTS interfaces, such as IObjectControl, you need access to the type library describing the MTS interface (Mtxas.dll in this case).

CAUSE

The error message can be caused by one of the following issues:

  • The DLLs and type libraries are not in a shared folder.
  • The System package identity is set to Interactive user by default. If no one logged on to the server, this package fails.




This behavior is by design.

RESOLUTION

To resolve this behavior, perform the following steps:
  1. Create a file share for the DLLs. Make sure that everyone has full control.
  2. Set the identity of the System Package on both computers.
  3. Use the information from the following Microsoft Knowledge Base article to set the identity package identity on both MTS computers:
    243973  (http://support.microsoft.com/kb/243973/EN-US/ ) HOWTO: Setting System Package Identity

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
243973  (http://support.microsoft.com/kb/243973/EN-US/ ) HOWTO: Setting System Package Identity

APPLIES TO
  • Microsoft Transaction Services 2.0
Keywords: 
kberrmsg kbprb kbsysadmin KB245470
Retired KB ArticleRetired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.