ディスク管理ツールから、偽のシステム パーティションを削除できない

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文書番号: 245799 - 対象製品
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目次

現象

ディスク管理ツールでパーティションを調べると、2 つの個別のボリューム (ドライブ C および D など) が、"システム" パーティションとして表示される場合があります。本来ののダイナミック システム ディスクが "不足" - "オフライン" として表示され、この "偽の" システム ボリュームを削除できない可能性があります。偽のシステム ボリュームを削除しようとすると、次のエラー メッセージが表示される場合があります。
このディスクのシステム ボリュームを削除できません。
そのパーティションを再フォーマットして、システム ボリュームのステータスを削除しようとすると、次のような警告メッセージが表示される場合があります。
このボリュームは現在のシステムボリュームではありません。このボリュームのデータはすべて消去されます。このボリュームをフォーマットしますか?
[はい] をクリックし、フォーマットを続けた場合でも、偽のシステム ボリュームのステータスは削除されず、結果ボリュームの削除にも失敗します。

原因

この問題は、次のいずれかの理由で発生します。
  • ダイナミック ディスクの "システム" パーティションのミラー設定を手動で解除した場合、シャドウ ドライブが処理に失敗する場合があります。この時、論理ディスクマネージャ(Logical Disk Manager:LDM) の private region データ ベース 内に「システム パーティション」フラグが設定されたまま残ってしまいます。
  • システム パーティションをダイナミック ディスク上に作成します。このシステム パーティションと、別のダイナミック ディスクとをWindows 2000 のミラーリング機能を使用してミラーリングします。この環境において何らかの理由でミラーリングに失敗し、かつ、ミラー先およびミラー元が共にブート不能になった場合、Windows 2000 を最初からインストールし直さなければならない場合があります。新しいシステム ボリュームを再作成した場合、残ったダイナミック ディスク データベースには、まだ元のシステム ボリュームのパーティションへの参照が存在しています。このため異なるドライブそれぞれに、"システム" パーティションが存在している状態になります。
  • "システム" パーティションを含んだダイナミック ディスク セットを、現在のシステムにインポートした場合。インポートされたダイナミック ディスクには、LDM 個別領域データベースでフラグが設定されたシステム パーティションが存在しています。

解決方法

Windows 2000

この問題を解決するには、Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法
この問題を回避するには、次の手順を実行してください。
  1. ディスク管理ツールから"偽の" システム パーティションを削除できないため、そのディスクの他のボリュームにあるデータをすべてバックアップします。
  2. "未処理の" ドライブを再パーティション化して、データをバックアップから復元するために、Recovery Console のdiskpart コマンドを使用して、手動ですべてのパーティションを削除します。 その方法の詳細については、Microsoft Knowledge Base から提供されている、以下の関連文書をご参照下さい。
    229716 Description of the Windows 2000 Recovery Console
    227364 Dynamic Volumes Are Not Displayed Accurately in Text-Mode Setup
メモ : ダイナミック ディスクの物理的パーティションを削除し、リブートした後も、"不足" - "オフライン" として表示された、ダイナミック "システム" ディスクが残ります。これは、残ったすべてのダイナミック ディスクが、失われたディスクを記述するデータベースに記録を残しているためです。この "仮の" ディスクは削除できませんが、障害になることもありません。

状況

弊社ではこの問題を、この資料の冒頭に記載した Microsoft 製品の問題として認識しております。

詳細

ディスク ミラーに失敗して Windows 2000 の再インストールを決定する前に、緊急の修復手段、フォールト トレラントのブート ディスク、Recovery Console などを使用して、失敗したミラーのどちらかをブート可能にしてください。ブート可能なシステム パーティションができれば、ミラーを再同期化または再確立できます。これによって問題が回避できれば、この資料で説明した問題は発生しません。

詳細

この資料は、米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 245799 (最終更新日 2000-07-27) を基に作成したものです。

プロパティ

文書番号: 245799 - 最終更新日: 2004年11月9日 - リビジョン: 2.2
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Server
キーワード:?
kbtshoot kbtool kbui win2000presp1fix KB245799
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

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