Works: Mensaje de error "Wkgdcache provocó un error de protección general en el módulo" cuando ejecuta Works

Seleccione idioma Seleccione idioma
Id. de artículo: 246065 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando ejecuta Microsoft Works, puede recibir uno de los mensajes de error siguientes:
Wkgdcach provocó un error de protección general en el módulo Unidrv.dll.
Wkgdcach provocó un error de protección general en el módulo Wkgdcach.dll.
Wkgdcach provocó un error de protección general en el módulo Envoydrv.drv.
WKGDCACH provocó un error de página no válida en el módulo WKWINUNI.DLL
WKGDCACH ha provocado un error en msvcrt.dll
wkgdcach causó un gpf en el módulo atm32-dll
WKGDCACH provocó un error página no válida en el módulo module name
En este mensaje de error, module name es el nombre de un controlador de hardware o de otro programa.

Causa

Este problema puede producirse si se cumple una de las condiciones siguientes:
  • El controlador de impresora para su impresora está dañado.
  • Más de 300 fuentes se instalan en el equipo.
  • Existen conflictos con los controladores o programas en el equipo.
En sistemas basados en Microsoft Windows XP, puede surgir un conflicto si el programa se ejecuta en modo de compatibilidad de Microsoft Windows 98.

Solución

Para resolver este problema, emplee los métodos siguientes en el orden en que aparecen.

Deshabilitar el modo de compatibilidad de Windows 98 (Windows XP)

Si el programa que está experimentando el problema se está ejecutando en modo de compatibilidad de Windows 98 en Windows XP, deshabilitar a la configuración de modo de compatibilidad de Windows 98 para ese programa.

Instalar la versión más reciente del controlador de impresora para la impresora

Póngase en contacto con el fabricante para obtener información acerca de cómo obtener e instalar al controlador de impresora más reciente disponible para su impresora.

Para obtener más información sobre proveedores de hardware y software información de contacto, visite el siguiente sitio Web de Microsoft:
http://support.microsoft.com/gp/vendors
Nota Si una impresora multifunción está conectada al equipo, quizás tenga que quite el controlador de impresora y desconecte la impresora. Para ello:
  1. Haga clic en Inicio , seleccione configuración y, a continuación, haga clic en impresoras .
  2. Haga clic con el botón secundario en la impresora multifunción y, a continuación, haga clic en Eliminar .
  3. Si se le pide que confirme la eliminación, haga clic en .
  4. Si pide confirmación para eliminar archivos que sólo se han utilizado para esta impresora, haga clic en .
  5. Cerrar la ventana Impresoras.
Si el problema persiste, vaya al método siguiente.

Quitar fuentes adicionales

Para comprobar el número de fuentes instaladas en el equipo:
  1. Haga clic en Inicio , seleccione configuración y, a continuación, haga clic en Panel de control .
  2. Haga doble clic en fuentes .
  3. Anote el número de fuentes instaladas muestra en la barra de estado en la parte inferior de la ventana fuentes .

    Nota Si no se muestra la barra de estado, haga clic en Barra de estado en el menú Ver .
Si más de 300 fuentes están instaladas en su equipo, quite las fuentes que raramente usan.

Nota Microsoft Windows requieren ciertas fuentes. No quite cualquiera de las fuentes siguientes:
  • Arial (incluidas negrita Arial, Arial cursiva o cualquier otra variación de Arial)
  • Libro Antiqua
  • Calisto MT
  • Siglo Gothic (incluyendo cualquier variación de Century Gothic)
  • Copperplate Gothic (incluyendo cualquier variación de Copperplate Gothic)
  • Courier (incluido cualquier variación de correo)
  • Courier New (incluido cualquier variación de Courier New)
  • Haettenschweiler.
  • Impacto
  • Lucida (incluido cualquier variación de Lucida)
  • Marlett
  • Matisse ITC
  • Moderno
  • Noticias Gothic MT (incluido cualquier variación de News Gothic MT)
  • OCR A Extended
  • MS Sans Serif 8,10,12,14,18,24
  • MS Serif 8,10,12,14,18,24
  • Fuentes pequeñas
  • Símbolo
  • Symbol 8,10,12,14,18,24
  • Tahoma (incluido cualquier variación de Tahoma)
  • Tempus Sans ITC
  • Times New Roman (incluyendo cualquier variación de Times New Roman)
  • Verdana (incluidas cualquier variación de Verdana)
  • Webdings
  • Abadía
  • Wingdings
Para quitar una fuente:
  1. En la ventana fuentes , haga clic con el botón secundario en la fuente que desea quitar y, a continuación, haga clic en Eliminar .
  2. Si se le pide que confirme la eliminación, haga clic en .
  3. Repita los pasos 1 y 2 para eliminar todas las fuentes que desea eliminar.
  4. Cuando termine de eliminar fuentes, reinicie el equipo.
Si el problema persiste, vaya al método siguiente.

Reducir la configuración de aceleración del hardware de gráficos

Para reducir la configuración de aceleración del hardware de gráficos en el equipo:
  1. Haga clic en Inicio , seleccione configuración y, a continuación, haga clic en Panel de control .
  2. Haga doble clic en sistema .
  3. Haga clic en la ficha rendimiento y, a continuación, haga clic en gráficos .
  4. Mueva el control deslizante Aceleración de hardware hasta que esté una muesca a la derecha de Ninguno (la configuración de aceleración básica ).
  5. Haga clic en Aceptar y, a continuación, haga clic en Cerrar .
  6. Cuando se le pregunte si desea reiniciar el equipo, haga clic en .
  7. Si experimenta problemas después de reducir la aceleración de hardware de gráficos, siga estos pasos para restaurar la aceleración de hardware de gráficos a la configuración original:
    1. Reinicie Windows en el Modo a prueba de errores. Para ello, utilice el método correspondiente para su sistema operativo.

      Microsoft Windows 98

      Reinicie el equipo, presione y mantenga presionada la tecla CTRL una vez completada la POST Power On Self Test () y, a continuación, en el menú Inicio seleccione Modo seguro .

      Microsoft Windows 95

      Reinicie el equipo. Cuando se vea el "Iniciando Windows 95" del mensaje, presione la tecla F8 y, a continuación, en el menú Inicio elija Modo a prueba de errores .
    2. Cuando se inicie Windows en modo a prueba de errores, haga clic en Aceptar .
    3. Repita los pasos 1 a 6, pero en el paso 4 mover el Hardware Acceleration control deslizante volver al su posición original.
Si los procedimientos anteriores no resuelven el problema, a continuación, utilice la solución de problemas para descartar posibles conflictos con los controladores de hardware y otros programas de inicio limpio.Para obtener información adicional acerca de cómo solucionar inicio limpio, haga clic en los números de artículo siguientes para verlos en Microsoft Knowledge Base:
267288Cómo realizar un inicio limpio en Windows Millennium Edition
192926Cómo realizar la solución de problemas de inicio limpio en Windows 98
310353Cómo realizar un inicio limpio en Windows XP

Actualizar ATM

Este problema puede deberse a un conflicto con las versiones anteriores de Adobe Type Manager (ATM). Si estás utilizando ATM, actualice su versión de ATM o deshabilite ATM como el Administrador de fuentes de Windows. Para deshabilitar las versiones de la mayoría de ATM:
  1. Iniciar el programa Adobe Type Manager y, a continuación, desactive la función de administrador de la fuente.
  2. Reinicie el equipo para que el cambio surta efecto.
Consulte la documentación de Adobe Type Manager para obtener información adicional.

Deshabilitar Wkgdcach.dll

En versiones de Suite del programa, quizás pueda evitar este problema deshabilitando Wkgdcach.dll. Para ello, cambie el nombre Wkgdcach.dll Wkgdcach.old .

Nota Esto puede provocar que el programa procesador de textos de Works no funcione. En las versiones de Suite, esto no es normalmente un problema, porque el procesador de textos de Works no se usa normalmente (en su lugar se utiliza Microsoft Word).

Más información

Si ninguna de las resoluciones proporcionadas en este trabajo de sección, probablemente hay daños en el controlador de fuente para Windows. La mejor para resolver este problema consiste en hacer una reinstalación completa de Windows.

Nota Reinstalación sobre el sistema operativo existente puede no resolver el problema, porque no todos los programas de Windows se reemplazarán. Por consiguiente, puede tener quitar Windows (formato del disco duro) y, a continuación, volver a instalar completamente (restauración del sistema).

Propiedades

Id. de artículo: 246065 - Última revisión: lunes, 24 de febrero de 2014 - Versión: 10.3
La información de este artículo se refiere a:
  • Microsoft Works 8.0
  • Microsoft Works 6.0 Standard Edition
  • Microsoft Works 2000 Standard Edition
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004 Standard Edition
  • Microsoft Works Suite 2000 Standard Edition
  • Microsoft Works Suite 2001 Standard Edition
  • Microsoft Works Suite 2006
Palabras clave: 
kbnosurvey kbarchive kbmt kbenv kberrmsg kbprb kbprint KB246065 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 246065

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com