Works: Mensagem de erro de "Wkgdcache causou uma falha de proteção geral no módulo" ao executar o Works

Traduções deste artigo Traduções deste artigo
ID do artigo: 246065 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

Quando você executa o Microsoft Works, você pode receber uma das seguintes mensagens de erro:
Wkgdcach causou uma falha de proteção geral no módulo Unidrv.dll.
Wkgdcach causou uma falha de proteção geral no módulo Wkgdcach.dll.
Wkgdcach causou uma falha de proteção geral no módulo Envoydrv.drv.
WKGDCACH causou uma falha de página inválida no módulo WKWINUNI.DLL
WKGDCACH causou um erro em msvcrt.dll
wkgdcach causou um gpf no módulo atm32-dll
WKGDCACH causou uma falha de página inválida no módulo module name
Nessa mensagem de erro, o module name é o nome de um driver de hardware ou outro programa.

Causa

Esse problema pode ocorrer se uma das seguintes condições for verdadeira:
  • O driver de impressora para a sua impressora está danificado.
  • Mais de 300 fontes são instaladas em seu computador.
  • Conflitos com outros programas ou drivers existem no seu computador.
Em sistemas com o Microsoft Windows XP, um conflito pode surgir se o programa estiver sendo executado no modo de compatibilidade do Microsoft Windows 98.

Resolução

Para resolver esse problema, use os seguintes métodos na ordem em que eles são apresentados.

Desativar modo de compatibilidade do Windows 98 (Windows XP)

Se o programa que está enfrentando o problema está sendo executado no modo de compatibilidade do Windows 98 no Windows XP, desative a configuração de modo de compatibilidade do Windows 98 para o programa.

Instale a versão mais recente do driver de impressora para a impressora

Contate o fabricante da impressora para obter informações sobre como obter e instalar o driver de impressora mais recente disponível para sua impressora.

Para obter mais informações sobre fornecedores de hardware e software informações de contato, visite o seguinte site:
http://support.microsoft.com/gp/vendors
Observação Se uma impressora multifuncional estiver conectada ao computador, talvez seja necessário remover o driver de impressora e desconectar-se a impressora. Para fazer isso:
  1. Clique em Iniciar , aponte para configurações e, em seguida, clique em impressoras .
  2. Clique a impressora multifuncional com o botão direito do mouse e, em seguida, clique em Excluir .
  3. Se você for solicitado para confirmar a exclusão, clique em Sim .
  4. Se você for solicitado para excluir arquivos que foram usados somente para esta impressora, clique em Sim .
  5. Feche a janela de impressoras.
Se o problema persistir, vá para o próximo método.

Remover fontes adicionais

Para verificar o número de fontes que são instaladas em seu computador:
  1. Clique em Iniciar , aponte para configurações e, em seguida, clique em Painel de controle .
  2. Clique duas vezes em fontes .
  3. Anote o número de fontes instalados exibidas na barra de status na parte inferior da janela fontes .

    Observação Se a barra de status não for exibida, clique em Barra de status no menu Exibir .
Se mais de 300 fontes estiverem instaladas no seu computador, remova as fontes que você raramente usa.

Observação Determinadas fontes são necessários pelo Microsoft Windows. Não remova qualquer uma das seguintes fontes:
  • Arial (incluindo negrito Arial, Arial itálico ou qualquer outra variação de Arial)
  • Livro Book Antiqua
  • Calisto MT
  • Gothic século (incluindo qualquer variação de Century Gothic)
  • Copperplate Gothic (incluindo qualquer variação de Copperplate Gothic)
  • Courier (incluindo qualquer variação de Courier)
  • Courier New (incluindo qualquer variação de Courier New)
  • Haettenschweiler
  • Impacto
  • Lucida (incluindo qualquer variação de Lucida)
  • Marlett
  • Matisse ITC
  • Moderno
  • Notícias Gothic MT (incluindo qualquer variação de News Gothic MT)
  • OCR A Extended
  • MS Sans Serif 8,10,12,14,18,24
  • MS Serif 8,10,12,14,18,24
  • Fontes pequenas
  • Símbolo
  • Symbol 8,10,12,14,18,24
  • Tahoma (incluindo qualquer variação de Tahoma)
  • Tempus Sans ITC
  • Times New Roman (incluindo qualquer variação de Times New Roman)
  • Arial (incluindo qualquer variação de Verdana)
  • Webdings
  • Westminster
  • Wingdings
Para remover uma fonte:
  1. Na janela fontes , clique com o botão direito na fonte que você deseja remover e, em seguida, clique em Excluir .
  2. Se você for solicitado para confirmar a exclusão, clique em Sim .
  3. Repita as etapas 1 a 2 para excluir outras fontes que você deseja excluir.
  4. Quando terminar de excluir fontes, reinicie o computador.
Se o problema persistir, vá para o próximo método.

Reduzir a configuração de aceleração de hardware gráfico

Para reduzir a configuração de aceleração de hardware gráfico em seu computador:
  1. Clique em Iniciar , aponte para configurações e, em seguida, clique em Painel de controle .
  2. Clique duas vezes em sistema .
  3. Clique na guia desempenho e, em seguida, clique em gráficos .
  4. Mova o controle deslizante Hardware aceleração até que seja um ponto à direita do Nenhum (a configuração de aceleração básica ).
  5. Clique em OK e, em seguida, clique em Fechar .
  6. Quando você for solicitado a reiniciar o computador, clique em Sim .
  7. Se você tiver problemas depois de você reduzir a aceleração de hardware gráfico, execute estas etapas para restaurar a aceleração de hardware gráfico para a configuração original:
    1. Reinicie o Windows no modo de segurança. Para fazer isso, execute as etapas apropriadas para seu sistema operacional.

      Microsoft Windows 98

      Reinicie o computador, pressione e mantenha pressionada a tecla CTRL após o computador concluir o POST (Power On Self Test) e selecione Modo de segurança no menu Iniciar.

      Microsoft Windows 95

      Reinicie o computador. Quando você vir "Iniciando o Windows 95" da mensagem, pressione a tecla F8 e escolha Modo de segurança no menu Iniciar.
    2. Quando o Windows iniciar no modo de segurança, clique em OK .
    3. Repita as etapas 1 a 6, mas na etapa 4 mover o Hardware Acceleration controle deslizante de volta para sua posição original.
Se os procedimentos anteriores não resolverem o problema, use solução de problemas a regra de saída possíveis conflitos com drivers de hardware e outros programas de inicialização limpa.Para informações adicionais sobre como solucionar problemas inicialização limpa, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
267288Como executar uma inicialização limpa no Windows Millennium Edition
192926Como executar a solução de problemas com inicialização limpa para Windows 98
310353Como executar uma inicialização limpa no Windows XP

Atualizar ATM

Esse problema pode ser causado por um conflito com versões mais antigas do tipo Gerenciador Adobe. Se você estiver usando o ATM, atualizar a sua versão do ATM ou desativar ATM como seu Gerenciador de fonte do Windows. Para desativar a maioria das versões do ATM:
  1. Iniciar o programa Adobe Type Manager e, em seguida, desative a função de Gerenciador de fonte.
  2. Reinicie o computador para que a alteração tenha efeito.
Consulte a documentação do Adobe Type Manager para obter informações adicionais.

Desativar Wkgdcach.dll

Em versões de Suite do programa, você poderá solucionar esse problema desativando Wkgdcach.dll. Para fazer isso, renomeie Wkgdcach.dll como Wkgdcach.old .

Observação Isso pode causar o programa processador de texto do Works não funcione. Em versões de conjunto, isso não é geralmente um problema, porque o processador do Works não é normalmente usada (Microsoft Word é usado em vez disso).

Mais Informações

Se nenhuma das resoluções fornecidas no trabalho nesta seção, provavelmente há corrupção no driver da fonte para o Windows. A melhor maneira de resolver esse problema é fazer uma reinstalação completa do Windows.

Observação Reinstalando o sobre o sistema operacional existente pode não resolver o problema, porque nem todos os programas do Windows serão substituídos. Portanto, você talvez precise remover Windows (formato de disco rígido) e, em seguida, reinstalar completamente (restauração do sistema).

Propriedades

ID do artigo: 246065 - Última revisão: quarta-feira, 26 de fevereiro de 2014 - Revisão: 10.3
A informação contida neste artigo aplica-se a:
  • Microsoft Works 8.0
  • Microsoft Works 6.0 Standard Edition
  • Microsoft Works 2000 Standard Edition
  • Microsoft Works Suite 2005
  • Microsoft Works Suite 2004 Standard Edition
  • Microsoft Works Suite 2000 Standard Edition
  • Microsoft Works Suite 2001 Standard Edition
  • Microsoft Works Suite 2006
Palavras-chave: 
kbnosurvey kbarchive kbmt kbenv kberrmsg kbprb kbprint KB246065 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 246065

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com