Artigo: 246183 - Última revisão: quinta-feira, 1 de Março de 2007 - Revisão: 6.5

Recebe a mensagem de erro 0x80090016 ou 0x8009000f da mensagem de erro quando tentar agendar uma tarefa

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante
Este artigo aplica-se para o Windows 2000. Suporte para o Windows 2000 termina em 13 de Julho de 2010. O Windows 2000 End-of-Support Solution Center (http://support.microsoft.com/?scid=http%3a%2f%2fsupport.microsoft.com%2fwin2000) é um ponto de partida para planear a estratégia de migração a partir do Windows 2000. Para mais informações consulte a Microsoft Support Lifecycle Policy (http://support.microsoft.com/lifecycle/) .
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Sintomas

Quando tentar agendar uma tarefa utilizando a ferramenta tarefas agendadas no painel de controlo, poderá receber uma das seguintes mensagens de erro:
  • A nova tarefa foi criada mas pode não ser executada porque não foi possível definir as informações da conta. O erro específico é:
    0x80090016: conjunto de chaves não existe.
  • A nova tarefa foi criada mas pode não ser executada porque não foi possível definir as informações da conta. O erro específico é:
    0x8009000f: objecto já existe.

Causa

Este comportamento ocorre porque o serviço Armazenamento protegido não é iniciado ou em execução num computador baseado no Windows 2000.

Resolução

Importante Esta secção, método ou tarefa contém passos que a saber como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo incorrectamente. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows
Para resolver este problema:
  1. Inicie o serviço Armazenamento protegido utilizando um dos seguintes métodos:
    • Utilize o snap-in compmgmt.msc.
    • Escreva o seguinte comando numa linha de comandos:
      net start "armazenamento protegido"
    Nota Se o subsistema criptográfica ficou danificado, poderá ter que criar uma cópia de segurança na seguinte subchave, em seguida, elimine-o e, em seguida, reinicie o computador:
    HKEY_USERS\.Default\Software\Microsoft\Cryptography\Providers\Type 001

    Nota Se esta chave de registo não existir, avance para o passo seguinte.
  2. Teste para determinar se o problema foi resolvido. Se o problema for resolvido, ignore os restantes passos. Se o problema não ficar resolvido, avance para o passo 3.
  3. Inicie o computador no modo de segurança e, em seguida, inicie sessão como administrador.
  4. Faça duplo clique no Meu computador e, em seguida, clique em Opções de pastas no menu Ferramentas.
  5. No separador Ver, clique para seleccionar Mostrar ficheiros e pastas ocultos e, em seguida, clique em OK.
  6. Eliminar todos os ficheiros no "c:\Documentos e Settings\All Users\Application Data\Microsoft\Crypto\RSA\S-1-5-18" pasta.
  7. Reinicie o computador e, em seguida, execute a tarefa.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Datacenter Server
Palavras-chave: 
kbmt kberrmsg kbprb KB246183 KbMtpt
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