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PRB: COM+ Setup Problems While Upgrading to Windows 2000

Article ID:246499
Last Review:October 26, 2007
Revision:1.1
This article was previously published under Q246499
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SYMPTOMS

When you upgrade your computer to Microsoft Windows 2000, you may find problems when starting the Component Services snap-in from Administrative tools, or you may notice problems when trying to run ASP pages.
-or-
When you open the Component Services Microsoft Management Console (MMC) in Windows 2000 and click to expand the Component Services and Computers nodes, you may receive the following error message:
Catalog error - An error occurred while processing the last operation: 80040154, Class not registered

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CAUSE

This problem usually happens if there was a problem during COM+ setup.

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STATUS

This behavior is by design.

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MORE INFORMATION

At the beginning of setup, Windows 2000 generates a file named ~clbcatq.dll. The existence of this file signals that COM+ setup has not been successfully completed. When COM+ setup completes successfully, it deletes the ~clbcatq.dll file.

Check whether the ~clbcatq.dll file is present in your %windir%\system32 folder. If so, then it's likely that something failed during COM+ setup. If the ~clbcatq.dll file is present, this could be because either:
The Windows 2000 optional component setup experienced some problem and halted prematurely, before allowing COM+ to finish its setup. -or-

COM+ setup experienced some problem.
Windows 2000 uses ~clbcatq.dll to determine whether or not to allow access to the COM+ catalog. If this DLL is present, then you can't use the Component Services snap-in to administer the COM+ catalog, and ASP pages and ISAPI DLLs will not run.

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Problem Diagnosis and Troubleshooting

COM+ setup logs errors to a file named Comsetup.log. Search Comsetup.log for errors.

If you find COM+ errors, follow these initial troubleshooting steps:
1.Delete the ~clbcatq.dll file.
2.Move the contents of %systemroot%\registration somewhere else
3.Export the HKLM\Software\Microsoft\COM3 for posterity, then delete it.
4.Re-run COM+ setup. To do this, follow these steps:

a. In Control Panel, click Add/Remove Programs.
b. Click Add/Remove Windows Components.
c. Click Next several times, and then click Finish.
When you click Finish, Windows Optional Component Manager checks whether COM+ has been set up correctly. If not, Windows Optional Component Manager re-attempts COM+ setup.
If this method does not correct the COM+ setup error (for example, COM+ setup fails again), collect all the error messages found in Setuperr.log, Comsetup.log,

NOTE: Make sure that the identity setting of the IIS Out-of-Process Pooled Applications in component services is set to IWAM_(Computer name) after COM+ setup has finished successfully.

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APPLIES TO
Microsoft COM+ 1.0

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Keywords: 
kbproductlink kberrmsg kbprb kbsysadmin KB246499

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