Dizin Hizmetleri Olay Günlüğünde Çok Sayıda "Olay Kimliği 1216" Olayı

Bu makalede, Dizin Hizmetleri Olay Günlüğü'nde çok sayıda "Olay Kimliği 1216" Olayının oluşması sorununa yönelik bir çözüm sağlanır.

Şunlar için geçerlidir: Windows Server 2012 R2
Özgün KB numarası: 246717

Not

Bu makale, kayıt defterini değiştirme hakkında bilgiler içerir. Kayıt defterini değiştirmeden önce yedeklediğinizden ve bir sorun oluşursa kayıt defterinin nasıl geri yüklendiğini anladığınızdan emin olun. Kayıt defterini yedekleme, geri yükleme ve düzenleme hakkında bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
Microsoft Windows Kayıt Defteri'nin 256986 Açıklaması

Belirtiler

Dizin Hizmetleri olay günlüğünde aşağıdaki girdinin birden çok örneğini bulabilirsiniz:

Olay Türü:Uyarı
Olay Kaynağı:NTDS LDAP
Olay Kategorisi:LDAP Arabirimi
Olay Kimliği:1216
Tarih:<DateTime>
Saat:<DateTime>
Kullanıcı:Yok
Bilgisayar:Bilgisayar
Açıklama:
LDAP sunucusu, 1234 hata koşulu nedeniyle istemciye yuva kapattı. (İç kimlik c01028c::4294967295).

Not

İç Kimlik değeri her örneğe göre değişir.

Neden

Bu olay günlüğü iletisi, Basit Dizin Erişim Protokolü (LDAP) istemcisi Kullanıcı Veri Birimi Protokolü 'nü (UDP) kullanarak bilgisayara bir istek gönderdiğinde oluşur, ancak sunucudan gelen yanıtı dinlemek için yuvasını açık tutmaz. Sunucu yanıtı geri göndermeye çalıştığında, hata iletisi olay günlüğüne kaydedilir. Normal çalışma koşullarında sıklıkla oluşabilecek zararsız bir hatadır. Bu durum yalnızca ldap günlük düzeyini kayıt defterinde 2 veya daha fazla olarak değiştirerek tanılama günlüğü düzeyinin artırılması durumunda oluşur.

Çözüm

Uyarı

Kayıt Defteri Düzenleyicisi'ni yanlış kullanırsanız, işletim sisteminizi yeniden yüklemenizi gerektirebilecek ciddi sorunlara neden olabilirsiniz. Microsoft, Kayıt Defteri Düzenleyicisi'nin yanlış kullanımı sonucunda ortaya çıkan sorunları çözebileceğiniz konusunda garanti vermez. Kayıt Defteri Düzenleyicisi'ni kullanmak kendi sorumluluğunuzdadır.

Bu sorunu çözmek için:

  1. Kayıt Defteri Düzenleyici (Regedt32.exe) başlatın.
  2. Aşağıdaki kayıt defteri anahtarında LDAP Arabirimi Olayları değerini bulun: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NTDS\Diagnostics
  3. LDAP Arabirimi Olayları değerinin veri değerini daha düşük bir ayara ayarlayın ve ardından Tamam'a tıklayın.
  4. Kayıt Defteri Düzenleyicisi'nden çıkın.

Bu kayıt defteri değeri için varsayılan değer 0'dır.