Drucker Orphan Pruner kann alle Objekte drucken Warteschlangen auf Ihre Website Prune.

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 246906 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Problembeschreibung

Alle von der PrintQueue-Objekte von Druckservern auf derselben Site veröffentlicht ein bestimmten Domänencontroller (DC) als erkannt werden kann verwaist und gelöscht, obwohl die entsprechenden Drucker in der Domäne verfügbar sind.

Wenn dieser Fall eintritt, schreibt Drucker Orphan Pruner eine System-Ereignis für jedes PrintQueue-Objekt, das als verwaist erkannt wird. Diese kann bei Sites mit großen Anzahl veröffentlichter Druckwarteschlangen schnell ansammeln. Wenn auf den Standort viele veröffentlichte Drucker vorhanden sind, im Systemereignisprotokoll möglicherweise mit Drucker Orphan Pruner Ereignissen gefüllt werden.

Ursache

Drucker Orphan Pruner erkennt, dass ein bestimmtes PrintQueue-Objekt verwaist durch Kontaktieren des Druckservers und vergleichen das Printer-Objekt auf das Active Directory-Warteschlange-Objekt. Da Drucker Orphan Pruner nur auf Domänencontrollern,, ausführt Wenn ein Domänencontroller im Netzwerk stammt, kann die Drucker Orphan Pruner erhalten Sie beliebige Druckserver und markiert, die alle Drucker als verwaist werden veröffentlicht. Standardmäßig löscht Drucker Orphan Pruner verwaiste Druckern nach drei Mal Prüfung wartet acht Stunden zwischen überprüft. Daher würde standardmäßig ein Domänencontroller verfügen, aus dem Netzwerk entfernt und für mindestens 24 Stunden vor Druckwarteschlagen Objekte gelöscht werden kontinuierlich ausgeführt werden.

Hinweis : eine fehlerhafte DNS-Server oder Router-Konfiguration kann auch einen Domänencontroller werden nicht Druckserver zu suchen und weisen dieses Verhalten verursachen.

Lösung

Um falsche Drucker löschen zu verhindern, während ein DOMÄNENCONTROLLERS aus dem Netzwerk entfernt wird, verwenden Sie eines der folgenden Methoden:
  • Bevor Sie einen Domänencontroller von im Netzwerk für ein Intervall länger als die Verzeichnislöschintervall und Verzeichnislöschwiederholungen Punkte entfernen, legen Sie den Verzeichnislöschintervall -Wert auf nie . Diese Richtlinien befinden sich im Gruppenrichtlinien-Editor unter Computerkonfiguration\administrative Vorlagen\Drucker.
  • Beenden Sie den Spooler-Dienst auf dem Domänencontroller.
Sie können auch die Drucker gelöscht und der Druckserver veröffentlicht Status überprüfen Richtlinien für bestimmte (oder alle) in der Domäne festgelegt werden. Diese Richtlinie verursacht den Spooler auf einem Druckserver, um in regelmäßigen Abständen überprüfen, ob die veröffentlichten Druckern in Active Directory vorhanden sind. Standardmäßig überprüft der Spooler-Dienst den Status der veröffentlichte Drucker nur, wenn er gestartet wird.

Sie sollten die Kontrollkästchen veröffentlicht Status Richtlinie verwenden, nur, wenn Netzwerkausfälle häufig, da die weit verbreitete Verwendung dieser Richtlinie auf vielen Computern in der Domäne (die ständig den Status Publikation Ihre PrintQueue-Objekte in Active Directory überprüfen) Netzwerkleistung negativ auswirken kann. Microsoft empfiehlt, dass Sie diese Richtlinie nur auf der Hauptproduktion Druckserver festzulegen.

Der Dienst für selten Ausfälle, die im Zusammenhang mit Domänencontrollern, die über 24 Stunden und lassen Sie der Computer eingeschaltet, für die Dauer des Ausfalls, Microsoft empfiehlt den Spooler beenden auf den Domänencontrollern.

Weitere Informationen

Weitere Informationen unter Verwendung von Richtlinien zur Steuerelement-Drucker und Orphan Pruner Drucker in Active Directory finden Sie die Artikel der Microsoft Knowledge Base:
234270Mithilfe von Gruppenrichtlinien zum Steuerelement Drucker in Active Directory

Eigenschaften

Artikel-ID: 246906 - Geändert am: Donnerstag, 1. März 2007 - Version: 2.2
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Datacenter Server
Keywords: 
kbmt kbenv kbprb KB246906 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 246906
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com