Una plantilla global dañada produce errores al automatizar Word

Síntomas

Uno o varios archivos de plantilla global no válidos pueden provocar que un cliente de automatización fuera de proceso genere uno de los siguientes mensajes de error:

  • HRESULT: 0x8001010A
    Error de VB: -2147417846
    "El filtro de mensajes indica que la aplicación está ocupada"

  • HRESULT: 0x800A175D
    Error de VB: 5981
    "No se puede abrir el almacenamiento de macros"

  • HRESULT: 0x800A142D
    Error de VB: 5165
    "Word no se puede abrir el [cuadrado] existente"

Causa

El archivo de plantilla global que usa Word puede estar dañado.

Nota:

En Microsoft Office Word 2007, la plantilla global se denomina Normal.dotm. En Microsoft Office Word 2003 y en versiones anteriores de Word, la plantilla global se denomina Normal.dot.

Solución

Si encuentra uno de los errores descritos en la sección Síntomas, puede cambiar temporalmente el nombre de la plantilla global para determinar si es la causa del problema.

Al cambiar el nombre de la plantilla global, se restablecen varias opciones a su configuración predeterminada, incluidos los estilos personalizados, las barras de herramientas personalizadas, las macros y las entradas de Autotexto. Se recomienda cambiar el nombre del archivo de plantilla global en lugar de eliminarlo, de modo que pueda restaurar esta configuración si la plantilla no está dañada.

Algunas instalaciones de Word pueden producir más de un archivo de plantilla global legítimo. Estas situaciones incluyen varias versiones de Word que se ejecutan en el mismo equipo o varios perfiles de usuario en el mismo equipo. En estas situaciones, preste especial atención para que cambie el nombre de la copia correcta de Normal.dot.

Para cambiar el nombre del archivo de plantilla global, siga estos pasos.

Nota:

Puesto que hay varias versiones de Microsoft Windows, los pasos siguientes pueden ser diferentes en su equipo. Si son diferentes, consulte la documentación de su producto para completar estos pasos.

  1. Salga de todas las instancias de Word, incluido WordMail.
  2. Seleccione Iniciar>buscar>archivos o carpetas.
  3. En el cuadro Con nombre, escriba el nombre de plantilla global de la versión de Word.
  4. En el cuadro Buscar en , seleccione la unidad de disco duro local (o una ubicación de plantilla de usuario alternativa si ejecuta Word desde un servidor de red).
  5. Seleccione Buscar ahora para buscar el archivo.
  6. Para cada aparición de plantilla global que aparece en el cuadro de diálogo Buscar , haga clic con el botón derecho en el archivo y, a continuación, seleccione Cambiar nombre. Asigne un nuevo nombre al archivo, como OldNormal.dot o Normal-1.dot.
  7. Minimice el cuadro de diálogo Buscar.
  8. Reinicie el cliente de automatización para iniciar Word.

Si Word se inicia correctamente, ha resuelto el problema. En este caso, el problema es una plantilla global dañada. Es posible que tenga que cambiar algunas opciones para restaurar sus opciones favoritas. Si el archivo de plantilla global al que cambió el nombre contiene personalizaciones, como estilos, macros o entradas de Autotexto que no se pueden volver a crear fácilmente, es posible que pueda copiar esas personalizaciones del archivo de plantilla global antiguo al nuevo archivo de plantilla global mediante el organizador.

Si las personalizaciones de la barra de herramientas se almacenan en una barra de herramientas personalizada, debería poder copiarlas mediante el organizador. Desafortunadamente, si las personalizaciones se realizaron en una de las barras de herramientas integradas de Word, es posible que tenga que volver a crearlas después de cambiar el nombre de la plantilla porque no puede copiar esos cambios con el organizador.

Referencias

Para obtener más información sobre los mensajes de error, vea Error 800A175D: no se pudo abrir el almacenamiento de macros.