Iniciar sessão com a Microsoft
Iniciar sessão ou criar uma conta.
Olá,
Selecione uma conta diferente.
Tem várias contas
Selecione a conta com a qual pretende iniciar sessão.

Sintomas

Depois de instalar um programa no seu computador, o programa não está listado na ferramenta Adicionar/Remover Programas no Painel de Controlo. Além disso, outros programas que estão instalados no seu computador e que foram listados anteriormente em Adicionar/Remover Programas podem já não estar listados.

Causa

Este problema pode ocorrer se o programa que instalou criar um nome de chave de registo com mais de 60 carateres de comprimento. Adicionar/Remover Programas apenas lista os nomes dos programas que localiza até ao ponto em que se depara com esta situação.

Resolução

Importante Esta secção, método ou tarefa contém passos que lhe indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorreta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Para maior segurança, faça uma cópia de segurança do registo antes de o modificar. Deste modo, pode restaurar o registo se ocorrer um problema. Para mais informações sobre como fazer uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para ver o artigo na Base de Dados de Conhecimento Microsoft:

322756 Como fazer uma cópia de segurança e restaurar o registo no WindowsPara contornar este problema, utilize um dos seguintes métodos:

Desinstalar o Programa

O programa de instalação pode detetar que este programa já está instalado no seu computador e fornecer uma opção para o desinstalar. Quando este programa é removido, os outros programas em falta em Adicionar/Remover Programas são listados novamente.

Executar o Programa de Desinstalação Incluído na Pasta de Desinstalação



Alguns programas criam uma pasta na pasta Winnt que contém um caráter "$" no início e no fim do nome da pasta. Esta pasta pode conter um programa de desinstalação que pode executar para remover o programa que instalou anteriormente no seu computador. Tenha em atenção que estas pastas estão normalmente ocultas e que poderá ter de configurar o Explorador do Windows para ver ficheiros e pastas ocultos. Para tal, clique com o botão direito do rato em Iniciar, clique em Explorar, clique em Opções no menu Ver e, em seguida, clique em Mostrar todos os ficheiros.

Utilizar o Comando de Desinstalação apresentado no Registo

  1. Utilize o Editor de Registo (Regedit.exe) para ver a seguinte chave de registo:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall

  2. Faça duplo clique no valor de registo UninstallString, copie o conteúdo da caixa Dados do Valor ao selecionar o conteúdo, premir CTRL+C e, em seguida, sair do Editor de Registo.

  3. Clique em Iniciar, clique em Executar, prima Ctrl+V para colar o comando de desinstalação e, em seguida, clique em OK.

Abreviar o Nome da Chave de Registo

Execute Regedit.exe para ver a seguinte chave de registo:


HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\UninstallClique na chave de registo do programa que instalou, clique em Mudar o Nome no menu Editar e, em seguida, utilize um nome com menos de 60 carateres. Tenha em atenção que, se o valor DisplayName tiver mais de 32 carateres, não será apresentado. Para mudar o nome, faça duplo clique em DisplayName e utilize um nome com até 32 carateres de comprimento.

Estado

A Microsoft confirmou que se trata de um problema nos produtos Microsoft listados no início deste artigo.

Mais Informações

Os programas são ordenados alfabeticamente na chave de registo Desinstalar e todas as chaves listadas após o nome da chave longa são ignoradas.

Precisa de mais ajuda?

Quer mais opções?

Explore os benefícios da subscrição, navegue em cursos de formação, saiba como proteger o seu dispositivo e muito mais.

As comunidades ajudam-no a colocar e a responder perguntas, a dar feedback e a ouvir especialistas com conhecimentos abrangentes.

Estas informações foram úteis?

Quão satisfeito está com a qualidade do idioma?
O que afetou a sua experiência?
Ao selecionar submeter, o seu feedback será utilizado para melhorar os produtos e serviços da Microsoft. O seu administrador de TI poderá recolher estes dados. Declaração de Privacidade.

Obrigado pelo seu feedback!

×