Chkdsk tidak menggunakan sektor Boot cadangan untuk memperbaiki sektor Boot FAT32 rusak

Terjemahan Artikel Terjemahan Artikel
ID Artikel: 247575 - Melihat produk di mana artikel ini berlaku.
Pemberitahuan
Artikel ini berlaku untuk Windows 2000. Dukungan untuk Windows 2000 berakhir pada 13 Juli 2010. The Pusat Solusi Windows 2000 akhir dukungan adalah titik awal untuk perencanaan strategi migrasi dari Windows 2000. Untuk informasi lebih lanjut lihat Microsoft Support Lifecycle Policy.
Perbesar semua | Perkecil semua

GEJALA

Jika FAT32 volume menjadi rusak atau tidak dapat diakses dan Anda mencoba untuk memperbaiki volume yang menggunakan alat Chkdsk (Chkdsk.exe), sistem file mungkin dilaporkan dengan benar sebagai FAT32 (atau mungkin sebagai baku, tergantung pada kerusakan), tapi alat Chkdsk segera berhenti tanpa membuat perbaikan. Sebagai contoh, jika Anda menggunakan Chkdsk e:/f perintah, akan muncul pesan berikut:
Jenis sistem berkas adalah FAT32.
Volume nomor seri adalah C408-2213
Jika Anda menjalankan Chkdsk lagi tanpa switch baris perintah apa pun, itu masih menunjukkan volume rusak. Jika Anda menggunakan Chkdsk e: perintah, akan muncul pesan berikut:
Jenis sistem berkas adalah FAT32.
Volume nomor seri adalah C408-2213

Ditemukan kesalahan. CHKDSK tidak dapat melanjutkan pada mode baca-saja.

PENYEBAB

Perilaku ini terjadi karena sistem file FAT32 berisi salinan cadangan dari sektor boot. Namun, Chkdsk.exe tidak berusaha untuk menggunakan FAT32 cadangan sektor boot kecuali sektor boot primer secara fisik terletak di sektor buruk dan Chkdsk.exe menerima pesan kesalahan I/O saat mencoba membaca volume. Chkdsk.exe tidak mencoba untuk menggunakan salinan cadangan karena salinan utama rusak atau berisi informasi yang tidak valid.

PEMECAHAN MASALAH

Jika Anda memiliki sektor boot primer yang rusak, Anda dapat menggunakan alat Dskprobe (Dskprobe.exe) untuk membuat perbaikan dengan menyalin sektor boot cadangan atas sektor boot utama rusak.

Sektor boot primer adalah sektor 0 drive logis. Sektor boot FAT32 cadangan terletak di sektor 6 drive logis. Sementara dalam byte pandangan, membaca sektor enam dari pengandar logis dan menulis lebih dari sektor nol drive logis.

Menggunakan langkah-langkah berikut untuk memulihkan cadangan FAT32 sektor boot.

CATATAN: Untuk memastikan perbaikan operasi berhasil, menjaga Dskprobe.exe dalam pandangan byte sepanjang prosedur ini.
  1. Ambil Dskprobe.exe dari file Support\Tools\Support.cab terletak di CD-ROM penginstalan Windows 2000.
  2. Jalankan Dskprobe.exe.
  3. Pada Drive menu, klik Pengandar logis, kemudian klik dua kali Hurufkandar (di mana Hurufkandar adalah FAT32 volume yang ingin Anda perbaiki).
  4. Klik untuk menghapus Hanya membaca Periksa kotak, klik set aktif, lalu klik Oke.
  5. Pada Sektor menu, klik Baca, dan kemudian mengubah default Sektor awal nilai dari 0 6 (tidak berubah Jumlah sektor = 1 nilai). Tindakan ini membaca sektor boot FAT32 cadangan.
  6. Pada Sektor menu, klik Menulis.
  7. Verifikasi bahwa menangani aktif masih huruf pengandar logis dari volume yang diperbaiki, mengubah mulai sektor untuk menulis data nilai dari 6 ke 0, dan kemudian klik Menulis itu. Klik Ya untuk mengkonfirmasi Anda ingin menimpa sektor 0 pada perangkat Hurufkandar.
  8. Berhenti Dskprobe.exe dan menjalankan Chkdsk lagi terhadap volume diperbaiki menggunakan perintah berikut:
    Chkdsk Hurufkandar:
    CATATAN: Menggunakan / f beralih jika volume memerlukan tambahan memperbaiki.

STATUS

Microsoft telah menegaskan hal ini merupakan masalah di dalam Microsoft Windows 2000.

INFORMASI LEBIH LANJUT

246146 Dskprobe.exe dapat merusak sektor Boot FAT32

Properti

ID Artikel: 247575 - Kajian Terakhir: 21 September 2011 - Revisi: 2.0
Berlaku bagi:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Kata kunci: 
kbbug kbenv kbpending kbmt KB247575 KbMtid
Penerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:247575

Berikan Masukan

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com