Article ID: 247641 - Last Review: March 14, 2006 - Revision: 2.1 FIX: Trusted TCP/IP Socket Connection May Fail with Error Message 18452This article was previously published under Q247641
BUG #: 56445 (SQLBUG_70)
SYMPTOMS
Under certain situations, a client may fail to connect to SQL Server 7.0 when using TCP/IP sockets and Microsoft Windows NT authentication (trusted connection), and the following error message is displayed:
Error 18452: Login failed for user 'null'. Reason: Not associated with a trusted SQL Server connection.
Server: Msg 7619, Level 16, State 1, Line 1 Access is denied.
CAUSE
This problem is more likely to occur when both Multi-Protocol and TCP/IP sockets trusted connections are attempted from the same client computer. Connection stress also makes the problem more likely to occur.
WORKAROUND
Use one of the following workarounds:
STATUS
Microsoft has confirmed this to be a problem in SQL Server 7.0. This problem has been corrected in U.S. Service Pack 2 for Microsoft SQL Server 7.0. For more information, click the following article number to view the article in the Microsoft Knowledge Base: 254561
(http://support.microsoft.com/kb/254561/
)
INF: How to Obtain Service Pack 2 for Microsoft SQL Server 7.0 and Microsoft Data Engine (MSDE) 1.0 For more information, contact your primary support provider.
MORE INFORMATION
This same error message may occur under normal SQL Server operations when many simultaneous trusted connections are attempted through TCP/IP sockets. This is due to the server and network being too busy, causing SSPI communication timeout, which in turn causes trusted connection timeouts. However, these intermittent connection timeouts will not affect SQL Server accepting new connections, and should not be a cause for concern.
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