Article ID: 248033 - View products that this article applies to.
This article was previously published under Q248033
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Symptoms

When a Web page is requested, you receive the following error message at the top of the Web browser:
The page cannot be found
The page you are looking for might have been removed, had its name changed, or is temporarily unavailable.
You receive the following error message further down on the Web page:
HTTP 404 - File not found
Internet Information Services

Cause

The Web server returns the "HTTP 404 - File not found" error message when it cannot retrieve the page that was requested.

The following are some common causes of this error message:
  • The requested file has been renamed.
  • The requested file has been moved to another location and/or deleted.
  • The requested file is temporarily unavailable due to maintenance, upgrades, or other unknown causes.
  • The requested file does not exist.
  • IIS 6.0: The appropriate Web service extension or MIME type is not enabled.
  • A virtual directory is mapped to the root of a drive on another server.

Resolution

To resolve this problem, verify that the file requested in the browser's URL exists on the IIS computer and that it is in the correct location.

Use the IIS Microsoft Management Console (MMC) snap-in to determine where the file requested must exist in the IIS computer's file system.

This is particularly important if the Web site uses a virtual directory (VDIR). A VDIR is a directory that is not contained in the home directory of the Web site, but appears to client browser as though it does. This virtual directory must be mapped to a subfolder on a drive or reference the files by name.

For example, assume that the URL that caused the 404 error is http://Microsoft.Com/Test/File1.htm, and the IIS snap-in shows that for Microsoft.Com Web site, the /Test/ directory is actually a virtual directory that maps to the location of c:\Information on the IIS computer. This means that you must verify that the File1.htm file is located in the c:\Information directory (and that the file name is spelled correctly).

IIS6 Dynamic Content: A 404.2 entry in the W3C Extended Log file is recorded when a Web Extension is not enabled. Use the IIS Microsoft Management Console (MMC) snap-in to enable the appropriate Web extension. Default Web Extensions include: ASP, ASP.net, Server-Side Includes, WebDAV publishing, FrontPage Server Extensions, Common Gateway Interface (CGI). Custom extensions must be added and explicitly enabled. See the IIS 6.0 Help File for more information.
IIS6 Static Content: A 404.3 entry in the W3C Extended Log file is recorded when an extension is not mapped to a known extention in the MIME Map property. Use the IIS Microsoft Management Console (MMC) snap-in to configure the appropriate extension in the MIME Map. See the IIS 6.0 Help file for more information.

For more information about other, less common causes of this error message, click the following article numbers to view the articles in the Microsoft Knowledge Base:
247714 Using PUT command for a long file name causes "HTTP 404 - File not found" error
221553 Setting file attributes on Web content causes 404 - File not found error
216803 IIS hidden static files return HTTP 404 or access denied errors
288123 HTTP Error 404 "Page cannot be displayed" when you attempt to connect to the OWA server after you upgrade from Exchange Server 5.5 to Exchange 2000 Server

More information

For more information about virtual directories, see the "About Web site management" topic in the IIS 5.0 documentation at the following location:
Administration\Web Site Management\About Web Site Management
Note If you have the IIS 5.0 documentation installed on your local computer, you can use the following URL to locate this topic:
http://localhost/iishelp/iis/htm/core/iihtmat.htm#virtualdirectories
To view this topic on a Microsoft Windows Server 2003-based computer that has IIS installed, paste the following link in the address bar of your browser, and then press ENTER:
mk:@MSITStore:C:\WINDOWS\help\iismmc.chm::/HTM/qss_wss_troubleshooting.htm
Note C:\Windows represents the system root. If your Windows operating system is installed on a different drive, you must edit the link as appropriate.

You can also access the product documentation through the IIS Manager. For more information about how to access this Help feature, click the following article number to view the article in the Microsoft Knowledge Base:
815127 How to access IIS 6.0 Help documentation
NoteWe strongly recommend that all users upgrade to Microsoft Internet Information Services (IIS) version 7.0 running on Microsoft Windows Server 2008. IIS 7.0 significantly increases Web infrastructure security. For more information about IIS security-related topics, visit the following Microsoft Web site:
http://www.microsoft.com/technet/security/prodtech/IIS.mspx
For more information about IIS 7.0, visit the following Microsoft Web site:
http://www.iis.net/

Properties

Article ID: 248033 - Last Review: November 20, 2012 - Revision: 14.0
Applies to
  • Microsoft Internet Information Server 1.0
  • Microsoft Internet Information Server 2.0
  • Microsoft Internet Information Server 3.0
  • Microsoft Internet Information Services 6.0
  • Microsoft Internet Information Services 7.0
Keywords: 
kbresolve kbhttp404 kbprb kbprod2web KB248033

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