Problemas de instalación de programa en Sysprep o RIPrep instalación Systems

Seleccione idioma Seleccione idioma
Id. de artículo: 248257 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
Expandir todo | Contraer todo

En esta página

Síntomas

Puede experimentar problemas al instalar programas que utilizan el valor de shell en la siguiente ubicación del registro para obtener la configuración de Explorer.exe:
HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\Shell
Rutina de instalación del programa puede o no genera mensajes de error, pero todos tienen el mismo problema resultante: el programa no coloca iconos en la carpeta Inicio Inicio\Programas. Este comportamiento se produce sólo si Sysprep.exe o RIPrep.exe se utilizó para crear la imagen maestra.

Causa

La entrada del Registro siguiente contiene una coma al final del valor:
HKEY_LOCAL_MACHINE\Software\Microsoft\WindowsNT\CurrentVersion\Winlogon\Shell:REG_SZ:C:\Winnt\Explorer.exe,
El punto y coma final hace que este problema.

Solución

Para resolver este problema, obtenga el Service Pack más reciente de Windows 2000. Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
260910Cómo obtener el Service Pack más reciente para Windows 2000

Solución

Para corregir imágenes creadas con cualquiera Sysprep o RIPrep

  1. Cree un archivo de texto con el siguiente contenido:
    Editor del Registro de Windows versión 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon]
    "Shell"="Explorer.exe"
  2. Guarde el archivo. Asígnele el nombre Shell.reg (sin una extensión .txt).
  3. Cree un archivo denominado Cmdlines.txt que incluya las líneas siguientes:
    [Comandos]
    "regedit /s c:\sysprep\i386\$oem$\shell.reg"

Para corregir imágenes creadas con Sysprep.exe

  1. Busque la carpeta Sysprep\I386 en la imagen de Sysprep y, a continuación, cree una subcarpeta $OEM$ en esta carpeta.
  2. Copie los archivos Shell.reg y Cmdlines.txt en la carpeta Sysprep\I386\ $ OEM $.
  3. En el archivo Sysprep.inf, agregue una clave InstallFilesPath a la sección [Unattended]. Esta clave debe tener el valor siguiente:
    InstallFilesPath = "C:\sysprep\i386"
Cuando se ejecuta la ejecución del Asistente para la mínima, la clave del registro cambia a su valor original correcto.

Para corregir imágenes creadas con RIPrep.exe

  1. En el servidor de instalación remota que contiene la imagen RIPrep, cree una carpeta Sysprep\I386\ $ OEM $ en la carpeta siguiente:
    RemoteInstall\Setup\ Language \Images\ Riprep_dir_name \I386\Mirror1\UserData
  2. Copia el los archivos Shell.reg y Cmdlines.txt en la nueva carpeta $ OEM $.
  3. Modificar el archivo de \I386\Templates\Riprep.sif RemoteInstall\Setup\ Language \Images\ Riprep_dir_name (y cualquier otro archivo de plantilla para esta imagen de RIPrep que haya creado) para sumar los valores OemPreinstall e InstallFilesPath para que aparezcan como sigue:
    [Desatendida]
    OemPreinstall = "Sí"
    InstallFilesPath = "C:\sysprep\i386"
  4. Cierre y guarde el archivo.
Cuando se ejecuta la ejecución del Asistente RIPrep para mínima, la clave del registro cambia a su valor original correcto.

Nota : debe utilizar estos pasos para cada imagen de RIPrep o Sysprep que se haya creado. Si ya ha implementado sistemas y utiliza Active Directory, puede utilizar el método siguiente para corregir el los sistemas:
  1. Crear un archivo por lotes denominado Fix.cmd en un recurso compartido de red para que el grupo Todos tiene acceso de lectura.
  2. Copie el archivo Shell.reg a este recurso compartido de red.
  3. En el archivo por lotes, coloque el comando siguiente:
    Regedit /s sharename \shell.reg
  4. Modifique o cree un nuevo objeto de directiva de grupo (GPO) que se aplicará a los sistemas que deben actualizarse con este archivo. reg. Para información acerca de crear o modificar GPO, consulte la documentación de Kit de recursos de Microsoft Windows 2000.
  5. Edite el GPO en Settings\Scripts\Startup de configuración del equipo. Agregue el archivo Fix.cmd.
Si no utiliza Active Directory, debe aplicar esta secuencia de comandos a los clientes mediante otros métodos, como las secuencias de comandos de inicio de sesión.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:" de este artículo. Este problema se corrigió por primera vez en Windows 2000 Service Pack 1.

Propiedades

Id. de artículo: 248257 - Última revisión: domingo, 02 de febrero de 2014 - Versión: 3.4
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palabras clave: 
kbnosurvey kbarchive kbmt kbhotfixserver kbqfe kbbug kbenv kbfix kbqfe kbsetup kbwin2000sp1fix KB248257 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 248257

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com