Ověřování pomocí protokolu Kerberos se nezdaří po upgradu ze služby IIS 4.0 na službu IIS 5.0 (Tento článek může obsahovat odkazy na anglický obsah (dosud nepřeložený).)

Překlady článku Překlady článku
ID článku: 248350 - Produkty, které se vztahují k tomuto článku.
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Důležité: Tento článek obsahuje informace o úpravě metabáze. Před úpravou metabázi ověřte, zda máte záložní kopii můžete obnovit, pokud dojde k potížím. Informace o tomto postupu najdete v tématu nápovědy Configuration Backup/Restore (Zálohování a obnovení konfigurace) v konzole MMC (Microsoft Management Console).
Rozbalit všechny záložky | Minimalizovat všechny záložky

Příznaky

Při inovaci počítače se systémem Windows NT Server 4.0 s Internet Information Server 4.0 nainstalován systém Windows 2000 s Internetová informační služba 5.0 ověřování Kerberos může selhat. Vyjednat metodu nelze použít webovým serverem, i když je vybrána integrované ověřování systému Windows.

Při provést trasování v síti ze vzdáleného klientského počítače pomocí programu Sledování sítě se obvykle zobrazí v záhlaví WWW-Authenticate klientovi odeslána následující:
WWW-Authenticate: Negotiate
WWW-Authenticate: NTLM
Pokud spustíte stejné trasování v síti počítače, který byl inovován ze systému Windows NT 4.0 Windows 2000, se může zobrazit pouze záhlaví NTLM WWW-Authenticate klientovi odeslány (Negotiate odeslána klientovi). Například:
WWW-Authenticate: NTLM

Příčina

Chcete-li zachovat výchozí metoda ověřování, který se používá v Internet Information Server 4.0, nastavení metabáze NTAuthenticationProviders nebyl změněn. Výchozí nastavení pro tento klíč metabáze je "NTLM" v Internet Information Server 4.0; však to byl změněn v Internetová informační služba 5.0 tak, aby nové vyjednat metodu můžete použít "Negotiate, NTLM."

Pokud proveďte čistou instalaci systému Windows 2000 (nikoli na upgrade) klíč bude odrážet výchozí v Internetová informační služba 5.0 jako "Negotiate, NTLM."

Řešení

Chcete-li tento problém vyřešit, musíte upravit metabázi.

Upozornění: Pokud upravit metabázi nesprávně, můžete způsobit vážné problémy, které mohou vyžadovat přeinstalaci produktu, jenž metabázi využívá. Společnost Microsoft nemůže zaručit, že potíže vzniklé v důsledku nesprávné úpravy metabáze budete moci vyřešit. Metabázi upravujete na vlastní nebezpečí.

Poznámka: vždy zálohovat metabázi před jeho úpravou.

Změna hodnoty NTAuthenticationProviders následujících kroků:
  1. Otevřete příkazový řádek (Cmd.exe).
  2. Změňte adresář c:\inetpub\adminscripts. Všimněte si, že tato cesta je cesta výchozí a může být odlišné od Tvé Pokud změně oblasti obsahu nebo nainstalovány jiné písmeno jednotky.
  3. Určení hodnoty NTAuthenticationProviders, zadejte následující a stisknutím klávesy ENTER:
    cscript adsutil.vbs get w3svc/NTAuthenticationProviders
    By měl vrátit následující výstup:
    NTAuthenticationProviders: (STRING) "NTLM"
  4. Pokud je hodnota NTAuthenticationProviders "NTLM", potom zadejte následující (přesně):
    cscript adsutil.vbs set w3svc/NTAuthenticationProviders "Negotiate,NTLM"
    Stiskněte klávesu ENTER. Měli byste obdržet následující výstup:
    NTAuthenticationProviders: (STRING) "Negotiate, NTLM"
Pokud se chybová v posledním kroku zkontrolujte, zda není ponechali mezeru mezi Negotiate a NTLM. Například "Negotiate, NTLM" liší od "Negotiate, NTLM."

Prohlášení

Společnost Microsoft potvrzuje, že se jedná o problém v Internetová informační služba verze 5.0.

Odkazy

Další informace o použití nástroje Sledování sítě v počítačích se systémem Windows 2000 Server klepněte na následující číslo článku databáze Microsoft Knowledge Base:
812953Jak pomocí programu Sledování sítě sběr zatížení sítě

Vlastnosti

ID článku: 248350 - Poslední aktualizace: 2. února 2014 - Revize: 2.1
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Internet Information Services 5.0
Klíčová slova: 
kbnosurvey kbarchive kbmt kbbug kbpending KB248350 KbMtcs
Strojově přeložený článek
Důležité: Tento článek byl přeložen pomocí software společnosti Microsoft na strojový překlad, ne profesionálním překladatelem. Společnost Microsoft nabízí jak články přeložené překladatelem, tak články přeložené pomocí software na strojový překlad, takže všechny články ve Znalostní databázi (Knowledge Base) jsou dostupné v češtině. Překlad pomocí software na strojový překlad ale není bohužel vždy dokonalý. Obsahuje chyby ve skloňování slov, skladbě vět, nebo gramatice, podobně jako když cizinci dělají chyby při mluvení v češtině. Společnost Microsoft není právně zodpovědná za nepřesnosti, chyby nebo škody vzniklé chybami v překladu, nebo při použití nepřesně přeložených instrukcí v článku zákazníkem. Společnost Microsoft aktualizuje software na strojový překlad, aby byl počet chyb omezen na minimum.
Projděte si také anglickou verzi článku:248350

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com