Windows Search Service will not start, Error: "The Windows Search service on local computer started and then stopped. Some services stop automatically if they are not in use by other services or programs"

Article translations Article translations
Close Close
Article ID: 2484025 - View products that this article applies to.
Support for Windows Vista Service Pack 1 (SP1) ends on July 12, 2011. To continue receiving security updates for Windows, make sure you're running Windows Vista with Service Pack 2 (SP2). For more information, refer to this Microsoft web page: Support is ending for some versions of Windows.
Expand all | Collapse all

SYMPTOMS

Windows Search Service may not start and when attempting to start the service manually, you may get the following error:

========
Services
========
"The Windows Search service on local computer started and then stopped. Some services stop automatically if they are not in use by other services or programs"
===
OK
===

CAUSE

You may see this issue if there are missing subkeys or registry entries under the following registry location:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\CrawlScopeManager\Windows\SystemIndex

Or if there are corrupted log files at the following location:

C:\windows\system32\config\TxR


Note: The above regisrty key is unique to each machine, so should not be replaced manually.

RESOLUTION

To resolve this issue, delete all files with .BLF and .REGTRANS-MS extension in the following directory:

C:\windows\system32\config\TxR

Note: The files in the folder location above are hidden and will thus not be visible unless you set the system to not Hide Protected Operating System Files under Tools - Folder Options.

Once these files are deleted, reboot the machine. Once rebooted, observe that the Windows Search service has already started and is in process of rebuilding the Index.

Note: You may observe High CPU while the Search Index is being rebuilt.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2484025 - Last Review: June 10, 2011 - Revision: 1.1
APPLIES TO
  • Windows Vista Business
  • Windows Vista Business 64-bit Edition
  • Windows Vista Enterprise
  • Windows Vista Enterprise 64-bit Edition
  • Windows Vista Home Basic
  • Windows Vista Home Basic 64-bit Edition
  • Windows Vista Home Premium
  • Windows Vista Home Premium 64-bit Edition
  • Windows Vista Service Pack 1
  • Windows Vista Service Pack 2
  • Windows Vista Ultimate
  • Windows Vista Ultimate 64-bit Edition
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Service Pack 1
  • Windows 7 Ultimate
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Service Pack 1
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Service Pack 2
  • Windows Server 2008 Standard
Keywords: 
KB2484025

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com