FIX: Non-XML messages are suspended at a send port that uses the PassThruTransmit pipeline if a BAM tracking profile is applied in BizTalk Server 2010

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Article ID: 2486267 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario:
  • On a computer that is running Microsoft BizTalk Server 2010, you create a send port that uses the PassThruTransmit pipeline.
  • You create and then deploy a Business Activity Monitoring (BAM) activity.
  • You create a tracking profile that is based on the BAM activity definition, and then you apply this tracking profile.
  • A non-XML message arrives at the send port.

    Note To do this, you can create a receive location that uses the PassThruReceive pipeline, and then you can send a non-XML message to the receive location. 

In this scenario, the message is suspended on the send port. Additionally, an event that resembles one of the following is logged.

Note The event details may vary, based on different scenarios.

Event 1
Log Name: Application
Source: BizTalk Server
Event ID: 5720
Task Category: BizTalk Server
Level: Error
Keywords: Classic
Description:
There was a failure executing the send pipeline: "Microsoft.BizTalk.DefaultPipelines.PassThruTransmit, Microsoft.BizTalk.DefaultPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" Source: "Unknown " Send Port: "send_port" URI: "URI" Reason: Unexpected end of document. This is not a new document. The dissassembly is incomplete.


Event 2
Log Name: Application
Source: BizTalk Server
Event ID: 5754
Task Category: BizTalk Server
Level: Error
Keywords: Classic
Description:
A message sent to adapter "FILE" on send port "send_port" with URI "URI" is suspended.
Error details: Unable to read the stream produced by the pipeline.

CAUSE

This problem occurs because the BizTalk tracking engine examines the message body for XML content when BAM tracking is enabled. This occurs even when the PassThruTransmit pipeline is used.

RESOLUTION

Cumulative update information

The fix for this issue was first released in Cumulative Update 1. For more information about how to obtain this cumulative update package for BizTalk Server 2010, click the following article number to view the article in the Microsoft Knowledge Base:
2497789 Cumulative update package 1 for BizTalk Server 2010

WORKAROUND

In some scenarios, you may be able to work around this problem. To do this, do one of the following:
  • Remove the BAM tracking profile. When you do this, you receive no new BAM tracking data.

    For more information about how to do this, visit the following Microsoft Developer Network (MSDN) website:
    Tracking Profile Deployment Utility
  • Use an XML-formatted message on the send port, or ask the sender to change the format of the message to XML.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about default pipelines, visit the following Microsoft Developer Network (MSDN) website:
Microsoft.BizTalk.DefaultPipelines Reference
For more information about BizTalk Server hotfixes, click the following article number to view the article in the Microsoft Knowledge Base:
2003907 Information about BizTalk Server hotfixes

Properties

Article ID: 2486267 - Last Review: May 23, 2011 - Revision: 1.0
APPLIES TO
  • Microsoft BizTalk Server Branch 2010
  • Microsoft BizTalk Server Developer 2010
  • Microsoft BizTalk Server Enterprise 2010
  • Microsoft BizTalk Server Standard 2010
Keywords: 
kbqfe kbfix kbexpertiseinter kbsurveynew kbbtsbam KB2486267

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