How To Manually Uninstall Visual Studio with MSDN Library

Article translations Article translations
Article ID: 248697 - View products that this article applies to.
This article was previously published under Q248697
Expand all | Collapse all

SUMMARY

This article describes how to manually remove Visual Studio 6.0 and the MSDN Library, as well as any other HTML Help collections installed on the system. When you manually uninstall Visual Studio, you must uninstall the MSDN Library as well.

The following steps are required also if you want to change the location of the installed product. This is because of the registry entries that remain present even if you have removed the product by using the Add/Remove Programs utility in Control Panel.

NOTE: Only use this procedure as a last resort. Whenever possible, remove Visual Studio 6.0 and the MSDN Library by using the Add/Remove Programs utility in Control Panel.

MORE INFORMATION

WARNING: These steps will remove all Visual Studio and earlier language programs from the system. This includes but is not limited to the Visual Studio subcomponents. Microsoft Visual Basic, Visual C++, Visual J++, and Visual InterDev installations and all customizations for these products will be lost.

WARNING: These steps will remove all HTML Help collections from the system. This includes but is not limited to MSDN Library installations and the Platform SDK documentation. All customizations for these collections will be lost.

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756 How to back up and restore the registry in Windows


Before you begin:
  • If your computer is running Windows NT, make sure you are using administrator permissions.
  • Close all running applications.

If the operating system is Windows 2000, first change the settings to view all the hidden files and folders on the system:
  1. Open Windows Explorer.
  2. From the Tools menu, choose Folder Options.
  3. Click the View tab.
  4. Under Advanced settings, select Show hidden files and folders.

If the operating system is Windows 95, Windows 98, or Windows NT 4.0, first change the settings to view all the hidden files and folders on the system:
  1. Open Windows Explorer.
  2. From the View menu, choose Folder Options.
  3. Click the View tab.
  4. Under Advanced settings, select Show hidden files and folders.

The following steps will completely remove all Visual Studio and MSDN Library Components from the system.

NOTE: If any one step fails continue to the next step:
  1. Use Add/Remove Programs in Control Panel to remove the Visual Studio installations listed.
  2. Use Add/Remove Programs to remove any other language programs, such as Visual Basic, Visual C++, Visual J++, and Visual InterDev, and all customizations for these products.
  3. Use Add/Remove Programs in Control Panel to remove all MSDN Library installations listed.
  4. Use Add/Remove Programs to uninstall any other HTML Help collections, such as the Platform SDK documentation.
  5. On the Start menu, point to Search (Windows 2000) or Find (Windows 95/Windows 98 or Windows NT), and click (For) Files or Folders.
  6. Search for and delete all occurrences of the following files on your local hard drives:
    *.CHK
    *.TMP
    HH.EXE
    HH.DAT
    HHCOLREG.DAT
    VIEWS.PRF (user files)
    CMDUI.PRF (user files)
    TOOLBOX.TBD (user files)
    HHCTRL.OCX *** do not delete from computers running Windows 2000, Windows XP, or Windows Server 2003 ***
    ITSS.DLL *** do not delete from computers running Windows 2000, Windows XP, or Windows Server 2003 ***
    ITIRCL.DLL *** do not delete from computers running Windows 2000, Windows XP, or Windows Server 2003 ***
    NOTE: Some of the files listed may not be found on your system. Skip these files and continue.
  7. Delete the installation folders for any Visual Studio products. Note that the following are the default locations; the actual locations may be different on your system if you did a custom installation:
    \Program Files\Microsoft Visual Studio
    \Program Files\Common Files\Microsoft Shared\MSDesigners98
    \Program Files\Common Files\Microsoft Shared\MSDN
    \Program Files\Common Files\Microsoft Shared\VS98
    \Program Files\Common Files\Microsoft Shared\Wizards98
  8. Delete the installation folders for any MSDN Libraries (the previous step may have deleted these if they were installed to the default location). The default folders are as follows:
    Program Files\Microsoft Visual Studio\MSDN98 (for the MSDN Library for Visual Studio 6.0)
    Program Files\Microsoft Visual Studio\MSDN (for the MSDN Quarterly Library releases)
    					
  9. Use Regedit.exe to delete the following Registry keys if they exist:
    HKEY_LOCAL_MACHINE\Software\Microsoft\DevStudio
    HKEY_LOCAL_MACHINE\Software\Microsoft\MSVSDG
    HKEY_LOCAL_MACHINE\Software\Microsoft\HTML Help Collections
    HKEY_LOCAL_MACHINE\Software\Microsoft\Visual Basic\6.0
    HKEY_LOCAL_MACHINE\Software\Microsoft\Visual Component Manager
    HKEY_LOCAL_MACHINE\Software\Microsoft\Visual Modeler
    HKEY_LOCAL_MACHINE\Software\Microsoft\VisualStudio\6.0
    HKEY_CURRENT_USER\Software\Microsoft\DevStudio
    HKEY_CURRENT_USER\Software\Microsoft\MSVSDG
    HKEY_CURRENT_USER\Software\Microsoft\Visual Basic\6.0
    HKEY_CURRENT_USER\Software\Microsoft\Visual Modeler
    HKEY_CURRENT_USER\Software\Microsoft\VisualFoxPro
    HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\6.0
    					
  10. WARNING: Do not delete the "Uninstall" key; only delete MSDN or Visual Studio keys listed within it!

    Use Regedit.exe to delete any instance of the key for Visual Studio or MSDN Library under the following key:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall
    					
  11. Empty the Recycle Bin.
  12. Restart the system and disable any anti-viral software.
  13. Update the HTML Help system by running the HTML Help update available from the following Microsoft Web site:
    http://msdn.microsoft.com/en-us/library/ms669985.aspx
  14. Reinstall Visual Studio and the MSDN Library.
  15. Reapply the current Visual Studio service pack.
  16. Test the product.
WARNING: On Windows 2000, these steps can cause problems for the Administrative Tools (Microsoft Management Console [MMC], services, Event Viewer, and so forth). The Help files for these tools may not work. To fix this, you must also do the following on Windows 2000:
  1. Locate the path containing user profiles. By default this is C:\Documents and Settings. For an upgrade, it may be located under WindowsDirectory\Profiles.
  2. For each user, go to UserProfileDirectory\Local Settings\Temp.
  3. Delete all collection files (.col) from this directory.

REFERENCES

For additional information, click the article number below to view the article in the Microsoft Knowledge Base:
240350 How To Manually Uninstall the MSDN Library
201420 How To Manually Uninstall and Update HTML Help
216109 How To Troubleshoot MSDN Library Run-Time/Install/Uninstall Problems

Properties

Article ID: 248697 - Last Review: August 15, 2005 - Revision: 3.4
APPLIES TO
  • Microsoft Visual Studio 6.0 Enterprise Edition
  • Microsoft Visual Studio 6.0 Service Pack 1
  • MSDN 2003 Universal Edition
Keywords: 
kbhowto KB248697

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com