Artigo: 248993 - Última revisão: quinta-feira, 1 de Março de 2007 - Revisão: 3.3

PROBLEMA: O objecto de desempenho não é apresentado no Monitor de desempenho

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando utilizar a ferramenta Monitor de desempenho (ou snap-in System Monitor Microsoft Management da consola [MMC]) um objecto de desempenho poderá inesperadamente não aparecem na caixa Objecto de desempenho de lista pendente na caixa de diálogo Adicionar para o gráfico .

Causa

O problema pode ocorrer porque o desempenho extensível DLL está marcado como "desactivado".

Resolução

O objecto pode ser reactivado, definindo o valor de registo "Desactivar os contadores de desempenho" na subchave de desempenho do serviço suportada para a extensão.

Ponto Da Situação

Este comportamento ocorre por predefinição.

Mais Informação

Nas versões do Windows NT anteriores ao Windows 2000, um desempenho de danificado ou defeituoso DLL é capaz de processar as funcionalidades do sistema operativo inoperante monitorização do desempenho. Para manter a integridade dos dados de desempenho e melhorar a fiabilidade, a biblioteca de desempenho do Windows 2000 desactiva qualquer desempenho DLL que devolve dados em formato incorrecto, provoca um erro de programa não processado ou demora demasiado tempo a devolver os dados de desempenho (esta normalmente é a causa de uma biblioteca está desactivada).

Quando uma extensão de desempenho que dll está desactivada, os contadores de desempenho fornecidos por essa DLL não estão disponíveis através do Monitor de desempenho ou a API de Gestor da impressão em dados de desempenho. DLL desactivadas não estão carregadas quando o sistema é reiniciado.

Se uma extensão de desempenho que dll torna-se desactivadas inesperadamente, verifique o registo aplicação eventos para eventos 1017 ou 1018 (os eventos "Desactivar") registado pela origem de Perflib. Em seguida, procure outros eventos registados por Perflib fornecerá as razões por que razão o sistema desactivado a extensão. Estes eventos devem ser indicado se terá de contactar o suporte técnico.

Pode tentar reactivar a DLL de extensão. Se o problema persistir (ou seja, o sistema desactiva-lo novamente) deverá contactar o fornecedor a extensão. Se o objecto for um contacto de objecto (como, por exemplo, o objecto Process) do sistema Windows 2000 serviços de suporte técnico da Microsoft (PSS).

Para reactivar uma DLL de extensão, a Microsoft recomenda que utilize o utilitário ExCtrlList do Windows 2000 Resource Kit. Em alternativa, pode utilizar a ferramenta de editor de registo (Regedit.exe) fornecido com o Windows 2000.

Reactivar uma extensão utilizando ExCtrlLst

  1. Inicie Exctrlst.exe. Esta é uma ferramenta a partir do Windows 2000 Resource Kit.
  2. Seleccione o primeiro item na caixa de listagem contadores de desempenho extensível.
  3. Verifique se a caixa de verificação Activa contadores de desempenho , que aparece exactamente abaixo da caixa de listagem. Se a caixa de verificação estiver seleccionada, o contador está activado. Se estiver desmarcada, seleccione a caixa de verificação reactivá-lo.
  4. Seleccione o item seguinte na caixa de listagem Contadores de desempenho extensível e repita os dois passos anteriores até que todos os itens tenham a caixa de verificação Activa contadores de desempenho seleccionada.

Reactivar uma extensão utilizando o Regedit.exe

importante Esta secção, método ou tarefa contém passos que indicam como modificar o registo. No entanto, poderão ocorrer problemas graves se modificar o registo de forma incorrecta. Por conseguinte, certifique-se de que segue estes passos cuidadosamente. Criar uma para protecção adicional, cópia de segurança do registo antes de o modificar. Em seguida, pode restaurar o registo se ocorrer um problema. Para obter mais informações sobre como efectuar uma cópia de segurança e restaurar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) Como efectuar uma cópia de segurança e restaurar o registo no Windows
  1. Inicie o Regedit.exe. (Não pode utilizar o Regedt32.exe porque não lhe permite procurar valores de registo.)
  2. Clique para seleccionar a seguinte chave
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
  3. Seleccione Localizar no menu Editar .
  4. No campo Procurar , escreva Desactivar os contadores de desempenho .
  5. Clique em Localizar seguinte . Isto irá localizar uma chave de desempenho que pode ter este valor de registo definido como 1.
  6. Se o valor de registo é definido como 1, defina o valor para 0 ou elimine o valor de registo.
  7. Prima F3 para localizar a ocorrência seguinte deste valor de registo.
  8. Repita os dois passos anteriores até que não sem chaves de desempenho com o valor de Desactivar os contadores de desempenho definido para 1.
Nota : frequentemente o valor "Desactivar os contadores de desempenho" não aparece no registo. O valor pode ser criado e atribuído um valor DWORD de 1 para desactivar contadores.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
Palavras-chave: 
kbmt kbkernbase kbperfmon kbprb KB248993 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 248993  (http://support.microsoft.com/kb/248993/en-us/ )