SQL Server'da veritabanı yansıtmasını yeniden başlattıktan sonra yansıtılmış veritabanlarının bağlantısı kesilir

Bu makale, yansıtılmış veritabanlarının Bağlantısı Kesilmiş veya Kurtarma durumunda bırakılması sorununu çözmenize yardımcı olur.

Özgün ürün sürümü: SQL Server
Özgün KB numarası: 2490051

Belirti

Aşağıdaki senaryoyu inceleyin:

  • İki sunuculu veritabanı yansıtmasında microsoft SQL Server ikincil örneğini çalıştıran bir bilgisayarınız var.

  • CPU kullanımı bilgisayarda yüzde 100'e ulaşır ve SQL Server Yönetim Araçları'nı kullanarak SQL Server hizmetini durduramazsınız.

  • Görev Yöneticisi'ni kullanarak SQL Server ikincil örneğinin işlemini sonlandırabilirsiniz.

  • SQL Server ikincil örneğini yeniden başlatırsınız.

Bu senaryoda, tüm yansıtılmış veritabanları Bağlantısız veya Kurtarma durumundadır. Ayrıca, her veritabanı için SQL Server hata günlüğüne aşağıdakine benzer bir hata iletisi günlüğe kaydedilir:

'Veritabanı Adı' veritabanı erişilemez veritabanı yansıtma veritabanı olarak işaretlendiğinden kurtarmayı atlama. Yansıtma oturumuyla ilgili bir sorun var. Oturumda çekirdek yok veya bağlantılarla, uç nokta yapılandırmasıyla veya izinlerle (sunucu hesabı veya güvenlik sertifikası için) ilgili sorunlar nedeniyle iletişim bağlantıları kesiliyor. Veritabanına erişim elde etmek için oturum yapılandırmasında nelerin değiştiğini öğrenin ve değişikliği geri alın.

Neden

Bu sorun, SQL Server veritabanı yansıtma uç noktalarındaki sorunlar nedeniyle oluşur.

Çözüm

Bu sorunu çözmek için aşağıdaki yöntemleri kullanın. İlk yöntem sorunu çözmezse ikinci yöntemi kullanın.

Yöntem 1

Veritabanı yansıtması üzerinde uç noktayı geri dönüştürin. Bunu yapmak için şu adımları uygulayın:

  1. Uç noktayı durdurmak için asıl veritabanında aşağıdaki SQL betiğini çalıştırın:

    ALTER ENDPOINT <Endpoint Name> STATE=STOPPED
    
  2. Uç noktayı yeniden başlatmak için aşağıdaki SQL betiğini yürütür:

    ALTER ENDPOINT <Endpoint Name> STATE=STARTED
    

    Not

    Betikleri yürütürken uç noktalar arasındaki iletişim yeniden başlatılmazsa, betikleri veritabanı yansıtması üzerinde çalıştırın. Ancak, bunu yaptıktan sonra veritabanı Askıya Alındı durumuna girebilir. Bu sorun oluşursa aşağıdaki SQL betiğini çalıştırın:

    ALTER DATABASE <Database Name> SET PARTNER RESUME
    

Yöntem 2

Her iki sunucuda da veritabanı yansıtma uç noktalarını silin ve yeniden oluşturun.