Numéro d'article: 249191 - Dernière mise à jour: lundi 20 février 2006 - Version: 4.1

Bureau vierge ou message d'erreur d'opérations illégales après l'installation d'Internet Explorer

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Ancien nº de publication de cet article : F249191
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Symptômes

Le shell de l'Explorateur Microsoft Windows peut ne pas se charger (entraînant l'affichage d'un Bureau vierge) ou vous pouvez recevoir le message d'erreur suivant lorsque vous redémarrez votre ordinateur après avoir installé Internet Explorer 5.0 ou version ultérieure :
Ce programme va être arrêté parce qu'il a effectué une opération non conforme. Si le problème persiste, contactez le revendeur du programme.
Lorsque vous cliquez sur Détails, le message suivant s'affiche, où nom_fichier est le fichier Explorer.exe ou Shdocvw.dll :
Explorer a causé une défaillance de page dans le module nom_fichier

Cause

Ce problème peut se produire lorsque l'une des conditions suivantes est remplie :
  • Le fichier Shdocvw.dll est manquant ou endommagé.
  • La Vérification du Registre de Windows 98 (Scanreg.exe) restaure une copie antérieure du Registre. Pour déterminer si cela s'est produit, vérifiez s'il existe sur votre ordinateur un fichier Rbbad.cab avec comme cachet de date le jour où vous avez installé Internet Explorer 5 ou version ultérieure. Si le fichier est sur votre ordinateur, suivez uniquement les étapes 8 à 10 de la section « Contournement » de cet article.
  • L'ordinateur est infecté par le virus Pretty Park.

Contournement

REMARQUE : si vous pensez que votre ordinateur est infecté par le virus Pretty Park ou par tout autre virus, n'utilisez pas les étapes suivantes. Au lieu de cela, obtenez une version à jour d'un utilitaire antivirus et analysez votre ordinateur avec le programme.

Pour plus d'informations sur le virus Pretty Park, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
250931  (http://support.microsoft.com/kb/250931/ ) Impossible de démarrer un fichier avec une extension .exe
Si vous êtes certain que votre ordinateur n'a pas de virus, utilisez les étapes suivantes pour contourner le problème :
  1. Démarrez votre ordinateur à partir d'une invite de commandes, modifiez le fichier System.ini en remplaçant Shell=Explorer.exe par Shell=Winfile.exe, puis redémarrez votre ordinateur. Vous pouvez effectuer l'étape précédente en suivant ces instructions détaillées :
    1. Redémarrez votre ordinateur, puis appuyez sur F8 à l'affichage du message « Démarrage de Windows ».
    2. À l'aide des touches de direction, sélectionnez Invite MS-DOS, puis appuyez sur ENTRÉE.
    3. Pour modifier votre fichier System.ini, vous devrez peut-être d'abord basculer vers le répertoire Windows en tapant cd\windows, puis en appuyant sur ENTRÉE.
    4. Pour modifier votre fichier System.ini, tapez edit system.ini et appuyez sur ENTRÉE.
    5. À ce stade, le texte du fichier System.ini doit être affiché à l'écran. Recherchez la ligne de texte suivante :
      Shell=Explorer.exe
    6. Supprimez le texte Explorer.exe et remplacez-le par :
      Winfile.exe
    7. Pour enregistrer vos modifications, appuyez sur ALT+F.
    8. Un menu s'affiche dans le coin supérieur gauche de l'écran. Appuyez sur la touche X pour quitter.
    9. Appuyez sur ENTRÉE pour enregistrer les modifications et revenir à l'invite de commandes.
    10. Redémarrez votre ordinateur normalement. Le Gestionnaire de fichiers Windows doit s'afficher après le redémarrage de Windows.
  2. Cliquez sur Exécuter dans le menu Fichier du Gestionnaire de fichiers, tapez command.com, puis cliquez sur OK.
  3. Réextrayez les fichiers Shdocvw.dll, Mshtml.dll, Comctl32.dll et Shlwapi.dll à partir des fichiers .cab d'Internet Explorer 5.

    Pour plus d'informations sur la façon d'extraire des fichiers Internet Explorer 5.0, consultez la section « Extraction des fichiers individuels Internet Explorer 4.0 ou 4.01 » de l'article suivant de la Base de connaissances Microsoft :
    129605  (http://support.microsoft.com/kb/129605/ ) Comment faire pour extraire des fichiers Windows originaux compressés
  4. Modifiez le fichier System.ini en remplaçant Shell=Winfile.exe par Shell=Explorer.exe, puis redémarrez votre ordinateur.

    Si le problème persiste, passez à l'étape suivante.
  5. Démarrez votre ordinateur à partir d'une invite de commandes, modifiez le fichier System.ini en remplaçant Shell=Explorer.exe par Shell=Winfile.exe, puis redémarrez votre ordinateur.
  6. Cliquez sur Exécuter dans le menu Fichier du Gestionnaire de fichiers, puis tapez la commande suivante :
    rundll32 setupwbv.dll,IE5Maintenance "C:\Program Files\Internet Explorer\Setup\SETUP.EXE" /g "C:\WINDOWS\IE Uninstall Log.Txt"
    Cette commande exécute l'utilitaire de réparation d'Internet Explorer (s'il est disponible) et respecte la casse. Si vous êtes invité à redémarrer Windows pour terminer le processus de réparation, cliquez sur Non, puis passez à l'étape suivante. Si vous êtes invité à réexécuter le programme d'installation afin de réinstaller tous les composants, cliquez sur Détails pour noter le problème, cliquez deux fois sur OK, puis passez à l'étape 9.
  7. Modifiez le fichier System.ini en remplaçant Shell=Winfile.exe par Shell=Explorer.exe, puis redémarrez votre ordinateur.

    Si le problème persiste, passez à l'étape suivante.
  8. Démarrez votre ordinateur à une invite de commandes, modifiez le fichier System.ini en remplaçant Shell=Explorer.exe par Shell=Winfile.exe, puis redémarrez votre ordinateur.
  9. Cliquez sur Exécuter dans le menu Fichier du Gestionnaire de fichiers, puis double-cliquez sur le fichier Setup.exe dans le dossier Program Files\Internet Explorer\Setup (où Internet Explorer est le nom de votre dossier d'installation d'Internet Explorer).
  10. Cliquez sur OK, puis sur Oui pour supprimer Internet Explorer.
  11. Cliquez sur Redémarrer Windows, redémarrez à une invite de commandes, modifiez le fichier System.ini en remplaçant Shell=Winfile.exe par Shell=Explorer.exe, puis redémarrez votre ordinateur.

    Si le problème est résolu, exécutez un antivirus avec des fichiers de signatures mis à jour, exécutez un démarrage « propre » (désactivez tout antivirus ou logiciel de protection contre les blocages), puis démarrez Internet Explorer.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.0
Mots-clés : 
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