No se puede asignar un dominio federado a un usuario en el Centro de Administración de Microsoft 365

Problema

Cree un nuevo usuario en el Centro de Administración de Microsoft 365. Sin embargo, al intentar asignar un dominio federado al nuevo usuario, el dominio federado no aparece en la lista de dominios del usuario.

A continuación se muestra un escenario de ejemplo de lo que sucede cuando se experimenta este problema:

  • En el portal de Microsoft 365, se habilita el inicio de sesión único (SSO) y la sincronización de Active Directory.
  • Al ver las propiedades del dominio en la página de propiedades del dominio, el tipo de dominio aparece como Federado o Inicio de sesión único. Por ejemplo, adatum.com es el dominio federado.
  • Al crear un nuevo usuario, verá que el dominio predeterminado proporcionado por Microsoft 365 aparece como la primera opción en el cuadro desplegable. Por ejemplo, el dominio predeterminado es contoso.onmicrosoft.com.
  • Al hacer clic en el cuadro desplegable para ver la lista de dominios, el dominio federado no aparece. Por ejemplo, adatum.com no aparece.

Causa

Este comportamiento es por diseño en Microsoft 365. No se pueden crear usuarios federados a través del portal. Todos los usuarios federados deben crearse de forma local y deben sincronizarse mediante el Herramienta de sincronización de Microsoft Azure Active Directory.

Nota:

Tampoco puede establecer un dominio federado como dominio predeterminado en Microsoft 365.

Solución

Para evitar este comportamiento, cree una cuenta de usuario coincidente en el entorno de Active Directory local Servicios de dominio (AD DS), configure el nombre principal de usuario (UPN) correctamente y, a continuación, sincronice la cuenta y Microsoft Entra ID mediante la sincronización de directorios. Para hacerlo, siga estos pasos:

  1. Para obtener la dirección SMTP principal de la cuenta de usuario de Microsoft 365, siga estos pasos:

    1. Inicie sesión en el portal de Microsoft 365 como administrador global.
    2. Seleccione Administración>Exchange para abrir el Centro de Administración de Exchange.
    3. Busque la cuenta de usuario y haga doble clic en ella.
    4. En el panel de navegación izquierdo, seleccione Email Dirección y anote la dirección SMTP principal de la cuenta de usuario.
  2. Inicie Usuarios y equipos de Active Directory y, a continuación, cree una cuenta de usuario en el dominio local que coincida con la cuenta de usuario de Microsoft 365. Para obtener más información, vea Crear una cuenta de usuario en Usuarios y equipos de Active Directory.

  3. Asegúrese de que el UPN de la cuenta de usuario se actualiza al nombre de dominio federado. Para obtener más información, consulte Solución de problemas de cuentas de usuario de Active Directory que se prueban como identificadores de usuario habilitados para sso de Microsoft 365.

  4. Use La edición de las interfaces de servicio de Active Directory (ADSI) para editar el atributo proxyAddresses del objeto de usuario para que coincida con la dirección SMTP principal que anotó en el paso 1D. Para hacerlo, siga estos pasos:

    Nota:

    Para obtener más información sobre cómo instalar ADSI Edit, consulte Instalación de ADSI Edit.

    1. Seleccione Iniciar>ejecución, escriba ADSIEdit.msc y, a continuación, seleccione Aceptar.

    2. Haga clic con el botón derecho en Edición de ADSI, seleccione Conectar a y, a continuación, seleccione Aceptar para cargar la partición de dominio.

    3. En el panel de navegación, busque el objeto de usuario que desea cambiar, haga clic con el botón derecho en él y, a continuación, seleccione Propiedades.

    4. En la lista Atributos , seleccione el atributo proxyAddresses y, a continuación, seleccione Editar.

    5. En el campo Valor para agregar , escriba la dirección SMTP adecuada y, a continuación, seleccione Agregar.

      Nota:

      El valor de dirección SMTP principal para el objeto de usuario debe anteponerse a un designador SMTP: en mayúsculas para que el valor de dirección se formatee correctamente para proxyAddressesattribute. Por ejemplo, "SMTP:username@contoso.com" es un valor aceptable y "username@contoso.com" no es un valor aceptable.

    6. Seleccione Aceptar dos veces y, a continuación, salga de EDICIÓN DE ADSI.

    Para obtener más información sobre cómo usar ADSI Edit para editar atributos de Active Directory, consulte Using ADSI Edit

  5. Forzar la sincronización de directorios.

Más información

Para obtener más información, consulte Solución de problemas de nombres de usuario que se producen para los usuarios federados al iniciar sesión en Microsoft 365, Azure o Intune.

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