Artigo: 249286 - Última revisão: terça-feira, 11 de Junho de 2002 - Revisão: 1.0

Erro: Não é possível instalar o Windows 95 DDK depois de instalar o Platform SDK

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante : Este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o restaurar o registo se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Sintomas

Não poderá instalar o Windows 95 DDK depois de instalar o Microsoft Windows Platform Software Development Kit (SDK).

Windows 95 DDK requer que o Win32 SDK ser instalado antes de instalar o DDK. O programa de configuração DDK procura teclas específicas no registo para confirmar que Win32 SDK está instalado.

Causa

Microsoft Windows Platform SDK não criar as chaves de registo necessárias ao programa o programa de configuração do Windows 95 DDK. Versões anteriores do SDK (denominado Win32 SDK) criar uma chave denominada "Win32SDK" no registo do sistema. O programa de configuração DDK procura para esta chave; as versões mais recentes do SDK (denominado Platform SDK) criar "Platform SDK" em vez disso.

Resolução

aviso : a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. As suas próprias risco da utilização do Editor de registo.

Pode corrigir este problema instalando o mais recente do Platform SDK. Para corrigir este problema sem reinstalar o Platform SDK, crie manualmente as chaves de registo necessárias. Por favor note que chaves de registo diferentes são necessárias, conforme o sistema de operação destino (Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows NT).

Para instalar o Windows 95 DDK num computador que está a executar o Windows 95 ou Windows 98:
  1. Crie a seguinte entrada de registo:
    HKEY_USERS\.DEFAULT\Software\Microsoft\Win23SDK
    							
    Tenha em atenção o ponto (.) que precede o predefinido.
  2. Crie a seguinte entrada de registo:
    HKEY_USERS\.DEFAULT\Software\Microsoft\Win32SDK\Directories
  3. Adicione um valor de cadeia denominado Directório de instalação . Tenha em atenção o espaço entre instalar e Dir.
  4. Escreva a pasta onde instalou o Platform SDK (por exemplo, SDK C:\Platform ) como os dados do valor para Instalar o directório .
  5. Execute o programa de configuração DDK do Windows 95.
Para instalar o Windows 95 DDK num computador com o Windows NT:
  1. Crie a seguinte entrada de registo:
    HKEY_CURRENT_USERS\Software\Microsoft\Win32SDK
  2. Crie a seguinte entrada de registo:
    HKEY_CURRENT_USERS\Software\Microsoft\Win32SDK\Directories
  3. Adicione um valor de cadeia denominado Instalar Dir (Repare no espaço entre instalar e directório).
  4. Introduza o directório onde instalou o Platform SDK (por exemplo, SDK C:\Platform ) como dados do valor para o Directório de instalação .
  5. Execute o programa de configuração do DDK do Windows 95.

Ponto Da Situação

A Microsoft confirmou que este erro ocorre nos produtos da Microsoft listados no início deste artigo.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 95 Driver Development Kit (DDK)
Palavras-chave: 
kbmt kbbug kbfix KB249286 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 249286  (http://support.microsoft.com/kb/249286/en-us/ )
Retired KB ArticleExclusão de Responsabilidade para Conteúdo sem Suporte na KB
Este artigo foi escrito sobre produtos para os quais a Microsoft já não fornece suporte. Por conseguinte, este artigo é oferecido "tal como está" e deixará de ser actualizado.