ID do artigo: 249286 - Última revisão: terça-feira, 11 de junho de 2002 - Revisão: 1.0

Erro: Não é possível instalar DDK do Windows 95 após instalar o SDK da plataforma

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante : Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de backup e certifique-se que você saiba como restaurar o registro se ocorrer um problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986  (http://support.microsoft.com/kb/256986/EN-US/ ) Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Sintomas

Você não poderá instalar DDK do Windows 95 depois de instalar o Microsoft Windows Platform Software Development Kit (SDK).

DDK do Windows 95 requer que o SDK do Win32 ser instalado antes de instalar o DDK. O programa de instalação DDK procura teclas específicas no Registro para confirmar que o Win32 SDK está instalado.

Causa

Microsoft Windows Platform SDK não cria as chaves do Registro necessários para o programa de instalação DDK do Windows 95. Versões anteriores do SDK (chamado Win32 SDK) criam uma chave chamada "Win32SDK" no registro do sistema. O programa de instalação DDK procura essa chave; as versões mais recentes do SDK (chamado SDK) criam "Platform SDK" em vez disso.

Resolução

Aviso : se você usar o Editor do Registro incorretamente, poderá causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Você pode corrigir esse problema instalando o mais recente do Platform SDK. Para corrigir esse problema sem reinstalar o Platform SDK, crie manualmente as chaves de registro necessárias. Observe que, chaves do Registro diferentes estão necessárias dependendo do sistema de operação de destino (Microsoft Windows 95, Microsoft Windows 98 ou Microsoft Windows NT).

Para instalar o Windows 95 DDK em um computador que está executando o Windows 95 ou Windows 98:
  1. Crie a seguinte entrada do Registro:
    HKEY_USERS\.DEFAULT\Software\Microsoft\Win23SDK
    							
    Observe o ponto (.) que precede o padrão.
  2. Crie a seguinte entrada do Registro:
    HKEY_USERS\.DEFAULT\Software\Microsoft\Win32SDK\Directories
  3. Adicione um valor seqüência de caracteres chamado Pasta de instalação . Observe o espaço entre instalar e Dir.
  4. Digite a pasta onde você instalou o Platform SDK (por exemplo, o SDK C:\Platform ) como os dados de valor para a Pasta de instalação .
  5. Execute o programa de instalação DDK do Windows 95.
Para instalar o Windows 95 DDK em um computador que está executando o Windows NT:
  1. Crie a seguinte entrada do Registro:
    HKEY_CURRENT_USERS\Software\Microsoft\Win32SDK
  2. Crie a seguinte entrada do Registro:
    HKEY_CURRENT_USERS\Software\Microsoft\Win32SDK\Directories
  3. Adicione um valor seqüência de caracteres chamado Instalar Dir (Observe o espaço entre instalar e diretório).
  4. Digite o diretório onde você instalou o SDK de plataforma (por exemplo, C:\Platform SDK ) como dados de valor para a Pasta de instalação .
  5. Execute o programa de instalação do DDK do Windows 95.

Situação

A Microsoft confirmou que esse é um problema nos produtos da Microsoft listados no começo deste artigo.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows 95 Driver Development Kit (DDK)
Palavras-chave: 
kbmt kbbug kbfix KB249286 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 249286  (http://support.microsoft.com/kb/249286/en-us/ )
Retired KB ArticleAviso de Isenção de Responsabilidade sobre Conteúdo do KB Aposentado
Este artigo trata de produtos para os quais a Microsoft não mais oferece suporte. Por esta razão, este artigo é oferecido "como está" e não será mais atualizado.