Chybové hlásenie, keď sa používateľ pokúsi prejsť do režimu offline v klientovi programu systém Microsoft Dynamics CRM pre program Outlook: "počas odstránenie databázy sa vyskytla chyba"

Preklady článku Preklady článku
ID článku: 2496443 - Zobraziť produkty, ktorých sa tento článok týka.
Poznámka
Dôležité Tento článok obsahuje informácie o tom, ako upraviť databázu registry. Presvedčte sa, či ste zálohovali databázu registry skôr, ako zmeníte ju. Uistite sa, že viete, ako obnoviť databázu registry, ak sa vyskytne problém. Ďalšie informácie o tom, ako zálohovať, obnovení a úprave databázy registry nájdete po kliknutí na nasledovné číslo článku databázy Microsoft Knowledge Base:
322756 Ako zálohovať a obnovovať databázu registry v systéme Windows
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Uvažujme o nasledujúcom prípade:
  • Klientsky počítač používa viac než jednému užívateľovi alebo sa používa v prostredí terminálový Server alebo Citrix.
  • Používateľ odchádza v režime offline. Potom klikne na druhý používateľ Neprejsť do režimu Offline.

V tomto scenári, druhý používateľ nemôže prejsť do režimu offline. V skutočnosti už nie ostatným užívateľom môže prejsť do režimu offline. Okrem toho zobrazí nasledujúce chybové hlásenie:

Počas odstránenie databázy sa vyskytla chyba. Požiadajte o pomoc správcu systému systém Microsoft Dynamics CRM a skúste to znova odpojuje.

PRICINA

Iba jeden používateľ môže byť nakonfigurovaný prejsť do režimu offline v klientovi programu systém Microsoft Dynamics CRM pre program Microsoft Office Outlook.

RIESENIE

Toto správanie je zámerné. V programe systém Microsoft Dynamics CRM 2011, môžete nainštalovať a nakonfigurovať klienta systém Microsoft Dynamics CRM pre program Outlook. Potom môžete nainštalovať v režime offline súčasti kliknutím Neprejsť do režimu Offline tlačidlo.

Ak nechcete, aby používatelia budú môcť kliknite na Neprejsť do režimu Offline tlačidlo, môžete použiť jednu z nasledujúcich možností.

Možnosť č. 1


Odstránenie idú Offline povolení pre používateľov, ktorým nechcete byť schopní vidieť Neprejsť do režimu Offline tlačidlo. To chcete urobiť, postupujte nasledovne:
  1. Pre používateľa, ktorý má povolenia meniť CRM bezpečnostné úlohy, kliknite na položku nastavenia, kliknite na správu, a potom kliknite Funkcií zabezpečenia.
  2. Kliknutím otvorte okno funkcie zabezpečenia, ktoré chcete zmeniť. (Napríklad kliknite na položku Predajné manažér)
  3. Kliknite na kartu Riadenie podniku a potom zrušte začiarknutie políčka Idú Offline v sekcii Rôzne výsady .
  4. Kliknite na tlačidlo Ak chcete uložiť, a potom kliknite na tlačidlo Zavrieť.

    Poznámka To môže trvať 5-minútových alebo dlhších pred tlačidlo nezmizne nástrojmi klienta ak klient je už nakonfigurovaný.

Možnosť č. 2


Vypnúť Neprejsť do režimu Offline tlačidlo pre všetkých používateľov na každý počítač a potom nainštalovať klienta systém Microsoft Dynamics CRM pre Outlook spolu s použitím prepínača disableofflinecapability . To chcete urobiť, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na položku spustiť, a potom zadajte cestu k Setupclient.exe súboru.
  2. se /disableofflinecapability prepnúť na inštaláciu klienta systém Microsoft Dynamics CRM pre program Outlook. (Napríklad použitie príkazu c:\Client\i386\SetupClient.exe /disableofflinecapability .)
  3. Kliknite na tlačidlo Nainštalovať alebo použite prepínač/q urobiť Tichá inštalácia bez výzva.

Možnosť č. 3


Upozornenie Ak databázu registry upravíte nesprávne pomocou editora databázy Registry alebo pomocou inej metódy, môžu nastať vážne problémy. Tieto problémy môžu vyžadovať preinštalovanie operačného systému. Spoločnosť Microsoft nemôže zaručiť, že je možné vyriešiť tieto problémy. Úpravu databázy registry na vlastné riziko.

Ak ste už nainštalovali klienta systém Microsoft Dynamics CRM pre program Outlook, môžete zmeniť kľúče databázy registry LightClient tak, aby noví používatelia, ktorí bežia konfiguráciu nezobrazuje Neprejsť do režimu Offline tlačidlo. To chcete urobiť, postupujte nasledovne:
  1. Kliknite na tlačidlo Štart, kliknite na tlačidlo spustiť, typ Regedita potom kliknite na tlačidlo ok.
  2. Vyhľadajte nasledujúci podkľúč databázy registry:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  3. Kliknite pravým tlačidlom myši na kľúč LightClient databázy registry a potom kliknite na tlačidlo Upraviť.
  4. Zmena Hodnota 1vyberte desiatkovou, a potom kliknite na tlačidlo OK.
  5. Spustiť systém Microsoft Dynamics CRM klienta pre program Outlook.

    Poznámka To môže trvať 5-minútových alebo dlhších pred tlačidlo nezmizne nástrojmi klienta ak klient je už nakonfigurovaný.
  6. Vyhľadajte nasledujúci podkľúč databázy registry:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMClient

    PoznámkaAk používate 64-bitový klientsky počítač a majú 3-bitovú verziu systému Microsoft Office nainštalovali podkľúč databázy registry je nasledovná:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\MSCRMClient
  7. Kliknite pravým tlačidlom myši na kľúč LightClient databázy registry a potom kliknite na tlačidlo Upraviť.
  8. Zmena Hodnota 1vyberte desatinnýa potom kliknite na tlačidlo OK. Keď spustíte novú konfiguráciu, Neprejsť do režimu Offline tlačidlo sa odstránia.

PoznámkaAk zmeníte položku databázy registry v HKEY_CURRENT_USER, zmena ovplyvní iba používateľ, ktorý je aktuálne prihlásený. Chcete použiť zmeny pre viacerých používateľov, vyhľadajte záznam podľa HKEY_Users\. Alebo použiť kľúč pomocou skupinovej politiky viacerých/ostatných užívateľov.

DALSIE INFORMACIE

Ak užívateľ odišla už v režime offline a iný používateľ musí byť schopný prejsť do režimu offline v jednom počítači, musíte Odho? databázy z predchádzajúcich užívateľa. Ďalšie informácie o tom, ako kvapka databázu SQL Express, navštívte nasledujúce webovú lokalitu webová lokalita Microsoft Developer Network (MSDN):

http://msdn.Microsoft.com/en-us/library/ms178613.aspx

Vlastnosti

ID článku: 2496443 - Posledná kontrola: 8. júna 2012 - Revízia: 0.1
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Dynamics CRM 2011
  • Microsoft Dynamics Live CRM Professional Edition
  • Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access
Kľúčové slová: 
kbmbsmigrate kbsurveynew kbmt KB2496443 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2496443

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com