ข้อความแจ้งความผิดพลาดเมื่อผู้ใช้พยายามปิดการทำงานให้เป็น offline ใน Microsoft Dynamics CRM Client for Outlook: "มีข้อผิดพลาดเกิดขึ้นขณะทำการลบฐานข้อมูล"

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2496443
หมายเหตุ
ข้อมูลสำคัญ บทความนี้มีข้อมูลเกี่ยวกับวิธีการปรับเปลี่ยนรีจิสทรี โปรดตรวจสอบว่าคุณได้สำรอง รีจิสทรี ก่อนที่จะแก้ไข โปรดทำความเข้าใจกับการเรียกคืน รีจิสทรี ในกรณีที่เกิดปัญหา สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการสำรองข้อมูล คืนค่า และปรับเปลี่ยน รีจิสทรี โปรดคลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
322756 วิธีการสำรองข้อมูลและคืนค่ารีจิสทรีใน Windows
ขยายทั้งหมด | ยุบทั้งหมด

อาการ

พิจารณาสถานการณ์ต่อไปนี้:
  • มีผู้ใช้คอมพิวเตอร์ของลูกค้ามากกว่า 1 รายหรือใช้ใน Terminal Server หรือในระบบ Citrix
  • ผู้ใช้เปลี่ยนสถานะเป็น offline จากนั้นผู้ใช้คนที่สองคลิก Go Offline

ในสถานการณ์เช่นนี้ ผู้ใช้คนที่สองไม่สามารถเปลี่ยนสถานะเป็น offline ได้ จริงๆ แล้วไม่มีผู้ใช้คนใดสามารถเปลี่ยนสถานะเป็น offline ได้ นอกจากนี้ คุณยังได้รับข้อความแจ้งความผิดพลาดต่อไปนี้:

"มีข้อผิดพลาดเกิดขึ้นขณะทำการลบฐานข้อมูล" กรุณาติดต่อเจ้าหน้าที่ Microsoft Dynamics CRM เพื่อขอความช่วยเหลือและลองเปลี่ยนสถานะเป็น offline อีกครั้ง

สาเหตุ

มีผู้ใช้เพียงคนเดียวเท่านั้นที่จะสามารถตั้งค่าเป็น offline ได้ใน Microsoft Dynamics CRM Client for Microsoft Office Outlook

การแก้ไข

ลักษณะการทำงานนี้จะเป็นตามการออกแบบ ใน Microsoft Dynamics CRM 2011 คุณสามารถติดตั้งและตั้งค่า Microsoft Dynamics CRM Client for Outlook ได้ จากนั้นให้คุณติดตั้งองค์ประกอบในการ offline โดยคลิกปุ่ม Go Offline

หากคุณไม่ต้องการอนุญาตให้ผู้ใช้คลิกปุ่ม Go Offline ให้ใช้ตัวเลือกต่อไปนี้

ตัวเลือกที่ 1


ซ่อนปุ่มอนุญาต Go Offline สำหรับผู้ใช้ที่คุณไม่ต้องการให้เห็นปุ่ม Go Offline โดยให้ทำตามขั้นตอนต่อไปนี้:
  1. สำหรับผู้ใช้ที่สามารถเปลี่ยนบทบาทของการตั้งค่าความปลอดภัย CRM ได้ ให้คลิก Settings คลิก Administration และคลิก Security Roles
  2. คลิกเพื่อเปิด Security Role ที่ต้องการเปลี่ยน (เช่น คลิก Sales Manager)
  3. คลิกแท็บ Business Management จากนั้นคลิกกล่อง Go Offline ในส่วน Miscellaneous Privileges ออก
  4. คลิก Save และคลิก Close

    หมายเหตุ โปรแกรมอาจใช้เวลาอย่างน้อย 5 นาทีจนกว่าปุ่มนั้นจะหายไปจาก toolbar ของลูกค้าหลังจากที่ลูกค้าได้ตั้งค่าแล้ว

ตัวเลือกที่ 2


คลิก Disable ที่ปุ่ม Go Offline ของผู้ใช้คอมพิวเตอร์ทุกเครื่อง และติดตั้ง Microsoft Dynamics CRM Client for Outlook ไปพร้อมกันโดยใช้ปุ่ม disableofflinecapability โดยให้ทำตามขั้นตอนต่อไปนี้:
  1. คลิก Start คลิก Run จากนั้นพิมพ์ path ของไฟล์ Setupclient.exe ลงไป
  2. ใช้ปุ่ม /disableofflinecapability เพื่อติดตั้ง Microsoft Dynamics CRM Client for Outlook (เช่น ใช้ปุ่ม C:\Client\i386\SetupClient.exe /disableofflinecapability)
  3. คลิก Install Now หรือใช้ปุ่ม /q เพื่อทำการติดตั้งโดยไม่ต้องแจ้งผู้ใช้

ตัวเลือกที่ 3


คำเตือน อาจเกิดปัญหาร้ายแรง หากคุณปรับเปลี่ยนรีจิสทรีไม่ถูกต้องโดยใช้ตัวแก้ไขรีจิสทรีหรือโดยใช้วิธีอื่น ซึ่งคุณอาจต้องติดตั้งระบบปฏิบัติการใหม่เพื่อแก้ไขปัญหาเหล่านี้ Microsoft ไม่รับประกันว่าจะสามารถแก้ไขปัญหาเหล่านี้ได้ คุณต้องยอมรับความเสี่ยงในการปรับเปลี่ยนรีจิสทรีด้วยตนเอง

หากคุณได้ติดตั้ง Microsoft Dynamics CRM Client for Outlook แล้ว คุณสามารถเปลี่ยนแปลงปุ่มรีจิสทรี LightClient เพื่อให้ผู้ใช้ที่ทำการตั้งค่าไม่สามารถมองเห็นปุ่ม Go Offline ได้ โดยให้ทำตามขั้นตอนต่อไปนี้:
  1. คลิก Start คลิก Run พิมพ์ Regedit จากนั้นคลิก OK
  2. ค้นหารีจิสตรี ซับคีย์ต่อไปนี้:
    HKEY_CURRENT_USER\Software\Microsoft\MSCRMClient
  3. คลิกขวาที่ปุ่มรีจิสทรี LightClient แล้วคลิก Modify
  4. เปลี่ยน Value ให้เป็น 1 เลือก Decimalจากนั้นคลิก OK
  5. เริ่มต้นโปรแกรม Microsoft Dynamics CRM Client for Outlook

    หมายเหตุ โปรแกรมอาจใช้เวลาอย่างน้อย 5 นาทีจนกว่าปุ่มนั้นจะหายไปจาก toolbar ของลูกค้าหลังจากที่ลูกค้าได้ตั้งค่าแล้ว
  6. ค้นหารีจิสตรี ซับคีย์ต่อไปนี้:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSCRMClient

    หมายเหตุ หากคุณใช้คอมพิวเตอร์ของลูกค้าขนาด 64 บิต และมี Microsoft Office เวอร์ชั่น 3 บิตติดตั้งอยู่ในคอมพิวเตอร์ คีย์ย่อยของรีจิสทรีที่เหมาะสมคือ:
    HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Microsoft\MSCRMClient
  7. คลิกขวาที่ปุ่มรีจิสทรีLightClient แล้วคลิก Modify
  8. เปลี่ยน Value ให้เป็น 1 เลือก Decimalจากนั้นคลิก OK หลังจากที่การตั้งค่าใหม่เสร็จสิ้นแล้ว ปุ่ม Go Offline จะหายไป

หมายเหตุ เมื่อคุณเปลี่ยนปุ่มรีจริสทรีใน HKEY_CURRENT_USER แล้ว การเปลี่ยนแปลงจะเกิดขึ้นกับผู้ใช้ที่ล็อคอินอยู่ในขณะนั้น หากต้องการเปลี่ยนค่าให้กับผู้ใช้หลายราย ให้ค้นหาบันทึกของผู้ใช้ใน HKEY_Users\ หรือใช้ปุ่ม Group Policy กับผู้ใช้ในรายที่ต้องการ

ข้อมูลเพิ่มเติม

หากผู้ใช้ได้ทำการ offline ออกไปแล้ว และผู้ใช้รายอื่นต้อง offline บนคอมพิวเตอร์เครื่องเดียวกัน คุณต้องปิดฐานข้อมูลจากผู้ใช้รายแรกก่อน หากต้องการข้อมูลที่เกี่ยวกับวิธีการปิดฐานข้อมูล SQL Express โปรดเยี่ยมชมเวปไซต์เครือข่ายผู้พัฒนาไมโครซอฟต์ (MSDN) ดังนี้

http://msdn.microsoft.com/th-th/library/ms178613.aspx

คุณสมบัติ

หมายเลขบทความ (Article ID): 2496443 - รีวิวครั้งสุดท้าย: 23 มีนาคม 2554 - Revision: 3.0
Keywords: 
kbmbsmigrate kbsurveynew KB2496443

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com