Outlook affiche des résultats de recherche incorrects de la liste d’adresses globale dans Exchange Server

Numéro de la base de connaissances d’origine : 2497077

Symptômes

Lorsque vous utilisez Microsoft Office Outlook 2007, Outlook 2010 ou Outlook 2013 pour rechercher des utilisateurs dans une liste d’adresses globale (GAL) dans Microsoft Exchange Server 2007, Exchange Server 2010 ou Exchange Server 2013, les problèmes suivants peuvent se produire :

  • Lorsque vous sélectionnez l’option qui trie les résultats de la recherche à l’aide du champ [Nom complet] sous Recherche avancée du carnet d’adresses Outlook, les résultats ne sont pas triés à l’aide de la colonne [Nom complet].
  • Lorsque vous recherchez des objets qui ont un nom d’utilisateur ou un nom de liste de distribution, l’opération de recherche ne retourne pas l’objet correct si l’option [Nom uniquement] est activée.

Remarque

Lorsque l’option [Plus de colonnes] est activée, les opérations de recherche retournent les résultats corrects.

Cause

Ce problème se produit car services de domaine Active Directory (AD DS) utilise furigana pour l’indexation dans Windows Server 2008.

Lorsque les noms d’affichage phonétiques sont définis sur des objets utilisateur ou groupe de distribution dans AD DS dans Windows Server 2008, un index du nom complet phonétique est généré sur le serveur de catalogue global. L’index est utilisé pour rechercher ou organiser un résultat de recherche d’une gal dans la version japonaise d’Outlook. Lorsque les objets dans la liste d’adresses gal n’ont pas de nom d’affichage phonétique, le nom complet est utilisé pour l’indexation. Si l’option [nom uniquement] est sélectionnée, l’étendue de recherche est limitée aux objets qui ont des noms complets phonétiques. Par conséquent, vous recevez des résultats incorrects lorsque vous effectuez une recherche dans un carnet d’adresses dans Office Outlook si les objets n’ont pas de noms complets phonétiques.

Par exemple, vous recherchez un nom d’affichage différent de son nom d’affichage phonétique dans une liste d’adresses gal dans laquelle certains objets n’ont pas de noms complets phonétiques. Dans ce scénario, l’objet qui a le nom complet correspondant dans la colonne [Nom d’affichage] n’est pas retourné dans les résultats de la recherche, et seuls les objets qui ont des noms d’affichage phonétiques sont retournés.

Si le nom complet phonétique de tous les utilisateurs et listes de distribution de la liste d’adresses globale n’est pas défini, une recherche qui utilise l’option [Nom uniquement] renvoie des résultats corrects. Les résultats corrects sont retournés, car l’index des noms d’affichage phonétiques inclut uniquement les noms complets.

Solution de contournement

Importante

Cette section, méthode ou tâche contient des étapes vous indiquant comment modifier le Registre. Toutefois, des problèmes graves peuvent se produire si vous modifiez le Registre de façon incorrecte. Par conséquent, veillez à suivre ces étapes scrupuleusement. Pour une meilleure protection, sauvegardez le registre avant de le modifier. Vous pouvez alors le restaurer en cas de problème. Pour plus d’informations sur la procédure de sauvegarde et de restauration du Registre, cliquez sur le numéro ci-dessous pour afficher l’article correspondant dans la Base de connaissances Microsoft :
322756 Comment sauvegarder et restaurer le Registre dans Windows

Pour contourner ce problème, appliquez l’une des méthodes suivantes :

Pour que nous puissions résoudre ce problème à l’aide de la méthode 1 pour vous, accédez à la section « Permettez-moi de le résoudre moi-même ».

Je résous le problème moi-même

  • Méthode 1

    1. Cliquez sur Démarrer , sur Exécuter, tapez Regedit, puis appuyez sur OK.
    2. Recherchez et cliquez sur l’entrée de Registre DisableGALPhonetic dans l’une des sous-clés de Registre suivantes :
      • HKEY_CURRENT_USER\Software\Policies\Microsoft\Exchange\Exchange Provider
      • HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider

    Remarque

    Si l’entrée de Registre DisableGALPhonetic n’existe pas, vous devez créer cette entrée. Pour cela, procédez comme suit :

    1. Dans le menu Modifier, cliquez sur Nouveau, puis sur Valeur DWORD(32 bits).
    2. Tapez DisableGALPhonetic, puis appuyez sur ENTRÉE.
    3. Cliquez avec le bouton droit sur DisableGALPhonetic, cliquez sur Modifier, tapez 1 dans la zone Données de la valeur , puis cliquez sur OK.
    4. Quittez le Registre Rédacteur, puis redémarrez l’ordinateur pour appliquer la modification.
  • Méthode 2

    Utilisez l’option [Plus de colonnes] au lieu de l’option [Nom uniquement] lorsque vous recherchez dans la liste d’adresses des objets qui ont furigana et des objets qui n’ont pas furigana.

Cela a-t-il résolu le problème ?

Vérifiez si le problème est résolu. Si le problème est résolu, vous en avez terminé avec cette section. Si le problème n’est pas résolu, vous pouvez contacter le support technique.

Informations supplémentaires

Les clients Outlook se connectent au serveur d’accès au client (CAS) dans le organization Exchange Server 2010. Toutefois, le site d’administration centrale ne prend pas en charge l’index de furigana lorsque vous recherchez ou affichez la liste d’adresses globale dans Outlook dans Exchange Server RTM 2010. Lorsque vous utilisez le mode non mis en cache pour rechercher dans la liste d’adresses dans Office Outlook, les utilisateurs correspondants ne sont pas retournés dans le résultat de la recherche. Toutefois, les objets du bas de la liste d’adresses sont sélectionnés. Pour résoudre ce problème, installez Exchange Server 2010 Service Pack 1 (SP1).