文書番号: 2497077 - 最終更新日: 2011年8月16日 - リビジョン: 4.0

Outlook 2007 または Outlook 2010 で、Exchange Server 2007 または Exchange Server 2010 の GAL の検索結果が正しく表示されない

お知らせお使いのオペレーティング システムには適用しない情報が含まれている場合があります。
すべて展開する | すべて折りたたむ

現象

Microsoft Office Outlook 2007 または Microsoft Office Outlook 2010 を使用して、Microsoft Exchange Server 2007 または Microsoft Exchange Server 2010 のグローバル アドレス一覧 (GAL) 内のユーザーを検索すると、以下の問題が発生する場合があります。
  • [表示名] 列を使用して検索結果を並べ替えるオプションを選択したときに、検索結果が [表示名] 列を使用して並べ替えられません。
  • ユーザー名または配布リスト名を持つオブジェクトを検索するときに、[名前のみ] オプションをオンにして検索すると正しい結果が返されません。

注: [その他のフィールド] オプションをオンにした場合は、正しい検索結果が返されます。

原因

この問題は、Windows Server 2008 の Active Directory ドメイン サービス (AD DS) でインデックスにふりがなが使用されていることが原因で発生します。

Windows Server 2008 の AD DS で、ユーザーまたは配布グループ オブジェクトに対してふりがなが設定されている場合、グローバル カタログ サーバー上でふりがなのインデックスが生成されます。このインデックスは、日本語版の Outlook で GAL の検索や検索結果の整列に使用されます。GAL のオブジェクトにふりがながない場合は、インデックスに表示名が使用されます。[名前のみ] オプションを選択した場合、検索範囲はふりがなが設定されているオブジェクトに制限されます。このため、オブジェクトにふりがなが設定されていない場合、Office Outlook でアドレス帳を検索したときに正しい結果が返されません。

たとえば、一部のオブジェクトにふりがなが設定されていない GAL で、ふりがなとは異なる表示名を検索するとします。このシナリオでは、[表示名] 列の表示名が一致するオブジェクトは検索結果に返されず、ふりがなのあるオブジェクトだけが返されます。

GAL ですべてのユーザーおよび配布リストのふりがなが設定されていない場合は、[名前のみ] オプションを指定して検索すると、正しい結果が返されます。正しい結果が返されるのは、ふりがなのインデックスに表示名のみが含まれているからです。

回避策

重要: このセクション、方法、またはタスクには、レジストリの変更方法が記載されています。レジストリを誤って変更すると、深刻な問題が発生することがあります。レジストリを変更する際には十分に注意してください。万一に備えて、編集の前にレジストリをバックアップしてください。問題が発生した場合でも、レジストリを復元できます。レジストリのバックアップ方法および復元方法の詳細を参照するには、以下のサポート技術情報番号をクリックしてください。
322756? (http://support.microsoft.com/kb/322756/ja/ ) Windows でレジストリをバックアップおよび復元する方法
この問題を回避するには、次のいずれかの方法を使用します。

このページで方法 1 を使用して問題を解決するには、「Fix it で解決する」セクションに進んでください。自分でこの問題を解決するには、「自分で解決する」セクションに進んでください。

Fix it で解決する



この問題を自動的に解決するには、[この問題を解決する] ボタンまたはリンクをクリックします。次に、[ファイルのダウンロード] ダイアログ ボックスで [実行] をクリックし、Fix it ウィザードの手順に従います。


この問題を解決する
Microsoft Fix it 50705


注:
  • このウィザードは英語版のみである場合があります。しかし、自動的な解決は英語版以外の Windows でも機能します。
  • 問題のあるコンピューターとは別のコンピューターを操作している場合、Fix it ソリューションをフラッシュ ドライブまたは CD に保存することで、問題のあるコンピューターで実行することができます。

次に、「問題が解決されたかどうかの確認」セクションに進んでください。



自分で解決する

  • 方法 1
    1. [スタート] ボタン
      元に戻す画像を拡大する
      [スタート] ボタン
      をクリックし、[ファイル名を指定して実行] をクリックして「Regedit」と入力し、[OK] をクリックします。
    2. 次のいずれかのレジストリ サブキーにある、DisableGALPhonetic レジストリ エントリを探してクリックします。
      • HKEY_CURRENT_USER\Software\Policies\Microsoft\Exchange\Exchange Provider
      • HKEY_CURRENT_USER\Software\Microsoft\Exchange\Exchange Provider

      注: DisableGALPhonetic レジストリ エントリが存在しない場合は、レジストリ エントリを作成する必要があります。これを行うには、以下の手順を実行します。
      1. [編集] メニューの [新規] をクリックし、[DWORD (32 ビット) 値] をクリックします。
      2. DisableGALPhonetic」と入力し、Enter キーを押します。
    3. DisableGALPhonetic を右クリックし、[変更] をクリックします。[値のデータ] ボックスに「1」と入力し、[OK] をクリックします。
    4. レジストリ エディターを終了し、コンピューターを再起動して変更内容を適用します。
  • 方法 2
    GAL でふりがなが設定されているオブジェクトと設定されていないオブジェクトを対象として検索する場合は、[名前のみ] オプションではなく [その他のフィールド] オプションを使用します。

問題が解決されたかどうかの確認

  • 問題が解決されたかどうかを確認します。問題が解決された場合、このセクションの作業は完了していることになります。問題が解決されていない場合は、サポートに問い合わせる (http://support.microsoft.com/contactus?ln=ja#tab0) ことができます。
  • マイクロソフトではフィードバックをお待ちしています。この解決方法に関するフィードバックを提供する、または問題を報告するには、"Fix it for me" ブログ (英語) (http://blogs.technet.com/fixit4me/) にコメントを記入するか、電子メール (mailto:fixit4me@microsoft.com?Subject=KB) メッセージ (日本語可) を送信してください。

詳細

Outlook クライアントは、Exchange Server 2010 組織内のクライアント アクセス サーバー (CAS) に接続します。ただし、Exchange Server 2010 RTM の CAS は、Outlook で GAL を検索または表示するときにふりがなのインデックスをサポートしていません。Office Outlook で非キャッシュ モードを使用してアドレス一覧を検索する場合、一致するユーザーが検索結果に表示されません。その代わりに、アドレス一覧の一番下のオブジェクトが選択されます。この問題を解決するには、Exchange Server 2010 Service Pack 1 (SP1) をインストールします。

Exchange Server 2010 SP1 の詳細については、次のマイクロソフト Web サイトを参照してください。
Exchange Server 2010 SP1 (http://www.microsoft.com/downloads/details.aspx?displaylang=ja&FamilyID=50b32685-4356-49cc-8b37-d9c9d4ea3f5b)

この資料は以下の製品について記述したものです。
  • Microsoft Exchange Server 2010 Enterprise
  • Microsoft Exchange Server 2010 Standard
  • Microsoft Exchange Server 2007 Enterprise Edition
  • Microsoft Exchange Server 2007 Standard Edition
  • Microsoft Office Outlook 2007
  • Microsoft Outlook 2010
キーワード:?
kbexpertiseinter kbtshoot kbprb kbfixme kbmsifixme KB2497077
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"