Impossible d’accéder au site web Microsoft Dynamics CRM après avoir exécuté une réparation sur le serveur Microsoft Dynamics CRM

Cet article fournit une résolution du problème selon lequel vous ne pouvez pas accéder au site web Microsoft Dynamics CRM après avoir exécuté une réparation sur le serveur Microsoft Dynamics CRM.

S’applique à : Microsoft Dynamics CRM 2011
Numéro de la base de connaissances d’origine : 2498257

Symptômes

Après avoir exécuté une réparation sur le serveur Microsoft Dynamics CRM, vous ne pouvez pas accéder au site web Microsoft Dynamics CRM. En outre, vous recevez l’invite de connexion IFD suivante lorsque vous tapez votre URL interne pour accéder à CRM :

Page HTTP 404 introuvable.

En outre, le message d’erreur suivant peut s’afficher dans Microsoft Dynamics CRM client pour Outlook une fois que vous avez sélectionné le organization que vous souhaitez configurer :

Il y a un problème de communication avec le serveur Microsoft Dynamics CRM. Le serveur n’est peut-être pas disponible. Veuillez réessayer plus tard. Si le problème persiste, contactez votre administrateur système.

Cause

Lorsque vous exécutez une réparation sur le serveur Microsoft Dynamics CRM, les URL d’adresse web internes stockées sur le serveur sont remplacées par le port> du nom <du serveur.

En fonction de votre environnement, les clients web peuvent toujours résoudre l’URL modifiée. Toutefois, le client Microsoft Dynamics CRM pour Outlook est susceptible d’échouer pendant la configuration.

Résolution

Pour résoudre ce problème, revenez aux URL d’adresse web internes à leurs valeurs d’origine. (Il doit s’agir des URL que vous avez tapées lorsque vous avez accédé au site web CRM avant d’exécuter la réparation. Ces URL doivent également correspondre à vos liaisons sur le site web Microsoft Dynamics CRM.) Pour ce faire, procédez comme suit :

  1. Sur le serveur Microsoft Dynamics CRM, sélectionnez Démarrer, Tous les programmes, Microsoft Dynamics CRM 2011, puis Gestionnaire de déploiement.
  2. Cliquez avec le bouton droit sur Microsoft Dynamics CRM, puis sélectionnez Propriétés.
  3. Sous l’onglet Adresse web, mettez à jour les URL pour qu’elles correspondent à votre liaison IIS pour le site web Microsoft Dynamics CRM.