Sign in with Microsoft
Sign in or create an account.
Hello,
Select a different account.
You have multiple accounts
Choose the account you want to sign in with.

Symptoms

When you use Windows Update to check for updates, you may not be offered the option of downloading Windows 7 Service Pack 1 (SP1).

Cause

There are certain scenarios where the installation of Windows 7 SP1 may not be successful. To help avoid these scenarios, Windows 7 SP1 is not offered through Windows Update if any of the following issues are true for your computer::

  • Windows SP1 is already installed, or a prerelease version of Windows 7 SP1 has not yet been uninstalled.

  • Another update has to be installed before Windows 7 SP1 will be available.

  • A program on your computer is preventing Windows 7 SP1 from being installed.

  • System files that are required to install Windows 7 SP1 are missing from your computer.

Resolution

To resolve this issue, follow the steps in the methods below starting with Method 1, if method 1 does not resolve the issue, go to method 2.

Method 1: Confirm that Windows 7 SP1 is not already installed and that you are not running a prerelease version of Windows 7 SP1

To do this, follow these steps:

  1. Click Start windows icon, right-click Computer, and then click Properties.

  2. Check the Windows edition section:

    1. If Service Pack 1 is listed, Windows 7 SP1 is already installed on your computer.

    2. If a version number (for example, v.153 or v.720) is listed after Service Pack 1, a prerelease version of Windows 7 SP1 is still installed on your computer. You have to uninstall it before Windows Update will offer you the release version of SP1. For more information, see

      How to uninstall Windows 7 SP1.

Method 2: Check for pending updates

Update 2454826, 2534366, and 2533552 may have to be installed on your computer before Windows 7 SP1 will be offered in Windows Update.

To install these updates by using Windows Update, follow these steps:

  1. Click Start windows icon, click All Programs, and then click Windows Update.

  2. In the navigation pane, click Check for updates, and then wait while Windows looks for the latest updates for your computer.

  3. If any important updates appear, click Install updates.

    Notice icon  If you are prompted for an administrator password or for confirmation, type the password or provide confirmation.

  4. Restart the computer if you are prompted to do this when the installation is complete.

  5. Check Windows Update again to see whether Windows 7 SP1 is now available.

Update 2454826, 2534366, and 2533552 are also available for download from the Microsoft Download Center. For more information about these update and about how to install these updates, click the following article number to view the articles in the Microsoft Knowledge Base:

2534366Windows 7 Sp1 installation fails on a machine with all Language packs installed Error 0xC0000009A

2533552 An update that prevents a "0xC0000034" error message when you try to install Windows 7 SP1 or Windows Server 2008 R2 SP1 is available
2454826 A performance and functionality update is available for Windows 7 and for Windows Server 2008 R2

Method 3: Verify that an incompatible version of SafeCentral is not installed on your computer

Windows SP1 may not appear in Windows Update if certain versions of SafeCentral are installed on your computer. SafeCentral is a security program that is manufactured by SafeCentral, Inc.

If your computer is running SafeCentral version 2.9.0.0 or an earlier version, you have to update SafeCentral before you can install Windows 7SP1.

To determine whether SafeCentral is installed, follow these steps:

  1. Click Start windows icon, click Control Panel, click Programs, and then click Programs and Features.

  2. Search the list of programs for SafeCentral. If SafeCentral version 2.9.0.0 or an earlier version is installed, visit the
    SafeCentral website for more information.

Method 4: Check whether you have Intel integrated graphics driver Igdkmd32.sys or Igdkmd64.sys and whether you upgraded the driver

Windows 7 SP1 will not appear in Windows Update if you have one of the following files on your computer.

  • Igdkmd32.sys (32-bit), versions 8.15.10.2104 through 8.15.10.2141

  • Igdkmd64.sys (64-bit), versions 8.15.10.2104 through 8.15.10.2141

These drivers are known to cause problems with certain applications that use D2D (Direct2D). For example, if you use these drivers together with Windows Live Mail under certain circumstances, Windows Live Mail could crash.

To check for the Intel integrated graphics driver and driver version, follow these steps:

  1. Start DirectX Diagnostic Tool. To do this, click Start windows icon, type dxdiag in the Search programs and files box, and then press Enter.

  2. Click the Display tab.

  3. Note the driver and driver version.

  4. If you have the Intel integrated graphics driver and driver version 8.15.10.2104 through 8.15.10.2141, visit the computer manufacturer's website to see whether a newer driver is available.

Update 2454826 is also available for download from the Microsoft Download Center. This update may help with performance and functionality improvements for this issue. For more information about this update and about how to install this update, click the following article number to view the article in the Microsoft Knowledge Base:

2454826 A performance and functionality update is available for Windows 7 and for Windows Server 2008 R2

Method 5: Make sure that you did not use vLite to customize your Windows 7 installation

vLite is a third-party program that is used to customize an installation of Windows 7. vLite is known to remove some Windows system components. If you know for a fact that you used vLite to customize your installation of Windows 7, you should not expect Windows Update to offer you the option to install Windows 7 SP1.

For more information about issues that are known to occur when you use vLite and try to install Windows 7 SP1, see the
Why am I receiving an error message that system components are missing when installing Windows 7 SP1 topic.

For more information about how to obtain the stand-alone version of Windows 7 SP1, see Learn how to install Windows 7 Service Pack 1 (SP1).

Steps to work around the vLite issue

If you have tried all the steps that are described in this article, and Windows Update still does not offer you the option of installing Windows 7 SP1, you can work around the vLite issue by installing Windows 7 SP1 from the
Microsoft Download Center.

Important The recommended method for installing Windows 7 SP1 is to use Windows Update. For information about how to install Windows 7 SP1 by using Windows Update, see the
Install Windows 7 SP1 topic. If you decide to work around the issue by installing the service pack from the Microsoft Download Center, there are steps that you should take before you install Windows 7 Service Pack 1 from the Microsoft Download Center. For more information, click the following article number to view the article in the Microsoft Knowledge Base:

2505743 Steps to take before you install Windows 7 Service Pack 1 from the Microsoft Download Center
Important If you do not follow the steps in Knowledge Base article 2505743, you may not have the best possible experience when you install the service pack from the Microsoft Download Center.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products.

Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information. 

Method 6: Download the Windows 7 SP1 from Microsoft Download Center

If you tried all the above methods and still cannot find Windows 7 SP1 available in Windows Update, download the Windows 7 SP1 from Microsoft Download Center:

Windows 7 and Windows Server 2008 R2 Service Pack 1 (KB976932)

Need more help?

Want more options?

Explore subscription benefits, browse training courses, learn how to secure your device, and more.

Communities help you ask and answer questions, give feedback, and hear from experts with rich knowledge.

Was this information helpful?

What affected your experience?
By pressing submit, your feedback will be used to improve Microsoft products and services. Your IT admin will be able to collect this data. Privacy Statement.

Thank you for your feedback!

×