Připojení klientů v místní síti s certifikáty SGC nefunguje

Překlady článku Překlady článku
ID článku: 249863 - Produkty, které se vztahují k tomuto článku.
Tento článek byl dříve publikován CZ249863
Tento článek byl archivován. Je nabízen v takovém stavu, v jakém je, a nebude již nadále aktualizován.
Rozbalit všechny záložky | Minimalizovat všechny záložky

Na této stránce

Příznaky

Pokud je požadované zabezpečené připojení k webovému serveru, dochází k odmítnutí připojení webových klientů k webovým serverům požadujícím silné šifrování SGC (Server Gated Cryptography). Pokud bud internetový server, nebo webový klient používá produkty společnosti Microsoft, dochází k selhání připojení. Pokud produkty společnosti Microsoft používají internetový server i webový klient, nedochází k žádným potížím.

Příčina

K těmto potížím dochází ve zprostředkovateli zabezpečení Schannel.dll, který je používaný v produktech Microsoft Internet Information Server (IIS) a Microsoft Internet Explorer při navazování připojení k serveru se silným šifrováním SGC, a když exportní šifrovací sada používá jeden druh algoritmu a místní šifrovací sada jiný. V takové situaci knihovna Schannel.dll někdy zvolí chybný algoritmus a výsledkem je selhání připojení.

Řešení

Windows 2000

Tyto potíže odstraníte instalací nejnovější aktualizace Service Pack pro Windows 2000. Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
260910 Jak získat nejnovější aktualizaci Service Pack pro systém Windows 2000

Windows NT 4.0

Pro odstranění těchto potíží nainstalujte opravný balíček Windows NT 4.0 Security Rollup Package. Další informace naleznete v následujícím článku znalostní báze Microsoft Knowledge Base:
299444 Opravný balíček Security Rollup Package (SRP) vydaný po vydání aktualizace Windows NT 4.0 Service Pack 6a
Anglická verze této opravy by měla mít následující atributy nebo vyšší:
   Datum        Čas    Velikost Název souboru Platforma

   -------------------------------------------------------------
   26. 1. 2000  18:15  154 384  Schannel.dll  NT x86 40bitová
   26. 1. 2000  19:40  267 536  Schannel.dll  NT Alpha 40bitová
   26. 1. 2000  19:40  123 664  Schannel.dll  NT x86 128bitová
   26. 1. 2000  19:40  226 576  Schannel.dll  NT Alpha 128bitová

Windows 9x

Společnost Microsoft uvedla podporovanou opravu, která je ale určena pouze k odstranění potíží popsaných v tomto článku. Proto by měla být použita pouze v systémech, ve kterých k těmto potížím opravdu dochází a nikoli preventivně.

Pokud chcete tyto potíže odstranit, obraťte se na službu odborné pomoci společnosti Microsoft se žádostí o tuto opravu. Úplný seznam telefonních čísel a ceník poskytované odborné pomoci naleznete na webu na adrese:
http://support.microsoft.com/directory/overview.asp
Poznámka: Ve zvláštních případech nemusí být poplatky za poskytnutí odborné pomoci účtovány, pokud pracovník služeb odborné pomoci společnosti Microsoft potvrdí, že tato zvláštní oprava odstraní vaše potíže. Další dotazy a žádosti o odbornou pomoc, které se netýkají této zvláštní opravy, podléhají běžným sazbám za poskytnutí odborné pomoci.

Anglická verze této opravy by měla mít následující atributy nebo vyšší:
   Datum        Čas    Velikost Název souboru Platforma
   ----------------------------------------------------------
   26. 1. 2000  15:15  154 384  Schannel.dll  Win95 40bitová
   26. 1. 2000  16:40  123 664  Schannel.dll  Win95 128bitová
   26. 1. 2000  15:15  154 384  Schannel.dll  Win98 40bitová
   26. 1. 2000  16:40  123 664  Schannel.dll  Win98 128bitová

Prohlášení

Windows 2000

Společnost Microsoft potvrzuje, že tato chyba může určitým způsobem ohrozit zabezpečení systému Windows 2000. Tyto potíže byly opraveny v aktualizaci Service Pack 1 pro systém Windows 2000.

Windows NT 4.0

Společnost Microsoft potvrzuje, že tato chyba může určitým způsobem ohrozit zabezpečení systému Windows NT 4.0.

Windows 9x

Společnost Microsoft potvrzuje, že tato chyba může určitým způsobem ohrozit zabezpečení systému Windows 95, Windows 98 a Windows 98 Druhé vydání.

Další informace

Tato oprava by měla být použita v následujících situacích:
  • Pokud webový server používá produkt IIS a klienti nepoužívají aplikaci Microsoft Internet Explorer, nainstalujte na server opravu pro systém Microsoft Windows NT.
  • Pokud webový server používá produkt Microsoft Personal Web Server (PWS) pro Windows 95 či 98 a klienti nepoužívají aplikaci Microsoft Internet Explorer, nainstalujte do počítače s produktem PWS opravu pro systém Microsoft Windows 95 či 98.
  • Pokud webový server nepoužívá produkty IIS či PWS a klienti používají aplikaci Microsoft Internet Explorer, nainstalujte do klientů odpovídající opravu pro systém Microsoft Windows NT, Microsoft Windows 95 či Microsoft Windows 98.
Poznámka : Pokud jsou webový server i klient produkty společnosti Microsoft, nemělo by docházet k žádným potížím. Ve většině případů při používání systému Windows 95 či Windows 98 je systém Windows používán jako klient a oprava by měla být nainstalována na straně klienta.

Vlastnosti

ID článku: 249863 - Poslední aktualizace: 28. února 2014 - Revize: 2.5
Informace v tomto článku jsou určeny pro produkt:
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Internet Information Server 4.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Klíčová slova: 
kbnosurvey kbarchive kbqfe kbhotfixserver kbfix kbprb kbwin2000presp1fix kbwinnt400presp7fix KB249863

Dejte nám zpětnou vazbu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com