Les tentatives de connexion à des sites SGC à partir des ordinateurs clients domestiques risquent d'échouer

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Numéro d'article: 249863 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F249863
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Sommaire

Symptômes

Les clients Web peuvent rencontrer un échec de connexion aux sites Web qui utilisent Server Gated Cryptography (SGC) pour des cryptages forts lorsqu'une connexion sécurisée est requise. Si les produits Microsoft sont en cours d'exécution soit sur le serveur Internet, soit sur le client Web, alors la connexion peut échouer. Si le serveur Internet et le client Web exécutent tous les deux des produits Microsoft, alors aucun problème ne survient.

Cause

Ce problème se produit dans le fichier Schannel.dll du fournisseur de sécurité qui est utilisé dans Microsoft Internet Information Server (IIS) et Microsoft Internet Explorer, lorsque vous vous connectez à un site qui utilise SGC pour le cryptage fort, la suite de cryptage utilise un algorithme de hachage pour l'étranger et un autre pour les États-Unis. Dans ce cas, le fichier Schannel.dll choisit parfois l'algorithme inapproprié, ce qui ce qui entraîne l'échec de la tentative de connexion.

Résolution

Windows 2000

Pour résoudre ce problème, procurez-vous le dernier Service Pack pour Windows 2000. Pour plus d'informations, consultez l'article suivant dans la Base de connaissances Microsoft :
260910 Procédures pour obtenir le dernier Service Pack pour Windows 2000

Windows NT 4.0

Pour résoudre ce problème, procurez-vous le Security Rollup Package sur Windows NT 4.0. Pour des informations supplémentaires, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
299444 Security Rollup Package (SRP) postérieur à Windows NT 4.0 Service Pack 6a
La version anglaise de ce correctif doit disposer des attributs de fichier suivants ou de ceux d'une version ultérieure :
   Date     Heure             Taille   Nom de fichier   Plate-forme
   -------------------------------------------------------------
   26/01/2000  18:15          154 384  Schannel.dll     NT x86 40 bits
   26/01/2000  19:40          267 536  Schannel.dll     NT Alpha40 bits
   26/01/2000  19:40          123 664  Schannel.dll     NT x86 128 bits
   26/01/2000  19:40          226 576  Schannel.dll     NT Alpha 28 bits

Windows 9x

Un correctif est désormais disponible auprès de Microsoft, mais est conçu uniquement pour corriger le problème décrit dans cet article et ne doit être appliqué qu'aux systèmes confrontés à ce problème spécifique.

Pour résoudre ce problème rapidement, contactez les services de Support technique Microsoft afin d'obtenir le correctif. Pour obtenir la liste complète des numéros de téléphone du Support technique Microsoft, ainsi que des informations relatives aux frais de support technique, consultez le site Web Microsoft à l'adresse suivante :
http://support.microsoft.com/directory/overview.asp
REMARQUE : Dans certains cas, aucun frais de support technique par téléphone ne vous sera facturé si un technicien du Support technique Microsoft détermine qu'une mise à jour spécifique peut résoudre votre problème. Les frais de support technique concernent les questions et problèmes supplémentaires qui n'entrent pas dans le cadre de la mise à jour en question.

La version anglaise de ce correctif doit disposer des attributs de fichier suivants ou de ceux d'une version ultérieure :
   Date     Heure     Taille   Nom de fichier   Plate-forme
   --------------------------------------------------------------
   26/01/2000  15:15  154 384  Schannel.dll     Win95 40 bits
   26/01/2000  16:40  123 664  Schannel.dll     Win95 128 bits
   26/01/2000  15:15  154 384  Schannel.dll     Win98 40 bits
   26/01/2000  14:40  123 664  Schannel.dll     Win98 128 bits

Statut

Windows 2000

Microsoft a confirmé que ce problème pouvait entraîner une lacune en matière de sécurité dans Windows 2000. Ce problème a été corrigé en premier lieu dans le Service Pack 1 pour Windows 2000.

Windows NT 4.0

Microsoft a confirmé que ce problème pouvait entraîner une lacune en matière de sécurité dans Windows NT 4.0.

Windows 9x

Microsoft a confirmé que ce problème pouvait entraîner une lacune en matière de sécurité dans Windows 95, Windows 98 et Windows 98 Deuxième Édition.

Plus d'informations

Ce correctif doit être appliqué dans les situations suivantes :
  • Si le serveur exécute IIS et que les clients n'exécutent pas Microsoft Internet Explorer, appliquez le correctif Microsoft Windows NT au serveur.
  • Si le serveur exécute Microsoft Personal Web Server (PWS) pour Windows 95 ou 98 et que les clients n'utilisent pas Microsoft Internet Explorer, appliquez le correctif Microsoft Windows 95 ou 98 approprié à l'ordinateur PWS.
  • Si le serveur n'exécute pas IIS ou PWS et que le client n'utilise pas Microsoft Internet Explorer, appliquez le correctif Microsoft Windows NT, Microsoft Windows 95, ou Microsoft Windows 98 approprié au client.
Remarque : Si le serveur Internet et le client Web sont des produits Microsoft, alors cela ne pose aucun problème. Dans la plupart des cas Windows 95 et Windows 98, Windows est utilisé en tant que client, et le correctif doit être appliqué côté client.

Propriétés

Numéro d'article: 249863 - Dernière mise à jour: dimanche 23 février 2014 - Version: 2.6
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows NT Workstation 4.0 Édition Développeur
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Édition Entreprise
  • Microsoft Internet Information Server 4.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Windows 98 Deuxième Édition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professionnel
  • Microsoft Windows 2000 Server
Mots-clés : 
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