I client versione USA non riescono a stabilire connessioni SGC

Traduzione articoli Traduzione articoli
Identificativo articolo: 249863 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I249863
Questo articolo è stato archiviato. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

È possibile che i client Web non riescano a connettersi a siti Web che utilizzano la crittografia avanzata SGC (Server Gated Cryptography) per le connessioni protette. Se solo il server Internet o solo il client Web utilizza prodotti Microsoft, la connessione potrebbe non riuscire, mentre se entrambi eseguono prodotti Microsoft, non si verificheranno problemi.

Cause

Questo problema ha luogo nel file Schannel.dll del provider di protezione. Tale file è utilizzato da Microsoft Internet Information Server (IIS) e Microsoft Internet Explorer quando ci si connette a un sito che utilizza la crittografia avanzata SGC e la versione di esportazione del pacchetto di crittografia utilizza un algoritmo hash diverso da quello della versione USA del pacchetto di crittografia. In questo caso è infatti possibile che il file Schannel.dll selezioni l'algoritmo sbagliato causando il fallimento della connessione.

Risoluzione

Windows 2000

Per risolvere questo problema è necessario ottenere la versione più recente del Service Pack per Windows 2000. Per ulteriori informazioni, vedere il seguente articolo della Microsoft Knowledge Base (informazioni in lingua inglese):
260910Come ottenere il Service Pack più recente per Windows 2000

Windows NT 4.0

Microsoft ha messo attualmente a disposizione una correzione che risolve questo problema. Poiché tale correzione non è ancora stata completamente testata, deve essere utilizzata solo per i sistemi in cui si verifica questo problema specifico. Se il problema in questione non costituisce una seria minaccia per il proprio sistema, si consiglia di attendere il rilascio del prossimo Service Pack per Windows NT 4.0 che contiene questa correzione.

Per risolvere subito il problema, scaricare la correzione come indicato di seguito oppure contattare il Servizio Supporto Tecnico Microsoft. Per un elenco completo dei servizi di supporto Microsoft e sui costi di assistenza, visitare il seguente sito Web:
La versione in lingua inglese di questa correzione deve avere i seguenti attributi di file (o successivi):
   Data       Ora     Dimensione   Nome file     Piattaforma
   -------------------------------------------------------------
   01/26/2000 06:15p  154.384      Schannel.dll  NT x86 40bit
   01/26/2000 07:40p  267.536      Schannel.dll  NT Alpha 40bit
   01/26/2000 07:40p  123.664      Schannel.dll  NT x86 128bit
   01/26/2000 07:40p  226.576      Schannel.dll  NT Alpha 28bit

Windows 9x

Microsoft ha messo attualmente a disposizione una correzione che risolve questo problema. Poiché tale correzione non è ancora stata completamente testata, deve essere utilizzata solo per i sistemi in cui si verifica questo problema specifico.

Per risolvere subito il problema, contattare il Servizio Supporto Tecnico Microsoft per ottenere la correzione. Per un elenco completo dei servizi di supporto Microsoft e sui costi di assistenza, visitare il seguente sito Web:
La versione in lingua inglese di questa correzione deve avere i seguenti attributi di file (o successivi):
   Data       Ora     Dimensione   Nome file     Piattaforma
   -------------------------------------------------------
   01/26/2000 03:15p  154.384      Schannel.dll  Win95 40bit
   01/26/2000 04:40p  123.664      Schannel.dll  Win95 128bit
   01/26/2000 03:15p  154.384      Schannel.dll  Win98 40bit
   01/26/2000 04:40p  123.664      Schannel.dll  Win98 128bit

Status

Windows 2000

Microsoft ha confermato che questo problema riguarda Windows 2000. Questo problema è stato corretto per la prima volta nel Service Pack 1 per Windows 2000.

Windows NT 4.0

Microsoft ha confermato che si tratta di un problema di Windows NT 4.0.

Windows 9x

Microsoft ha confermato che si tratta di un problema di Windows 95, Windows 98 e Windows 98 Seconda edizione.

Informazioni

Questa correzione dovrebbe essere applicata in base agli scenari descritti di seguito:
  • Se il server esegue IIS e i client non dispongono di Microsoft Internet Explorer, applicare la correzione per Microsoft Windows NT al server.
  • Se il server esegue Microsoft Personal Web Server (PWS) per Windows 95 o 98 e i client non dispongono di Microsoft Internet Explorer, applicare la correzione appropriata per Microsoft Windows 95 o 98 al computer PWS.
  • Se il server non esegue IIS o PWS e i client dispongono di Microsoft Internet Explorer, applicare la correzione appropriata per Microsoft Windows NT, Microsoft Windows 95 o Microsoft Windows 98 ai client.
Nota: se il server Internet e i client Web sono entrambi prodotti Microsoft, non sussisterà alcun problema. Nella maggior parte dei sistemi Windows 95 e Windows 98, Windows è utilizzato come client, pertanto la correzione dovrebbe essere applicata al client.

Proprietà

Identificativo articolo: 249863 - Ultima modifica: domenica 23 febbraio 2014 - Revisione: 3.3
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Internet Information Server 4.0
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Server
Chiavi: 
kbnosurvey kbarchive kbqfe kbhotfixserver kbbug kbbug4.00 kbfix kbfix4.00 win2000presp1fix KB249863
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com