ID. de suceso 1025 con código de error "0x80041606" cuando utiliza Outlook en modo en línea para buscar una palabra clave en Exchange Server 2007

Seleccione idioma Seleccione idioma
Id. de artículo: 2498852 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

Síntomas

Considere el siguiente escenario. De forma predeterminada, búsqueda de Exchange está habilitado para una base de datos de buzón en un entorno de Microsoft Exchange Server 2007. Utilice Microsoft Outlook en modo en línea para buscar un buzón para una palabra clave o frase que contiene una sola letra o un solo dígito. En este escenario, recibirá el siguiente mensaje de error, aunque hay coincidencias para la palabra clave en el buzón:
No hay coincidencias para"palabra clave?.


Además, se registra el suceso siguiente en el registro de aplicación en el servidor de buzones:
ID. de suceso: 1025
Categoría: ninguno
Origen: Almacén del buzón de MSExchangeIS
Tipo: advertencia
Genera:fecha>
Escrito:fecha>
Equipo:Equipo>
Mensaje: error en la base de datos "base de datos de buzones/grupo de almacenamiento de información>".
Nombre de función o descripción del problema: la indización de contenido recibió una inusual y
unexpect código de error de Microsoft Search
Error: 0x80041606


NOTA: 0X80041606 = QUERY_E_TOOCOMPLEX

Causa

Este problema se produce porque la búsqueda de Exchange tiene una restricción de consulta de 200.000 nodos. Cuando una búsqueda de prefijo supera la restricción de consulta, la búsqueda devuelve QUERY_E_TOOCOMPLEX. Por lo tanto, 0x80041606 se registra como parte del evento 1025 de ID. De forma predeterminada, todas las búsquedas que utilizan el modo en línea de Outlook en un entorno de Exchange 2007 son búsquedas de prefijo. Si se utilizan letras o dígitos único, esto hace que el sistema buscar todos los números o palabras que comienzan con el dígito o letra a través de la base de datos de buzón entero. Si se alcanza el límite predeterminado de 200.000 nodos, la búsqueda devuelve el error.

NotaEs la forma más habitual para alcanzar el límite de 200.000 nodos buscar una palabra o frase que contiene una letra o dígito. También hay otras causas menos comunes, como escribir búsquedas muy complejas que tienen muchos AND, OR y no los operadores. Además, las combinaciones complejas de rangos de fecha y búsqueda, en términos muchas entradas en elA y Desde campos o una combinación de todas estas cosas puede causar el límite se alcanza.

Solución

Para resolver este problema, instale el paquete siguiente:
2608656 Descripción del paquete acumulativo de actualizaciones 6 para Exchange Server 2007 Service Pack 3
Importante Esta sección, el método o la tarea contiene pasos que le indican cómo modificar el registro. Sin embargo, pueden producirse problemas graves si modifica incorrectamente el registro. Por lo tanto, asegúrese de que siga estos pasos cuidadosamente. Para mayor protección, copia de seguridad del registro antes de modificarlo. Luego puede restaurar el registro si surge algún problema. Para obtener más información acerca de cómo hacer copia de seguridad y restaurar el registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322756 Cómo hacer copia de seguridad y restaurar el registro en Windows

Después de instalar el paquete acumulativo de actualizaciones, siga estos pasos para establecer el número máximo de nodos de restricción de consulta.

Nota Se recomienda un valor de inicio de 1.000.000 (decimal):
  1. En el registro de aplicación en el servidor de buzón de Exchange Server 2007, tenga en cuenta el número de veces ID. de suceso 1025 junto con el código de error 0x80041606 se ha producido durante el mes pasado. Esta información se utilizará como base para determinar si el valor de MaxRestrictionNodes reduce o elimina el problema.
  2. Haga clic en Inicio
    Contraer esta imagenAmpliar esta imagen
    botón Inicio
    , tipo Regedit en el Iniciar búsqueda cuadro y, a continuación, presione ENTRAR.
  3. Busque y, a continuación, haga clic en la siguiente subclave del registro:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExSearch
  4. Haga clic en Editar, seleccione Nuevoy, a continuación, haga clic en Clave.
  5. Tipo MaxRestrictionNodes, y, a continuación, presione ENTRAR.
  6. Haga clic en MaxRestrictionNodes, haga clic en Editar, seleccione Nuevoy, a continuación, haga clic en Valor DWORD (32 bits).
  7. Tipo Servidor, y, a continuación, presione ENTRAR.

    Nota La entrada del registro debe ser similar al siguiente:

    Nombre de clave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExSearch\MaxRestrictionNodes

    Nombre de valor: Server
    Tipo de valor: REG_DWORD
  8. Haga clic en Servidor, haga clic en Editary, a continuación, haga clic en Modificar.
  9. En el Valor de datos campo de tipo 1000000 (Decimal).

    Nota La entrada del registro debe ser similar al siguiente:

    Nombre de clave:
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\ExSearch\MaxRestrictionNodes

    Nombre de valor: Server
    Tipo de valor: REG_DWORD
    Datos de valor: 1000000 (Decimal)
  10. Salga del Editor del registro.
  11. Reinicie el servicio de indizador de búsqueda de Microsoft Exchange.
Notas
  • Después de reiniciar el servicio de indizador de búsqueda de Microsoft Exchange, compruebe el registro de aplicación para los identificadores de suceso siguiente:
    • 130 De ID. de suceso: error al convertir la lectura de MailboxDB Guid en debajo de la clave de registro MaxRestrictionNodes en un GUID
    • 131 De ID. de suceso: error al abrir la clave del registro de MaxRestrictionNodes
    • 132 De ID. de suceso: error al establecer la propiedad MaxRestrictionNodes en el indizador
  • Si recibe cualquiera de estos eventos, puede escribió la clave del registro o el valor DWORD incorrectamente. O bien, es posible que no haya escrito la nueva clave o valor DWORD correctamente. Realice las correcciones necesarias y, a continuación, reinicie el servicio de indizador de búsqueda de Microsoft Exchange. Buscar todas las nuevas instancias de identificadores de suceso 130, 131 y 132.
  • Compruebe el registro de aplicación semanal o mensual en función del número de mensajes de sucesos identificador 1025 que tengan el error 0x80041606 en el registro de aplicación.
  • Si sigue recibiendo un número significativo de estos eventos, puede aumentar el valor incrementalmente a 2000000 (Decimal).
  • No aumente el valor más allá de 2000000 (Decimal) sin dirección explícito de un ingeniero de soporte técnico de Microsoft porque esto puede reducir el rendimiento del servidor.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "Se refiere a:".

Más información

Para obtener más información acerca de la búsqueda de Exchange, visite el siguiente sitio Web de Microsoft:
Información general acerca de la búsqueda de Exchange
Para obtener más información acerca de cómo deshabilitar o habilitar la búsqueda de Exchange, visite el siguiente sitio Web de Microsoft:
Información general acerca de cómo deshabilitar o habilitar la búsqueda de Exchange
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:

2616127ID. de suceso 9877 con código de error "0x80041606" cuando utiliza Outlook en modo en línea para buscar una palabra clave en Exchange Server 2010

Propiedades

Id. de artículo: 2498852 - Última revisión: martes, 30 de octubre de 2012 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Exchange Server 2007 Service Pack 3 sobre las siguientes plataformas
    • Microsoft Exchange Server 2007 Standard Edition
    • Microsoft Exchange Server 2007 Enterprise Edition
Palabras clave: 
kbqfe kbfix kbsurveynew kbexpertiseinter kbmt KB2498852 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2498852

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com