Das System stürzt ab, wenn Sie ein Konto hinzufügen, das crmAppPool als Microsoft Dynamics CRM Benutzer ausführt.

Dieser Artikel bietet eine Lösung für das Systemabsturzproblem, das auftritt, wenn Sie ein Konto hinzufügen, das CRMAppPool als Microsoft Dynamics CRM Benutzer ausführt.

Gilt für: Microsoft Dynamics CRM 2011
Ursprüngliche KB-Nummer: 2500917

Problembeschreibung

Wenn Sie ein Konto hinzufügen, das CRMAppPool als Microsoft Dynamics CRM Benutzer ausführt, stürzt das System ab. Darüber hinaus erhalten Sie möglicherweise Fehler, die den folgenden ähneln:

SecLib::RetrievePrivilegeForUser failed – dem Benutzer sind keine Rollen zugewiesen. Hr = -2147209463, User: [userid] zurückgegeben

Ursache

Wenn ein Microsoft Dynamics CRM Benutzer in Microsoft Dynamics CRM erstellt wird, verfügt der Benutzer standardmäßig über keine Sicherheitsrollen. Da das Microsoft Dynamics CRM-Dienstkonto dem neu erstellten Benutzer zugeordnet ist, kann das Microsoft Dynamics CRM-Dienstkonto nichts ausführen. Daher stürzt das System ab.

Es handelt sich hierbei um ein beabsichtigtes Verhalten. Das Festlegen des Kontos, auf dem CRMAppPool ausgeführt wird, in einem Microsoft Dynamics CRM Benutzer wird nicht unterstützt.

Lösung

Behalten Sie das Microsoft Dynamics CRM-Dienstkonto als dediziertes Dienstkonto bei.

Weitere Informationen

Weitere Informationen finden Sie im Abschnitt Identitätsberechtigungen für IIS-Anwendungspools für Dienste und CRMAppPool des implementierungshandbuchs für Microsoft Dynamics CRM 2011.

Informationen zum Herunterladen des Leitfadens finden Sie im Microsoft Dynamics CRM 2011-Implementierungshandbuch.