El sistema se bloquea al agregar una cuenta que ejecuta CRMAppPool como usuario Microsoft Dynamics CRM
En este artículo se proporciona una resolución del problema de bloqueo del sistema que se produce al agregar una cuenta que ejecuta CRMAppPool como usuario Microsoft Dynamics CRM.
Se aplica a: Microsoft Dynamics CRM 2011
Número de KB original: 2500917
Síntomas
Al agregar una cuenta que ejecuta CRMAppPool como usuario Microsoft Dynamics CRM, el sistema se bloquea. Además, puede recibir errores similares a los siguientes:
Error de SecLib::RetrievePrivilegeForUser: no se asignan roles al usuario. Devuelve hr = -2147209463, User: [userid]
Causa
De forma predeterminada, cuando se crea un usuario Microsoft Dynamics CRM en Microsoft Dynamics CRM, el usuario no tiene roles de seguridad. Dado que la cuenta de servicio de Microsoft Dynamics CRM se asigna al usuario recién creado, la cuenta de servicio de Microsoft Dynamics CRM no puede funcionar en nada. Por lo tanto, el sistema se bloquea.
Este comportamiento es una característica del diseño de la aplicación. No se admite la creación de la cuenta que ejecuta CRMAppPool en un usuario Microsoft Dynamics CRM.
Resolución
Mantenga la cuenta de servicio Microsoft Dynamics CRM como una cuenta de servicio dedicada.
Más información
Encontrará más información en la sección Servicios y permisos de identidad del grupo de aplicaciones de IIS CRMAppPool de la Guía de implementación de Microsoft Dynamics CRM 2011.
Para descargar la guía, consulte Microsoft Dynamics CRM Guía de implementación de 2011.