CRMAppPool を実行しているアカウントをMicrosoft Dynamics CRM ユーザーとして追加すると、システムがクラッシュします

この記事では、CRMAppPool を実行しているアカウントを Microsoft Dynamics CRM ユーザーとして追加するときに発生するシステム クラッシュの問題の解決策について説明します。

適用対象: Microsoft Dynamics CRM 2011
元の KB 番号: 2500917

現象

CRMAppPool を実行しているアカウントをMicrosoft Dynamics CRMユーザーとして追加すると、システムがクラッシュします。 さらに、次のようなエラーが発生する場合があります。

SecLib::RetrievePrivilegeForUser が失敗しました。ロールはユーザーに割り当てされていません。 返された hr = -2147209463、ユーザー: [userid]

原因

既定では、Microsoft Dynamics CRM ユーザーがMicrosoft Dynamics CRMで作成されると、ユーザーにはセキュリティ ロールがありません。 Microsoft Dynamics CRM サービス アカウントは新しく作成されたユーザーにマップされるため、Microsoft Dynamics CRM サービス アカウントは何も操作できません。 そのため、システムがクラッシュします。

この動作は仕様です。 CRMAppPool を実行しているアカウントをMicrosoft Dynamics CRMユーザーに作成することはサポートされていません。

解決方法

Microsoft Dynamics CRM サービス アカウントを専用サービス アカウントとして保持します。

詳細

詳細については、「Microsoft Dynamics CRM 2011 実装ガイド」の「サービスと CRMAppPool IIS アプリケーション プール ID のアクセス許可」セクションを参照してください。

ガイドをダウンロードするには、「Microsoft Dynamics CRM 2011 実装ガイド」を参照してください。