Mensagem de erro "Problema de comunicação com o Microsoft Dynamics CRM Server" quando configurar o cliente do Dynamics CRM para Outlook

Traduções de Artigos Traduções de Artigos
Artigo: 2502671 - Ver produtos para os quais este artigo se aplica.
Expandir tudo | Reduzir tudo

Sintomas

Quando um utilizador tenta configurar o cliente Microsoft Dynamics CRM para Outlook utilizando o Assistente de configuração, o utilizador recebe a seguinte mensagem de erro:
Existe um problema ao comunicar com o Microsoft Dynamics CRM Server. O servidor pode estar indisponível. Tente novamente mais tarde. Se o problema persistir, contacte o administrador.

Causa

Este problema poderá ocorrer por qualquer uma das seguintes causas:
  1. A data do sistema operativo no computador cliente não está definida como a data correcta.
  2. A hora do sistema operativo no computador cliente não está definida para a hora correcta.
  3. O fuso horário do sistema operativo no computador cliente não está definido para o fuso horário correcto.
  4. Existem várias ligações de HTTP no Web site do Microsoft Dynamics CRM no Internet Information Services (IIS).

Resolução

Por motivos 1, 2 e 3

  1. Sair do Assistente de configuração do CRM.
  2. Altere a data do sistema operativo e a hora. Para tal, utilize um dos seguintes métodos.

    Método 1: Alterar manualmente a hora do sistema operativo


    Nota
    são os seguintes passos para sistemas operativos Windows 7 ou Windows Server 2008. Para alterar a data e hora manualmente no Windows XP, consulte o manual de ajuda do Windows XP.
    1. Clique em Iniciar, clique em Painel de controlo, clique em Relógio, idioma e regiãoe, em seguida, clique em Data e hora.
    2. No Data e hora caixa de diálogo, clique em Alterar data e hora Para alterar a data e definições de tempo. Por exemplo, clique numa data, como de 1 de Fevereiro de 2011 do calendário e alterar a hora.
    3. Clique em OK.
    4. Clique em Alterar fuso horárioe, em seguida, seleccione o fuso horário.
    5. Clique em OK.

    Método 2: Configurar o sistema operativo tempo para sincronizar com um servidor de horas da Internet
    1. Clique em Iniciar, clique em Painel de controlo, clique em Relógio, idioma e regiãoe, em seguida, clique em Data e hora.
    2. No Data e hora caixa de diálogo, faça clique sobre o Hora da Internet separador e, em seguida, clique Alterar definições.
    3. Clique para seleccionar o Sincronizar com um servidor de horas da Internet caixa de verificação, seleccione um servidor de horas, clique em Actualizar agorae, em seguida, clique em OK.

    Método 3: Utilizar um comando para sincronizar a hora com o domínio se o computador for membro de um domínio
    1. Clique em Iniciar, clique em Todos os programas, clique em Acessórios, com o botão direito Linha de comandose, em seguida, clique em Executar como administrador.
    2. Na linha de comandos, escreva o seguinte texto e, em seguida, prima Enter:
      net time [{\ \Nome do computador | /Domain [:Nome de domínio] | /RTSDOMAIN [:Nome de domínio]}] [/set]
      Se não souber o Nome do computador ou o Nome de domínio, tente o seguinte comando simple:
      net time /set
      Em seguida, escreva YPara terminar a alteração:

      Reduzir esta imagemExpandir esta imagem
      2555885

    Para mais informações sobre o comando net time , visite o seguinte Web site da Microsoft:
Método 4: Forçar uma sincronização do cliente de rede NTP (Time Protocol) se o computador utiliza um cliente NTP para sincronizar com um servidor NTP

Para a causa 4


No servidor da web Microsoft Dynamics CRM 2011, abra o Gestor de IIS e limitar o Web site do CRM para uma ligação de http ou um enlace https ou ambos. Para tal, siga estes passos:
  1. Clique em Iniciar, clique em Executare tipo inetmgr no Abrir caixa.
  2. Expandir Sitese, em seguida, faça clique sobre o Web site do Microsoft Dynamics CRM.
  3. No Painel de acções, clique em Enlaces.
  4. No Ligações de sites janela, certifique que só tem uma ligação de http, escreva ou tipo de enlace de https apenas um ou ambos. Se tiver várias ligações de http ou várias ligações de https ou ambos, os enlaces múltiplos devem ser removidos.

Nota O enlace que deve permanecer é o enlace que é definido no Gestor de implementação. Para verificar os URL correctos, abra o Gestor de implementação, com o botão direitoMicrosoft Dynamics CRM, seleccione Propriedadese, em seguida, faça clique sobre o Endereço Web separador.

Nota Se for utilizada a implementação de opostas de Internet (IFD), deve ser mantido o certificado que corresponde às definições do IFD.

Mais Informação

Rastreio de configuração do Outlook (erro no) para a causa 1, 2 e 3
Excepção rethrown [0]:
em System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage (IMessage reqMsg, IMessage retMsg)
em System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke (MessageData & msgData, Int32 tipo)
em Microsoft.Xrm.Sdk.Discovery.IDiscoveryService.Execute (pedido de DiscoveryRequest)
em Microsoft.Xrm.Sdk.Client.DiscoveryServiceProxy.Execute (pedido de DiscoveryRequest)
em Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.DeploymentInfo.LoadOrganizations (AuthUIMode uiMode)
em Microsoft.Crm.Application.Outlook.Config.DeploymentsInfo.LoadOrganizations (AuthUIMode uiMode)
02:45:29| Error| Erro ao ligar ao URL: https://dev.crm5.Dynamics.com/XRMServices/2011/Discovery.svc

Excepção: System.ServiceModel.Security.MessageSecurityException: foi recebida uma falha não protegida ou incorrectamente protegida proveniente do outro interveniente. Consulte a FaultException de segurança para o código de falha e detalhe. ---> System.ServiceModel.FaultException: Ocorreu um erro ao verificar a segurança da mensagem.
---Fim do rastreamento da pilha de excepção interna


Rastreio de plataforma do Microsoft CRM Server (no erro) para a causa 4
Erro: O serviço ' / XRMServices/2011/Discovery.svc' não é possível activar devido a uma excepção durante a compilação. A mensagem de excepção é: Esta colecção já contém um endereço com o esquema http. Pode haver, no máximo, um endereço por esquema nesta colecção de. Se o serviço estiver a ser alojado no IIS pode corrigir o problema a definição 'system.serviceModel/serviceHostingEnvironment/multipleSiteBindingsEnabled' como VERDADEIRO ou especificando 'system.serviceModel/serviceHostingEnvironment/baseAddressPrefixFilters'.
O nome do parâmetro: item.

Propriedades

Artigo: 2502671 - Última revisão: 16 de julho de 2013 - Revisão: 3.1
A informação contida neste artigo aplica-se a:
  • Microsoft Dynamics CRM 2011
  • Microsoft Dynamics CRM for Microsoft Office Outlook with Offline Access
Palavras-chave: 
kbmbsmigrate kbsurveynew kbcip kbmt KB2502671 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 2502671

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com