Error al intentar desinstalar una solución administrada en Microsoft Dynamics CRM: "el objeto que se ha intentado eliminar está asociado con otro objeto y no se puede eliminar"

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Síntomas

Al intentar desinstalar una solución administrada en Microsoft Dynamics CRM, recibirá el siguiente mensaje de error:
El objeto que se ha intentado eliminar está asociado con otro objeto y no se puede eliminar

Sin embargo, es difícil determinar qué objeto se encuentra el objeto al que hace referencia el mensaje de error. El registro de seguimiento de la plataforma de CRM proporciona ningún detalle.

Por ejemplo, esto puede ocurrir en cualquiera de las situaciones siguientes:
  • Tiene instalada una solución administrada que incluya "Plantilla de artículo".
  • Hay registros de artículo en el sistema que hacen referencia a la templo del artículo en la solución administrada.

Causa

"Plantilla de artículo" en la solución no es una entidad, pero un registro. Por lo tanto, la dependencia es el nivel de registro, no el nivel de entidad. En este caso, el seguimiento de dependencias no funcionan, y se producirá un error en cascada.

De forma predeterminada, "Plantilla de artículo" y "Article" tienen una relación 1: n como Restrict para eliminación en cascada. Esto evita que la eliminación de un registro de la plantilla de artículo del sistema si se hace referencia a la plantilla por los registros de artículo.

Solución

En no puede desinstalar una solución administrada a causa de este error, debe comprobar el tipo de registro de los componentes de la solución dentro de la solución y compruebe si alguno de los registros se refieren a dichos componentes. Para resolver la referencia, tendrá que eliminar o modificar el registro que está asociado con el componente de la solución y, a continuación, intente desinstalar de nuevo la solución.

Más información

Se producirá problemas similares con otros tipos de componentes de la solución, como los siguientes:
  • Otros tipos de plantilla
  • Artículos de Microsoft Knowledge Base
  • Recursos Web
  • Proceso (proceso secundario)

Propiedades

Id. de artículo: 2503016 - Última revisión: viernes, 25 de febrero de 2011 - Versión: 1.1
La información de este artículo se refiere a:
  • Microsoft Dynamics CRM 2011
  • Microsoft Dynamics Live CRM Professional Edition
Palabras clave: 
kbmbsmigrate kbsurveynew kbmt KB2503016 KbMtes
Traducción automática
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Haga clic aquí para ver el artículo original (en inglés): 2503016

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