Works: How to Mail Merge All or Selected Records

Article translations Article translations
Article ID: 250310 - View products that this article applies to.
This article was previously published under Q250310
Expand all | Collapse all

On This Page

SUMMARY

This article describes how to merge data in a Microsoft Works database with a Works word processor document by using the Mail Merge function.

MORE INFORMATION

Mail Merge Data in All Records

To mail merge the data in all of the records in a database:
  1. Start Microsoft Works Word Processor.
  2. Open or create the document into which you want to merge data.
  3. On the Insert menu, click Database Field.
  4. Click the Merge information from another type of file button.
  5. In the Open Data Source dialog box, browse to the location of the database that contains the data that you want to merge.
  6. Click to select the database file, and then click Open.
  7. Under Fields in the Insert Fields dialog box, click to select the first field that you want to include in the mail-merge document, and then click Insert.
  8. Use the SPACEBAR, the TAB key, or the ENTER key to move the cursor to where you want the next field to be positioned.
  9. Repeat steps 7 and 8 for each field that you want to include in the mail-merge document.
  10. In the Insert Fields dialog box, click View Results.
  11. If you want to view different records in the mail-merge document, click the forward arrow or the back arrow in the View Results dialog box.
  12. On the File menu, click Save As.
  13. In the Save in box, click the folder where you want to save the file.
  14. In the File name box, type a file name, and then click Save.

Mail Merge Data in Marked Records

To mail merge the data in marked records in a database, you must first mail merge the data in all of the records in the database, and then use a filter in Works Word Processor to view or print only the data in the marked records. To do this:
  1. Start Microsoft Works Database.
  2. Open the database that contains the data you want to merge.
  3. On the View menu, click List.
  4. Click to select or clear the check box next to the record number (the row number to the left of each record) of each record that you want to mark or unmark.
  5. On the File menu, click Save.
  6. Quit Works Database.
  7. Start Works Word Processor.
  8. Open or create the document into which you want to merge data.
  9. On the Insert menu, click Database Field.
  10. Click the Merge information from another type of file button.
  11. In the Open Data Source dialog box, browse to the location of the database that contains the data that you want to merge.
  12. Click to select the database file, and then click Open.
  13. Under Fields in the Insert Fields dialog box, click to select the first field that you want to include in the mail-merge document, and then click Insert.
  14. Use the SPACEBAR, the TAB key, or the ENTER key to move the cursor to where you want the next field to be positioned.
  15. Repeat steps 12 and 13 for each field that you want to include in the mail-merge document.
  16. In the Insert Fields dialog box, click View Results.
  17. On the Tools menu, point to Mail Merge, and then click Filter and Sort.
  18. Click Use Marked Records, and then click OK.
  19. In the View Results dialog box, the total number of records should equal the number of records that you marked in step 4.

    If you want to view different records in the mail-merge document, click the forward arrow or the back arrow in the View Results dialog box.
  20. On the File menu, click Save As.
  21. In the Save in box, click the folder where you want to save the file.
  22. In the File name box, type a file name, and then click Save.

Change the Mail-Merge Document from Marked Records to All Records

To change a mail-merge document from a document that merges only the marked records in a database to a document that merges all of the records in a database:
  1. Start Works Word Processor.
  2. Open the mail-merge document that merges only the marked records in a database.
  3. On the Tools menu, point to Mail Merge, and then click Filter and Sort.
  4. Click Clear Filter, and then click OK.
  5. On the File menu, click Save As.
  6. In the Save in box, click the folder in which you want to save the file.
  7. In the File name box, type a file name, and then click Save.

Mail Merge Test

To mail merge and print only the first record in a database:
  1. Open the Works Word Processor document that you want to print.
  2. On the File menu, click Print.
  3. Click Test.

Mail Merge Data in a Selected Series of Records

To mail merge the data in a selected sequence of records in a database:
  1. Open the mail merge document that you want to print.
  2. On the File menu, click Print.
  3. Under Print range, click Record.
  4. In the from box, type the number of the first record that you want to print.
  5. In the to box, type the number of the last record that you want to print.
  6. Click OK.

Hints and Tips

To prevent Works from printing blank lines for empty merge fields, click to select the Don't print lines with empty fields check box in the Print dialog box, and then click OK.

To print personalized letters that can be edited individually, click to select the Send merge result to a new document check box in the Print dialog box, and then click OK.

Works creates a new document that contains individual letters for each merged record. You can then personalize each letter in the document before you print it.

Properties

Article ID: 250310 - Last Review: January 27, 2007 - Revision: 2.1
APPLIES TO
  • Microsoft Works 2000 Standard Edition
  • Microsoft Works 6.0
Keywords: 
kbdisplay kbhowto kbinterop kbui KB250310
Retired KB Content Disclaimer
This article was written about products for which Microsoft no longer offers support. Therefore, this article is offered "as is" and will no longer be updated.

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com