Numéro d'article: 250343 - Dernière mise à jour: mercredi 13 juin 2007 - Version: 4.0

Messages d'erreur « Commande non valide » ou « Assistant Installation » pendant l'installation après affichage de l'invite Clé du CD

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Symptômes

Après le démarrage de l'installation de Visual Studio 6 (ou d'un produit Visual Studio autonome), Visual Studio 6 Service Pack 5 ou Visual Studio 6 Service Pack 6 sur Microsoft Windows NT, sur Microsoft Windows 2000, ou sur Microsoft Windows XP, l'un des messages d'erreur suivants peut s'afficher avant ou après l'entrée de la clé du CD :
Setup a rencontré un problème et doit être fermé
L'assistant Installation n'a pas pu trouver Acme setup
L'assistant Installation ne trouve pas Acme setup
Erreur d'installation 530 Ligne de commande non valide
Erreur d'installation 530 Option de commande non valide dans settings \administrators\localsettings\temp\vs60wiz.exe
Erreur d'installation 725 Ligne de commande non valide
Erreur de programme dans VS60wiz.exe
Erreur d?initialisation du programme d?installation ; il n?y a pas suffisamment de mémoire pour exécuter le programme d?installation
Erreur d?initialisation du programme d?installation ; il n?y a pas suffisamment d?espace sur le disque pour exécuter le programme d?installation.
Le chemin d'accès spécifié n'existe pas. Vérifiez que le chemin est correct, puis essayez à nouveau.

Cause

L'installation ne réussit pas au niveau de la machine virtuelle DOS Microsoft Windows NT (NTDVM, Microsoft Windows NT Virtual DOS Machine) car l'installation est transférée vers Acmsetup. Cela est dû à un sous-système 16 bits endommagé.

Résolution

Sur les plates-formes Windows 2000, démarrez en Mode sans échec en appuyant sur F8 au démarrage du système et en sélectionnant Mode sans échec. Retentez ensuite l'installation.

Si l'installation échoue et génère l'une des erreurs répertoriées à la section « Symptômes » de cet article, passez aux étapes suivantes :
  1. Videz le dossier Temp en supprimant toutes les installations incomplètes précédentes.
    • L'emplacement par défaut du dossier Temp sur Windows 2000 est C:\Documents and Settings\Profile\Local Settings\Temp C:\Winnt\Temp ou, si vous avez effectué une mise à niveau à partir de Windows 98, C:\Windows\Temp.
    • L'emplacement par défaut du dossier Temp sur Windows NT 4 est C:\Temp C:\Winnt\Temp.
    REMARQUE Pour connaître l'emplacement de votre dossier Temp : dans le menu Démarrer, cliquez sur Exécuter, tapez %temp%, puis cliquez sur OK.

  2. Essayez de démarrer manuellement Acmsetup en tapant la ligne de commande suivante :
    E:\SETUP\ACMSETUP.EXE /T *.STF /S E:\ /n "" /o "" /k "YYYYYYYYYY" /b1
    E est la lettre du lecteur de CD-ROM ou de DVD-ROM, et YYYYYYYYYY est la clé de CD pour le produit (les options /k et leur argument doivent être omis pour les installations de Service Pack).

    REMARQUE : Le fichier *.stf spécifique qui est requis pour la ligne de commande manuelle peut varier en fonction du produit que vous installez. Recherchez le fichier *.stf à utiliser dans le dossier \Setup sur le CD-ROM du produit que vous installez. Par exemple, pour Visual Basic 6.0 Édition Professionnelle, utilisez VB98Pro.stf.
Si vous ne pouvez toujours pas installer le produit en entrant la ligne de commande manuellement, passez à l'étape suivante afin de réparer le processus NTVDM.

Annulez tous les paramètres non standard dans les fichiers Config.nt et Autoexec.nt dans le dossier system root\System32. Pour cela, utilisez une instruction REM afin de mettre en commentaire chaque entrée à l'exception des entrées par défaut suivantes :
Config.nt

dos=high, umb
device=%SystemRoot%\system32\himem .sys
files=20

Autoexec.nt

lh %SystemRoot%\system32\mscdexnt.exe
lh %SystemRoot%\system32\redir
lh %SystemRoot%\system32\dosx
lh %SystemRoot%\system32\nw16 (uniquement si CSNW est installé)*
lh %SystemRoot%\system32\vwipxspx (uniquement si CSNW est installé)*

* CSNW est Services client pour NetWare
REMARQUE : Une autre façon de faire consiste à développer Autoexec.nt_ et Config.nt_ à partir du CD-ROM Windows NT ou Windows 2000 dans le dossier SystemRoot\System32 :
  • Pour développer un seul fichier compressé, utilisez le programme Expand.exe. Ce programme se situe sur le CD-ROM Windows dans le dossier I386.
  • Pour développer les fichiers requis :
    1. Insérez le CD-ROM Windows dans le lecteur de CD-ROM ou de DVD-ROM.
    2. À l'invite de commandes, tapez ce qui suit, puis appuyez sur ENTRÉE :
      C:\WINDOWS\System32\Autoexec.nt
    3. À l'invite de commandes, tapez ce qui suit, puis appuyez sur ENTRÉE :
      EXPAND X:\i386\Config.NT_ C:\WINDOWS\System32\Config.nt
    4. Redémarrez l'ordinateur et essayez d'installer de nouveau le produit.

Plus d'informations

Setup.exe transmet les informations suivantes à Acmsetup.exe :
X:\disk1\SETUP\ACMSETUP.EXE /T VS98Ent.STF /S E:\ /n "" /o "" /k "YYYYYYYYYY" /b 1

où :
  • X est votre chemin d'accès à Acmsetup.exe
  • E est la lettre du lecteur de CD-ROM ou de DVD-ROM
  • YYYYYYYYYY est la clé de CD
Vous pouvez vérifier les commutateurs de ligne de commande en exécutant le programme d'installation sur un ordinateur qui fonctionne correctement, puis en créant un journal d'installation.

Votre fichier *.stf spécifique varie en fonction du produit que vous installez. Recherchez le fichier *.stf à utiliser dans le dossier \Setup du produit que vous installez. Par exemple, pour Visual Basic 6.0 Édition Professionnelle, il s'agit du fichier VB98Pro.stf.

Génération d'un fichier journal

Vous pouvez indiquer la partie Acme du programme d'installation afin de générer un fichier journal. Pour cela, démarrez le programme d'installation à l'aide de la commande suivante :
X:\setup /gc chemin\nom_fichier
X est l'emplacement du lecteur de CD-ROM ou de DVD-ROM, et chemin\nom_fichier est le chemin d'accès et le nom du fichier journal. Le chemin d'accès et le nom de fichier doivent être au format de nom court 8.3 et ne doivent pas être placés entre guillemets.

Références

Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
196453  (http://support.microsoft.com/kb/196453/ ) Résolution des erreurs de démarrage de NTVDM et WOW
220155  (http://support.microsoft.com/kb/220155/ ) Résolution des erreurs de démarrage de NTVDM et WOW
165214  (http://support.microsoft.com/kb/165214/ ) Dépannage des programmes MS-DOS sous Windows
222975  (http://support.microsoft.com/kb/222975/ ) Impossible d'installer programme qui utilise son utilitaire d'installation
260513  (http://support.microsoft.com/kb/260513/ ) Une erreur se produit lors de l'installation de produits Visual Studio
192392  (http://support.microsoft.com/kb/192392/ ) Comment faire pour dépanner l'Installation de Visual Studio 6.0
192731  (http://support.microsoft.com/kb/192731/ ) BOGUE : Blocage ou erreur d'application au cours de l'installation

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Visual Studio 6.0 Enterprise Edition
  • Microsoft Visual Basic 6.0 Édition initiation
  • Microsoft Visual Basic 6.0 Édition professionnelle
  • Microsoft Visual Basic 6.0 Édition Entreprise
  • Microsoft Visual C++ 6.0 Édition Entreprise
  • Microsoft Visual C++ 6.0 Édition Professionnelle
  • Microsoft Visual C++, 32-bit Learning Edition 6.0
  • Microsoft Visual InterDev 6.0 Édition standard
  • Microsoft Visual FoxPro 6.0 Édition Professionnelle
  • Microsoft Visual J++ 6.0 Édition standard
  • Microsoft Visual SourceSafe 6.0 Standard Edition
Mots-clés : 
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