Artigo: 250343 - Última revisão: terça-feira, 2 de Maio de 2006 - Revisão: 4.0

Linha de comandos "Comando inválido" ou "Assistente de instalação" erros durante a execução do programa de configuração depois da chave do CD

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Depois de iniciar a instalação do Visual Studio 6 (ou um produto Visual Studio autónomo), Visual Studio 6 Service Pack 5 ou Visual Studio 6 Service Pack 6 no Windows NT, no Microsoft Windows 2000 ou no Microsoft Windows XP, poderá receber uma das seguintes mensagens de erro antes ou depois de introduzir a chave do CD:
O programa de configuração encontrou um problema e vai ser encerrado
Assistente de instalação não foi possível encontrar Acme o programa de configuração
Assistente de instalação não é possível localizar Acme o programa de configuração
Configuração de linha de comandos inválido erro 530
Opção de comando inválido erro 530 no \administrators\localsettings\temp\vs60wiz.exe definições de configuração
Configuração erro 725 linha de comandos inválido
Erro de aplicação no VS60wiz.exe
Erro de inicialização de configuração; não existe memória suficiente para executar o programa de configuração
Erro de inicialização de configuração; não existe espaço em disco insuficiente para executar o programa de configuração
O caminho especificado não existe. Verifique o caminho e tente novamente

Causa

O programa de configuração não terá êxito ao nível do Windows NT Virtual DOS Machine (NTVDM) como a instalação é entregues ao Acmsetup. Isto é causado por um subsistema de 16-bit danificado.

Resolução

Em plataformas do Windows 2000, inicie no Modo de segurança premindo F8 quando lhe for pedido durante o arranque do sistema e seleccionar o Modo de segurança . Em seguida, tente novamente a instalação.

Se a instalação não terá êxito e devolve um dos erros listados na secção "Sintomas" deste artigo, continue com os seguintes passos:
  1. Limpe a pasta Temp, removendo instalações incompletas anteriores.
    • A localização predefinida para a pasta Temp no Windows 2000 é C:\Documents and Settings\ Profile \Local Settings\Temp C:\Winnt\Temp ou, se actualizado do Windows 98, C:\Windows\Temp.
    • A localização predefinida para a pasta Temp no Windows NT 4 é C:\Winnt\Temp C:\Temp.
    Nota : para descobrir a localização da sua pasta Temp: no menu Iniciar , clique em Executar , escreva % temp % e, em seguida, clique em OK .

  2. A tentar iniciar manualmente Acmsetup escrevendo a seguinte linha de comandos:
    E : \SETUP\ACMSETUP.EXE /T *.STF /S E:\ /n "" /o""/k" YYYYYYYYYY" /b1
    em que E é a letra da unidade CD-ROM ou DVD-ROM e YYYYYYYYYY é a chave do CD para o produto (as opções de /k e o argumento devem ser omitidos para instalações de Service Pack).

    NOTA: O ficheiro *.stf específica que é necessário para a linha de comandos manual irá variar consoante o produto específico que está a instalar. Procure a pasta \Setup o CD-ROM do produto que está a instalar para *.stf utilizar. Por exemplo, para o Visual Basic 6.0 Professional, utilize VB98Pro.stf.
Se ainda não conseguir instalar o produto, passando a linha de comandos manualmente, continue com o seguinte para reparar o NTVDM processo.

Anular quaisquer definições não padrão nos ficheiros Config.NT e Autoexec.NT na system root \System32. Para o fazer, utilize uma instrução REM para remark fora cada entrada , excepto as seguintes entradas predefinidas:
Config.NT

dos = high, umb
Device=%SystemRoot%\system32\himem.sys
ficheiros = 20

Autoexec.NT

lh %SystemRoot%\system32\mscdexnt.exe
lh %SystemRoot%\system32\redir
lh %SystemRoot%\system32\dosx
lh %SystemRoot%\system32\nw16 (apenas se CSNW estiver instalado) *
lh %SystemRoot%\system32\vwipxspx (apenas se CSNW estiver instalado) *

* CSNW está Serviços de cliente para NetWare
NOTA: Outra forma de efectuar este procedimento é expandir Autoexec.nt_ e Config.nt_ a partir do CD-ROM do Windows 2000 ou Windows NT para a SystemRoot \System32:
  • Para expandir um único ficheiro comprimido, utilize o Expand.exe programa. Programa deste está localizado no CD-ROM do Windows a I386 pasta.
  • Para expandir os ficheiros necessários:
    1. Introduza o CD-ROM do Windows na unidade CD-ROM ou DVD-ROM.
    2. Na linha de comandos, escreva o seguinte e, em seguida, prima ENTER:
      C:\WINDOWS\System32\Autoexec.NT
    3. Na linha de comandos, escreva o seguinte e, em seguida, prima ENTER:
      EXPAND X:\i386\Config.NT_ C:\WINDOWS\System32\Config.nt
    4. Reinicie o computador e tente instalar novamente o produto.

Mais Informação

Setup.exe transmite o seguinte para Acmsetup.exe:
X : \disk1\SETUP\ACMSETUP.EXE /T VS98Ent.STF /S E : \ /n "" /o""/k" YYYYYYYYYY" /b 1

em que:
  • X é o caminho para Acmsetup.exe
  • E é a letra da unidade CD-ROM ou DVD-ROM
  • YYYYYYYYYY é a chave do CD
Pode verificar os parâmetros da linha de comandos a utilizar o programa de configuração num computador que está a funcionar correctamente, assim, criar um registo de configuração.

O ficheiro *.stf específico irá variar consoante o produto específico que está a instalar. Procure a pasta \Setup do produto que está a instalar para *.stf utilizar. Por exemplo, para o Visual Basic Professional 6.0, é VB98Pro.stf

Gerar um ficheiro de registo

Pode saber parte do programa de configuração para gerar um ficheiro de registo Acme. Para efectuar este procedimento, inicie o programa de configuração com o seguinte comando:
X : \setup /gc path \ file name
onde X é a localização da unidade de CD-ROM ou de DVD-ROM e path\file name é o caminho e o nome do ficheiro de registo. O nome do caminho e tem de ser no formato de nome abreviado de 8.3 e tem não estar entre aspas.

Referências

Para obter mais informações, clique números de artigo que se seguem para visualizar os artigos na base de dados de conhecimento da Microsoft:
196453  (http://support.microsoft.com/kb/196453/ ) Resolução de problemas erros de arranque NTVDM e WOW
220155  (http://support.microsoft.com/kb/220155/ ) Resolução de problemas erros de arranque NTVDM e WOW
165214  (http://support.microsoft.com/kb/165214/ ) Resolução de problemas MS DOS programas baseados no Windows
222975  (http://support.microsoft.com/kb/222975/ ) Não é possível instalar o programa utilizando o utilitário de configuração
260513  (http://support.microsoft.com/kb/260513/ ) Ocorre um erro quando instala produtos Visual Studio
192392  (http://support.microsoft.com/kb/192392/ ) Como resolver problemas de programa de configuração do Visual Studio 6.0
192731  (http://support.microsoft.com/kb/192731/ ) Erro: Bloqueio ou erro de aplicação no programa de configuração

A informação contida neste artigo aplica-se a:
  • Microsoft Visual Studio 6.0 Enterprise Edition
  • Microsoft Visual Basic 6.0 Learning Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic Enterprise Edition for Windows 6.0
  • Microsoft Visual C++ 6.0 Enterprise Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual C++, 32-bit Learning Edition 6.0
  • Microsoft Visual InterDev 6.0 Standard Edition
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual SourceSafe 6.0 Standard Edition
Palavras-chave: 
kbmt kbprb KB250343 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 250343  (http://support.microsoft.com/kb/250343/en-us/ )